Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (85,470 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

  • 0
Rockstar Toronto

How to use -memrestrict to fix stuttering

Question

Rockstar Toronto

If you are experiencing frame speed fluctuations, please update to the latest video drivers, then use the -memrestrict commandline. Please do not use any other commandlines as they may override the effects of this one. Start at the lowest number based on your texture setting (ie. try them one at a time) You can try to increase the number until you notice stuttering again.

 

-memrestrict 188743680 LOW TEXTURES (256M Video Cards)

-memrestrict 209715200

-memrestrict 230686720

-memrestrict 262144000 MED TEXTURES (512M Video Cards)

-memrestrict 293601280

-memrestrict 314572800

-memrestrict 629145600 HIGH TEXTURES (1Gig+ Video Cards)

-memrestrict 650117120

-memrestrict 681574400

 

If you still notice stuttering with the lowest number, there may be a seperate issue with your system configuration.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
Tunning

Hello

 

Finaly today i get a Commandline that i can run my Game!!

 

It's the -memrestrict 188743680

 

Finaly no Frezee...But! I got so low Frame Rate!

 

At same place with the same save ,at same time of the game with -memrestrict 188743680 i get 30 Frame Rate ,Without -memrestrict 188743680 i get 65!! ,It's a big change!

 

But the game Freeze after 5 minutes of play

 

If i use Everything on LOW SETTING's yes i say EVERYTHING on low and 1 it hapens too

 

Windows XP SP3

 

Intel Core 2 Duo 8500 3.16GHZ

Asus ATI4850 1GB

2x 1GB OCZ DDR3 1600MHZ EACH = 2GB

Realtek Sound

 

Please help...

 

I have instaled my game again like 3 times and the problem still!

 

No problems on Patch 1 and Patch 2 !

 

My Game is Original ! I buy it in Portugal for 50 Euro

 

Help me Rockstar ,i want to play!

Share this post


Link to post
Share on other sites
  • 0
dom96

Thanks a lot Rockstar, this fix really helped me, here is my system specs and which one i used(maybe this info will help you's in some way)

My specs:

ATI Radeon 4670 512MB

AMD Phenom Quad Core 2.41Ghz

2GB Ram

Windows XP SP3

Driver version used: 9.4

Command line used:

-memrestrict 209715200

 

Thanks a lot for this fix and for this great game, the only issue that i have now is the weird grey things showing up but at least now i can play multiplayer.

I hope you's release Lost And Damned on the PC

Share this post


Link to post
Share on other sites
  • 0
BorisSF2
If you are experiencing frame speed fluctuations, please update to the latest video drivers, then use the -memrestrict commandline. Please do not use any other commandlines as they may override the effects of this one. Start at the lowest number based on your texture setting (ie. try them one at a time) You can try to increase the number until you notice stuttering again.

 

-memrestrict 188743680 LOW TEXTURES (256M Video Cards)

-memrestrict 209715200

-memrestrict 230686720

-memrestrict 262144000 MED TEXTURES (512M Video Cards)

-memrestrict 293601280

-memrestrict 314572800

-memrestrict 629145600 HIGH TEXTURES (1Gig+ Video Cards)

-memrestrict 650117120

-memrestrict 681574400

 

If you still notice stuttering with the lowest number, there may be a seperate issue with your system configuration.

http://www.gtaforums.com/index.php?showtopic=412021

 

I tried the lowest settings and it didn't work confused.gif

Share this post


Link to post
Share on other sites
  • 0
truehighroller

It is a joke man. R* put it here just to laugh at us poor saps some more that is all.

Share this post


Link to post
Share on other sites
  • 0
Flitskikker

I have a 512 MB Video Card, but I want Low textures (because it doesn't meet the Minimun Requirements sigh.gif ). Should I then choose the first one?

 

Regards,

Flitskikker

Share this post


Link to post
Share on other sites
  • 0
cuvip

i have 512mb card but i used the 256 setting, it works,mother hell!!!!!!!!Thank you R* inlove.gifinlove.gifinlove.gifinlove.gifinlove.gifinlove.gif

Share this post


Link to post
Share on other sites
  • 0
sammclean23

this fix works a dream

Share this post


Link to post
Share on other sites
  • 0
shir007j

what exactly i should write in this file?And what exactly should be the name of this file

Share this post


Link to post
Share on other sites
  • 0
Girish
what exactly i should write in this file?And what exactly should be the name of this file

The name of the file should be 'commandline.txt'. Open up Notepad, and copy past the memrestrict command mentioned in the first post of this topic that corresponds to the display setting that you use in-game. Then save the file in your main GTA IV directory.

Share this post


Link to post
Share on other sites
  • 0
Sal_niko

whatever anyone says, GTA IV works better than the stutter king - Saints Row 2.

Rockstar has emphasised on quality ( icon14.gif ) but I'd just like to say that Rockstar still needs to look over the difficulties of Dual core systems. Come on now, not everyone has a quad.

confused.gif

 

Share this post


Link to post
Share on other sites
  • 0
Sventilator

Ok I found out something weird... I've tried really every trick I can find on this forum to fix the stutter.. the -memrestrict trick helps a little but still it's not perfect.. my framerate doesn't drop under 30 but it isn't smooth..

 

But occasionally when I exit the benchmark I have a bug that the camera doesn't auto center behind the character when you walk or drive, I can fix it by restarting the game or reload a game sometimes also works...

 

But...!! when I keep playing like this and adjust the camera with the right stick while moving (I play with xbox for windows controller) the game is absolutly smooth!!! no stutter at all!!

 

Could it be that it isn't a memory problem at all that causes the stuttering? But maybe something with the camera fix that came with a patch? And maybe really easy to fix?

Share this post


Link to post
Share on other sites
  • 0
Yidakee

I get the stutters, tried everything to no avail.

 

64bit support my ASS ! (nvidia 9600m gt here)

 

Downloaded win 7 rc1 64bit just for the sake of this (vs 32bit) and there is NO comparison. 32bit outperforms by miles.

 

Updated, troubleshot everything, commandline.txt, drivers etc. .. (except one or two candidates)

did the contig.exe defrag trick, physix versions, DOX tweaked, windows 7 whql, cacheboost

 

ARG!!

 

No matter what quality settings I try, fps is always around 20-30 (5 stars etc vs stroling around) which makes me conclude that there is no driver/Setup issue.

 

Its a R* portability oversight somewhere.

 

Now whta HAS worked for me is, when I get the stutters (5-10 fps going down...) is try to end the mission if its a drive back or something else simple (which is a PAIN at +/- 7 fps) and press ESQ, go to game as if I were going to quit, wait 5-10 secs until the mouse is well responsive again, and go back into the game.

 

So far tried it like 5 times, hours of no stuttered gameplay. Cannot do that im MP.

 

I bought this 95% because of MP mode, and what utter crap it is.

 

R*, you deserve to be.... icon13.gificon13.gificon13.gificon13.gificon13.gificon13.gificon13.gificon13.gificon13.gificon13.gificon13.gificon13.gificon13.gificon13.gificon13.gificon13.gificon13.gificon13.gif

 

I am a poor guy and this is the FIRST game I've bought in many many years, and damn HOW I regret it.

Share this post


Link to post
Share on other sites
  • 0
raadden

... My other topic was locked for some reason.. i DONT have stuttering... but was sent to this topic.

 

My system is a fairly new medion with 3gb ram duo2 core intel cpu and a geforce 8600,

the roads sometimes dont get drawed, but other than that its all good no stuttering no fps problems..

 

Ive done the ultimate graphics tweak (picked the one with no blur, but with depth of field.)

 

Running in 1024*768 with well over 40fps

 

edit: reinstalled game and removed/reinstalled latest nvidia fixed it.

Edited by raadden

Share this post


Link to post
Share on other sites
  • 0
T.A.Z

i have, well some kind of problem biggrin.gif i have a sapphire hd 4890 1gb 4 gb RAM q6600 quadcore and i only get 20-25 fps with all settings at medium.i hope someone can help me out because i really dont know what to do.rockstar torronto, make me happy biggrin.gifbiggrin.gif .greetings from germany, and i am still loving rockstar games.(and yes, i have the lates drivers for every hardware part on my pc)

Share this post


Link to post
Share on other sites
  • 0
ExistHaunebu

Yeah i am running nearly the same system!!

 

After Patch 4 the Game is stuttering like hell an i am really sick of it.

 

I am running Core2Quad Q6600, 8GB RAM, Sapphire HD4890 1GB (925mhz!!!!!!), all drivers are up to date.

 

editing commandline with -memrestrict is not working. So i lost like 5 hours yesterday for all that installig and searching for solutions.

 

I am very angry about Rockstar again, anticheat is ok for me, because i am sick of missusing mods in this game.

 

But this patch 4 makes the game unplayable for me - one more time!

 

I paid money for this Game Rockstar, why are u making so much trouble to me. Its only GTA4 - Even ARMA2 is running well here!!!!!!! angry.gif

Share this post


Link to post
Share on other sites
  • 0
n11lc2

Can anyone tell me a setting between 314572800 and 629145600(1GB+)???

 

At 314572800 the stuttering is gone, but i get popup. At 629145600 the stuttering is present.

Share this post


Link to post
Share on other sites
  • 0
zBobG

Try this:

 

((b - a) / 2) + a

 

((629145600 - 314572800) / 2) + 314572800 = 471859200

 

Or, done in steps:

(629145600 - 314572800) = 314572800

 

(314572800 / 2) = 157286400

 

157286400 + 314572800 = 471859200 <--- equals halfway between a and b

 

Interestingly, this is roughly one half Gb (512Mb).

Share this post


Link to post
Share on other sites
  • 0
T.A.Z

ok i tested everything, commandline tricks, windowed mode different drivers etc... but nothing helped me out.i get the same fps with everything on high-max as on everything on lowest.my hardware is definatly not the problem, so if anyone could help me, i would aprreciate it, but i am slowly giving up on gta 4 suicidal.gifcryani.gif

Share this post


Link to post
Share on other sites
  • 0
Hunter9210

T.A.Z. ,we are 2 now with this problem,i have done a lot of things and i still get resc10 error,and game stuttering

Share this post


Link to post
Share on other sites
  • 0
debojitk

Hi all,

The only solution for nividia cards:

INStall forceware 181.22.

Yesterday i installed 181.20, even in that the stuttering is swept away.

My system

-------------

c2q 8200 @ 2.66

ddr2 3gb @800

evga 8600gt 1gb ddr2

avg framerate 20-25 on 800x600

 

1 question: how to turn the shadow off, the shadow is very crappy pixel-pixel type, and i find no such significant difference in high quality also

Can i have any option to enable antialiasing, as the lines are too bad in low resolution.

is there any hack to turn off env effects like fog/mist/smoke/shadow etc.

is there any shader editor, so that i can do these things???

 

Please reply

Thanks in advance

Edited by debojitk

Share this post


Link to post
Share on other sites
  • 0
debojitk
... My other topic was locked for some reason.. i DONT have stuttering... but was sent to this topic.

 

My system is a fairly new medion with 3gb ram duo2 core intel cpu and a geforce 8600,

the roads sometimes dont get drawed, but other than that its all good no stuttering no fps problems..

 

Ive done the ultimate graphics tweak (picked the one with no blur, but with depth of field.)

 

Running in 1024*768 with well over 40fps

 

edit: reinstalled game and removed/reinstalled latest nvidia fixed it.

Hi raadden,

i also have evga 8600gt+core 2 quad Q8200+3gb ram

Even in 800X600 i have never got more that 30(some times <10) fps in gta 4.

Can u tell me the driver version+what the ultimate tweak u have done, 40 fps with 1024x768 is amazing with core 2 duo

 

Share this post


Link to post
Share on other sites
  • 0
phandrew

Does anyone know how to bypass the GPU memory limit? I got a 320mb 8800GTS and i want higher graphic settings.

Share this post


Link to post
Share on other sites
  • 0
debojitk

 

Does anyone know how to bypass the GPU memory limit? I got a 320mb 8800GTS and i want higher graphic settings.

write the following commandline options in commandline.txt file and put the file in gta 4 main folder.

-nomemrestrict -availablevidmem 2.0 -norestrictions -percentvidmem 100

It Works...

Share this post


Link to post
Share on other sites
  • 0
tomoliop

It helps, but I ended using that lowest number for 256M cards, having 512M card... Tough stuttering occurs rarely now game still crashes or hangs computer really often.

Edited by tomoliop

Share this post


Link to post
Share on other sites
  • 0
Saddy
I am getting a stuttering/frame drop issue similar to what is described here, but ONLY when it rains in game. Before anyone suggests that I try changing texture/reflection/shadow quality, I've experimented with ALL of these options and the memrestrict command described in this post, AND updated my video drivers to the latest release, but the problem persists even with everything at minimum values. It's unfortunate that this has happened with the patch, as with the previous two versions I was getting perfectly smooth performance on high quality even during the worst of thunderstorms. Now, I'm forced to use a bed or garage to advance time to the point where it's not raining any longer, as the erratic frame drops make it unplayable. The weirdest part by far is, like I said, this ONLY occurs when it's raining. I've gone so far as to create test games where the weather is only allowed to be certain conditions, and everything else runs smoothly except for rain. If anyone else on this board, or Rockstar, has any insight for me, I will gladly try anything suggested.

 

Thanks.

 

EDIT: Sorry, forgot to include information that could be helpful.

 

OS: XP Pro SP3, 4GB RAM

Video Card: GTX 260

GTA Version: Steam, 1.0.3.0

Please use Systweaks cachebooster It will definitely cure shuttering problem and dont use -memrestrict or and other command line. I am playing it without these n not getting any shuttering issues Also update your graphics card driver. IN task manger set priority of gta 4 to High. I hope these works for u too

Share this post


Link to post
Share on other sites
  • 0
Saddy
I am getting a stuttering/frame drop issue similar to what is described here, but ONLY when it rains in game. Before anyone suggests that I try changing texture/reflection/shadow quality, I've experimented with ALL of these options and the memrestrict command described in this post, AND updated my video drivers to the latest release, but the problem persists even with everything at minimum values. It's unfortunate that this has happened with the patch, as with the previous two versions I was getting perfectly smooth performance on high quality even during the worst of thunderstorms. Now, I'm forced to use a bed or garage to advance time to the point where it's not raining any longer, as the erratic frame drops make it unplayable. The weirdest part by far is, like I said, this ONLY occurs when it's raining. I've gone so far as to create test games where the weather is only allowed to be certain conditions, and everything else runs smoothly except for rain. If anyone else on this board, or Rockstar, has any insight for me, I will gladly try anything suggested.

 

Thanks.

 

EDIT: Sorry, forgot to include information that could be helpful.

 

OS: XP Pro SP3, 4GB RAM

Video Card: GTX 260

GTA Version: Steam, 1.0.3.0

Please use Systweaks cachebooster It will definitely cure shuttering problem and dont use -memrestrict or and other command line. I am playing it without these n not getting any shuttering issues Also update your graphics card driver. IN task manger set priority of gta 4 to High. I hope these works for u too

Share this post


Link to post
Share on other sites
  • 0
Dag123

Where exactly do I need to write these codes in? I am a complete noob and I don't understand which file I have to write this command in.

Share this post


Link to post
Share on other sites
  • 0
madddogg1337

hey guys, I'm still having stuttering, crashes and hangs. even with those commands! Since my gfx card is pretty new, can't use 181.22.

 

Please help

 

GTA IV 1.0.2

Nvidia 185.86

C2Q Q9550 2.83ghz

GTS 250 1GB

4GB DDR2-800 RAM

Windows XP SP3 w/ .NET 3.5 SP1

Share this post


Link to post
Share on other sites
  • 0
zBobG

I don't think the 181.22 driver will solve all your problems. The GTS250 is just an updated 9800 GTX so the 181.22 driver should run without difficulty - if you can get it installed.

 

You can try a modified nv4_disp.inf file with your GTS250 info added to it. The 181.22 driver may still fail to install or run because the driver may still check the hardware for compatibility. But it's worth a try.

 

Steps:

1. Install (yes it will fail) or otherwise extract the 181.22 driver files. Keep the driver files on your harddisk.

 

2. In the folder that the driver files were extracted to, find the nv4_disp.inf file.

 

3. Open that file with Notepad (or any plain text editor). Find the two places where the added GTS250 ID should go (detailed below). Add the GTS250 info and save the file.

 

4. Run the 181.22 installer from the folder by running the setup.exe file.

 

Where to put the GTS250 info in the nv4_disp.inf file:

 

The GTS250 has a device ID number of 0615. In the v181.22 .inf file you will find these lines:

 

%NVIDIA_G92.DEV_0610.1%  = nv4_G9x,                  PCI\VEN_10DE&DEV_0610%NVIDIA_G92.DEV_0611.1%  = nv4_G9x,                  PCI\VEN_10DE&DEV_0611%NVIDIA_G92.DEV_0612.1%  = nv4_G9x,                  PCI\VEN_10DE&DEV_0612%NVIDIA_G92.DEV_0613.1%  = nv4_G9x,                  PCI\VEN_10DE&DEV_0613%NVIDIA_G92.DEV_0614.1%  = nv4_G9x,                  PCI\VEN_10DE&DEV_0614

 

Add this line after the 0614 line (note the two instances of 0615 in this line):

 

%NVIDIA_G92.DEV_0615.1%  = nv4_G9x,                  PCI\VEN_10DE&DEV_0615

 

For the second entry find these lines:

 

NVIDIA_G92.DEV_0610.1  = "NVIDIA GeForce 9600 GSO"NVIDIA_G92.DEV_0611.1  = "NVIDIA GeForce 8800 GT "NVIDIA_G92.DEV_0612.1  = "NVIDIA GeForce 9800 GTX/9800 GTX+"NVIDIA_G92.DEV_0613.1  = "NVIDIA GeForce 9800 GTX+"NVIDIA_G92.DEV_0614.1  = "NVIDIA GeForce 9800 GT  "

 

Add this line after the 0614 line:

 

NVIDIA_G92.DEV_0615.1  = "NVIDIA GeForce GTS 250  "

 

Note that there are 2 spaces at the end of the card name before the close quote. Those 2 spaces may or may not be necessary.

 

These instructions have been for XP, the files and method for Vista should be similar. In any case you only need to know your device ID and add it to any driver .inf file to enable that driver to install your device. Note that successfully installing the driver does not guarantee that the driver will work properly with a particular device.

Edited by zBobG

Share this post


Link to post
Share on other sites
  • 0
Dag123

Guys I still can't figure out where to write this command in. Help please dontgetit.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.