Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (85,236 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

  • 0
Rockstar Toronto

How to use -memrestrict to fix stuttering

Question

Rockstar Toronto

If you are experiencing frame speed fluctuations, please update to the latest video drivers, then use the -memrestrict commandline. Please do not use any other commandlines as they may override the effects of this one. Start at the lowest number based on your texture setting (ie. try them one at a time) You can try to increase the number until you notice stuttering again.

 

-memrestrict 188743680 LOW TEXTURES (256M Video Cards)

-memrestrict 209715200

-memrestrict 230686720

-memrestrict 262144000 MED TEXTURES (512M Video Cards)

-memrestrict 293601280

-memrestrict 314572800

-memrestrict 629145600 HIGH TEXTURES (1Gig+ Video Cards)

-memrestrict 650117120

-memrestrict 681574400

 

If you still notice stuttering with the lowest number, there may be a seperate issue with your system configuration.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
Pacal17

Solved my problem. Thanks!

Share this post


Link to post
Share on other sites
  • 0
Pacal17
Solved my problem. Thanks!

Well, looks like it didn't. I have a huge FPS drop after an hour of playing.

My PC specs:

 

Win 7 64bit

AMD Phenom II X4 965 @3,4Ghz

4GB DDR3 RAM

Sapphire HD5830 1GB

 

I've tryed -memrestrict 629145600, 650117120, 681574400 but non of them seems to help.

 

(Becouse of the 1GB card, the 629145600 value should work, but it dosen't)

 

Any help?

 

Share this post


Link to post
Share on other sites
  • 0
mkey82

memrestrict may or may not work, there is guarantee.

Share this post


Link to post
Share on other sites
  • 0
marklebbink

i have a problem with gta EFLC.

all my graphic settings are on low, and i cant make them better.

that is weird because i have perfectly good pc specs:

 

intelcore i7 2ghz, turbo boost up to 2.9ghz

 

nvidia geforce GT540M 2gig

 

4 gig RAM mem

 

can anybody help me?

 

 

 

 

Share this post


Link to post
Share on other sites
  • 0
mkey82

You should make sure you have the latest GPU drivers installed.

Share this post


Link to post
Share on other sites
  • 0
el_dani1803

Hello, my specs:

Asus M4A88TD-V-EVO/USB 3.0

AMD Phenom II x6 1100T

Kingston 8 gb ram ddr3 1600 mhz

XFX Radeon HD 6850 1GB DDR5

Windows 7 Home Premium 64-bit

 

The stuttering problem is that I have in the game, all the commands probe memrestric 1GB card and I could fix nothing.Someone help me solve my problem?, Not GTA IV might not run well on this pc.

I have the game patched to 1.0.7.0

Edited by el_dani1803

Share this post


Link to post
Share on other sites
  • 0
el_dani1803

I do not understand what each command, could help to use them correctly?

 

Edited by el_dani1803

Share this post


Link to post
Share on other sites
  • 0
mkey82

I can not explain it in any more detail then it's explained there.

Share this post


Link to post
Share on other sites
  • 0
el_dani1803

Sorry to bother you, but do not quite understand what I was saying in the post, in your case, if you had my specs what options you prove my system?

Share this post


Link to post
Share on other sites
  • 0
el_dani1803

I just uninstall the GTA IV to start a new, to begin what patch you recommend?, 1.0.4.0 or 1.0.7.0?, And if you like me to help me create a commandline according to my specifications, thanks and sorry to bother you.

Share this post


Link to post
Share on other sites
  • 0
mkey82

Patch 4 offers better performance.

 

Try using

 

 

-memrestrict 838860800

 

Share this post


Link to post
Share on other sites
  • 0
NoFieaR

ok i am facing the same problem. my commandline.txt looks like the following.

 

 

-refreshrate 31-framelimit 1 -memrestrict 262144000

 

 

The game runs ok. until the first cut scene. Then its back to square 1. But then it lags most of the time.

 

My system specs are the following. And yes i run on all the latest drivers.

 

Lenovo Y570

Processor

2nd generation Intel® Core™ i7-2630QM Processor ( 2.00GHz 1333MHz 6MB )

Graphics

NVIDIA GeForce GT 555M 1GB

RAM

8 GB PC3-8500 DDR3 SDRAM 1333MHz

 

 

And with the above specs i cant beleive that i cant even play the game on medium.

Share this post


Link to post
Share on other sites
  • 0
el_dani1803

 

ok i am facing the same problem. my commandline.txt looks like the following.

 

 

-refreshrate 31-framelimit 1 -memrestrict 262144000

 

 

The game runs ok. until the first cut scene. Then its back to square 1. But then it lags most of the time.

 

My system specs are the following. And yes i run on all the latest drivers.

 

Lenovo Y570

Processor

2nd generation Intel® Core™ i7-2630QM Processor ( 2.00GHz 1333MHz 6MB )

Graphics

NVIDIA GeForce GT 555M 1GB

RAM

8 GB PC3-8500 DDR3 SDRAM 1333MHz

 

 

And with the above specs i cant beleive that i cant even play the game on medium.

The only way that I go the stuttering with patch 1.0.7.0 was using option refreshrate 31 and framelimit 1, but I get black bars on the sides of the screen, someone has the solution?

Edited by el_dani1803

Share this post


Link to post
Share on other sites
  • 0
superwasi

my GTA IV runs too slow , help someone please...

 

my system specifications :

 

Intel Pentium 4 CPU 3.00 Ghz

 

3.02 Ghz

 

2 GB RAM DDR 2

 

NVIDIA GeForce 8400 GS

 

ASUS Motherboard

 

 

Share this post


Link to post
Share on other sites
  • 0
mkey82

That's a pretty slow PC for GTAIV, sadly. Especially if you're using Vista/7.

Share this post


Link to post
Share on other sites
  • 0
McGTA4

Hello!

I have Radeon Hd 6950 2 GB, what is parameter to me?

Share this post


Link to post
Share on other sites
  • 0
mkey82

You'll probably want to use the value for 1GB, something like 800*1021*1024=838860800

Share this post


Link to post
Share on other sites
  • 0
Vintage88

$300 CPU - Check

$430 GPU - Check

Properly functioning textures in a low-res game that's over 4 years old - Ex

Planning on buying a Rockstar title ever again - Ex

Share this post


Link to post
Share on other sites
  • 0
mkey82

The game is actually about 8 years old as it's been in the development process for a while, it all started in 2004.

Share this post


Link to post
Share on other sites
  • 0
Vintage88

Well the issue is most likely that it's a port. I'm not just talking texture glitches now, this game has more glitches than 19/20 games I've played on PC. I'm surprised because they had the resources of a full studio to make this work. Such an epic fail, lol.

Share this post


Link to post
Share on other sites
  • 0
mkey82

It was a massive and expensive project aimed at three completely different platforms. The simple truth is - the game is graphically unimpressive and it's runs like crap on all platforms. Had they ported to PC the stripped down console version of the game, it would have probably ran better on more gamer PCs, but it would look like crap. You win some, you lose some.

Share this post


Link to post
Share on other sites
  • 0
Vintage88

Have you heard of the SMAA injector? That + VisualIV actually does make the game look modern without crapping it out even worse like ENB does. Its still funny to me though how the dev's claim these higher settings are made for "future hardware" yet "future hardware" for the most part can't even load the textures up right xDD.

 

All that said I still play GTA IV PC more than all my other games. Love-hate relationship right here for most of us I think.

 

Thx for all the help you're giving in this thread btw, glad to see someone cares still.

Edited by Vintage88

Share this post


Link to post
Share on other sites
  • 0
mkey82

Well, I liked how the environment mod made the game look and play, it even enhanced performance as you mostly had sunny weather instead of that goddamn resource hungry fog. However, due to poor character selection and storyline faults, I never really enjoyed GTAIV. I found TBOGT and even TLAD storylines a lot more compelling and down to the point, which only makes my belief about the original GTAIV game being carved up into smaller, incomplete parts as to make it addon compatible and even more profitable stronger.

 

It's not that I care that much, I just can't believe a company as large as R* doesn't have any intention to address their damned customers in a honest and official manner, providing them support for broken games they publish on regular basis. In return they get treated as the best thing since toothpaste, that's fanboys for ya.

Share this post


Link to post
Share on other sites
  • 0
Vintage88

And on the 7th day, God did not rest, for he created Razor1911 icon14.gif

 

A lesson for the future I suppose.

Share this post


Link to post
Share on other sites
  • 0
mkey82

Piracy is not an answer to anything.

Share this post


Link to post
Share on other sites
  • 0
TheCoperz

My game is extremely choppy so i did one of them benchmark things

Happens as soon as it finishes loading a game, i have latest version and patch of the game

retail version

 

Statistics

Average FPS: 7.29

Duration: 37.87 sec

CPU Usage: 38%

System memory usage: 64%

Video memory usage: 49%

 

Graphics Settings

Video Mode: 1920 x 1080 (60 Hz)

Texture Quality: High

Shadow Quality: High

Reflection Resolution: High

Water Quality: Very High

Texture Filter Quality: Anisotropic x4

Night Shadows: Off

View Distance: 25

Detail Distance: 31

 

Hardware

Microsoft Windows 7 Home Premium /64 bit

Service Pack 1

Video Adapter: ATI Radeon HD 5400 Series

Video Driver version: 8.17.10.1091

Audio Adapter: Speakers (Realtek High Definition Audio)

AMD Phenom II X4 965 Processor

 

i recently built this set up, im not into lots of games but figured i try gta on the pc, im almost certain the fps being 7 isnt good. In terms of the system do i have decent set up to run it??

If so should i then move to attempt one of these txt fixes?

 

edit: i have

4 gig ram ddr3 1333

graphics hd radeon 5400 series 1gig ddr3

processor: Phenom II X4 3.4ghz

Win 7 prem 64 bit

all drivers are up to date aswell

Edited by TheCoperz

Share this post


Link to post
Share on other sites
  • 0
mkey82

You'll have to lower the settings a lot, starting from the render resolution.

Share this post


Link to post
Share on other sites
  • 0
TheCoperz

Thank god i only paid $10 for the game jesus

Share this post


Link to post
Share on other sites
  • 0
mkey82

You should consider system requirements prior to making any gaming purchase.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.