Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
      4. Frontier Pursuits
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Diamond Casino & Resort
      2. DLC
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA 6

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

Please be aware that this is not a tutorial request forum! Use the appropriate topic for the effect.
2pacproducer2

[TuT] Adding cars to GTA SA

Recommended Posts

Cell Tennyson

Do we need to remove Hashes (#)??? if if anyrhing else i should activate by removing hash??

Share this post


Link to post
Share on other sites
fastman92

Do we need to remove Hashes (#)??? if if anyrhing else i should activate by removing hash??

Useless question.

Of course you need to remove hashes.....

And you need to enable handling.cfg patch = 1....

Share this post


Link to post
Share on other sites
Cell Tennyson

Ok but one time when i exit the vehicle a the game hanged but didn't crashed. What was that can you tell me.. Besides that do i need to enable something else.

 

Yeas i have enabled Handling.cfg patch to 1. Besides that any other thing you wond recommend enabling??

Share this post


Link to post
Share on other sites
fastman92

Ok but one time when i exit the vehicle a the game hanged but didn't crashed. What was that can you tell me.. Besides that do i need to enable something else.

 

Yeas i have enabled Handling.cfg patch to 1. Besides that any other thing you wond recommend enabling??

Show me your fastman92LimitAdjuster.log

Share this post


Link to post
Share on other sites
Cell Tennyson
Starting fastman92 limit adjuster 1.2Enabling handling.cfg limit adjuster.New limits:Number of standard lines = 211Number of bike lines = 13Number of flying lines = 24Number of boat lines = 12mod_HandlingManager = 0x2290048sizeof(tHandlingData_extended) = 0xFB---------------------------------------------Modified limit of IDE:cars section to 213Game closed

I believe this is my log. I only enable things relating to adding cars i did not change anything else..

 

Edit: Should i remove Sacky's SA limit adjuster?? i have that installed at the moment.

Edited by Cell Tennyson

Share this post


Link to post
Share on other sites
fastman92

 

Starting fastman92 limit adjuster 1.2Enabling handling.cfg limit adjuster.New limits:Number of standard lines = 211Number of bike lines = 13Number of flying lines = 24Number of boat lines = 12mod_HandlingManager = 0x2290048sizeof(tHandlingData_extended) = 0xFB---------------------------------------------Modified limit of IDE:cars section to 213Game closed
I believe this is my log. I only enable things relating to adding cars i did not change anything else..

 

Edit: Should i remove Sacky's SA limit adjuster?? i have that installed at the moment.

 

Sacky's SA limit adjuster is no longer neccessary.

Share this post


Link to post
Share on other sites
Cell Tennyson

 

Starting fastman92 limit adjuster 1.2Enabling handling.cfg limit adjuster.New limits:Number of standard lines = 211Number of bike lines = 13Number of flying lines = 24Number of boat lines = 12mod_HandlingManager = 0x2290048sizeof(tHandlingData_extended) = 0xFB---------------------------------------------Modified limit of IDE:cars section to 213Game closed
I believe this is my log. I only enable things relating to adding cars i did not change anything else..

 

Edit: Should i remove Sacky's SA limit adjuster?? i have that installed at the moment.

 

Sacky's SA limit adjuster is no longer neccessary.

 

 

Then i guess we require 3 tools.

 

1. Your LimitAdjuster1.2

2. Your Audio Loader1.1.

3 More vehicles Asi plugin By Alexander Blade.

 

Right??

Share this post


Link to post
Share on other sites
fastman92

 

 

 

Starting fastman92 limit adjuster 1.2Enabling handling.cfg limit adjuster.New limits:Number of standard lines = 211Number of bike lines = 13Number of flying lines = 24Number of boat lines = 12mod_HandlingManager = 0x2290048sizeof(tHandlingData_extended) = 0xFB---------------------------------------------Modified limit of IDE:cars section to 213Game closed
I believe this is my log. I only enable things relating to adding cars i did not change anything else..

 

Edit: Should i remove Sacky's SA limit adjuster?? i have that installed at the moment.

 

Sacky's SA limit adjuster is no longer neccessary.

 

Then i guess we require 3 tools.

 

1. Your LimitAdjuster1.2

2. Your Audio Loader1.1.

3 More vehicles Asi plugin By Alexander Blade.

 

Right??

 

MoreVehicles.asi is useless.

It hacks 'IDE: cars' limit.

Share this post


Link to post
Share on other sites
Cell Tennyson

Then should i remove the Morevehicles.asi also?? then it means we require just two tools. Your Audio loader and limitadjuster right??

Edited by Cell Tennyson

Share this post


Link to post
Share on other sites
funcut

Hello everyone!

Are there any car mods out there that doesn't require changing that handling and other files? Thing is, I know how to install them and everything, but some people just make cars go soo fast. I don't like that. I just want car mods that make my cars look different but without changing their handling, speed etc.

Share this post


Link to post
Share on other sites
Automan

Car mods SA-MP/MTA compatible. :)

Share this post


Link to post
Share on other sites
Nudg3r

Ok. I just added 4 cars. One of them is a cop car. The cop car spawns with a simple cleo script I made but won't spawn in traffic even though its in cargrp.dat. I gave it same handling, colors and sounds as copcarla but then sirens doesn't work.

 

Im not using the handling adder.

 

Any ideas why?

Share this post


Link to post
Share on other sites
fastman92

Ok. I just added 4 cars. One of them is a cop car. The cop car spawns with a simple cleo script I made but won't spawn in traffic even though its in cargrp.dat. I gave it same handling, colors and sounds as copcarla but then sirens doesn't work.

 

Im not using the handling adder.

 

Any ideas why?

Police car IDs have some features hardcoded in gta_sa.exe code.

Share this post


Link to post
Share on other sites
Matheusroque

im having a problem with handling adder, i added two cars, and the last added are stuck or explode or never spawn because is something wrong with my handling adder, im having problem with id 613, id 613 its my last added car with problems with the handling

 

 

[MAIN]
Count=1
[CAR_IDs]
613
[612]
index=11
fmass=7600,0
fTurnMass=6200,0
fDragMult=2,0
x=0,0
y=0,3
z=-0,1
nPercentSubmerged=75
fTractionMultiplier=0,75
fTractionLoss=0,85
fTractionBias=0,495
nNumberOfGears=5
fMaxVelocity=1,7308189
fEngineAcceleration=0,00552
fEngineInertia=250,0
nDriveType=R
nEngineType=P
fBrakeDeceleration=0,00192
fBrakeBias=0,53
bABS=0
fSteeringLock=35,0
fSuspensionForceLevel=0,8
fSuspensionDampingLevel=0,08
fSuspensionHighSpdComDamp=0,0
fSuspensionUpperLimit=0,28
fSuspensionLowerLimit=-0,191
fSuspensionBiasBetweenFrontAndRear=0,55
fSuspensionAntiDiveMultiplier=0,0
fSeatOffsetDistance=0,2
fCollisionDamageMultiplier=0,32
nMonetaryValue=25000
modelFlags=1073741824
handlingFlags=270532616
frontLight=0
rearLight=1
animGroup=0
[613]
index=11
fmass=1600,0
fTurnMass=4500,0
fDragMult=2,0
x=0,0
y=0,3
z=-0,15
nPercentSubmerged=75
fTractionMultiplier=0,75
fTractionLoss=0,85
fTractionBias=0,52
nNumberOfGears=5
fMaxVelocity=1,0333247
fEngineAcceleration=0,002
fEngineInertia=10,0
nDriveType=R
nEngineType=P
fBrakeDeceleration=0,004
fBrakeBias=0,53
bABS=0
fSteeringLock=35,0
fSuspensionForceLevel=1,1
fSuspensionDampingLevel=0,12
fSuspensionHighSpdComDamp=0,0
fSuspensionUpperLimit=0,28
fSuspensionLowerLimit=-0,17
fSuspensionBiasBetweenFrontAndRear=0,55
fSuspensionAntiDiveMultiplier=0,0
fSeatOffsetDistance=0,2
fCollisionDamageMultiplier=0,32
nMonetaryValue=25000
modelFlags=1073741824
handlingFlags=270532616
frontLight=0
rearLight=1
animGroup=0
can someone tell me what i did wrong ?

Share this post


Link to post
Share on other sites
Silent

can someone tell me what i did wrong ?

  • You used Handling Adder
Edited by Silent

Share this post


Link to post
Share on other sites
Matheusroque

Silent, look, i edited the count to 2 now my game is crashing when i load a saved game or try to start a new game

 

 

[MAIN]
Count=2
[CAR_IDs]
613
[612]
index=11
fmass=7600,0
fTurnMass=6200,0
fDragMult=2,0
x=0,0
y=0,3
z=-0,1
nPercentSubmerged=75
fTractionMultiplier=0,75
fTractionLoss=0,85
fTractionBias=0,495
nNumberOfGears=5
fMaxVelocity=1,2259999
fEngineAcceleration=0,00552
fEngineInertia=250,0
nDriveType=R
nEngineType=P
fBrakeDeceleration=0,00192
fBrakeBias=0,53
bABS=0
fSteeringLock=35,0
fSuspensionForceLevel=0,8
fSuspensionDampingLevel=0,08
fSuspensionHighSpdComDamp=0,0
fSuspensionUpperLimit=0,28
fSuspensionLowerLimit=-0,191
fSuspensionBiasBetweenFrontAndRear=0,55
fSuspensionAntiDiveMultiplier=0,0
fSeatOffsetDistance=0,2
fCollisionDamageMultiplier=0,32
nMonetaryValue=25000
modelFlags=1073741824
handlingFlags=270532616
frontLight=0
rearLight=1
animGroup=0
[613]
index=11
fmass=1600,0
fTurnMass=4500,0
fDragMult=2,0
x=0,0
y=0,3
z=-0,15
nPercentSubmerged=75
fTractionMultiplier=0,75
fTractionLoss=0,85
fTractionBias=0,52
nNumberOfGears=5
fMaxVelocity=1,0333247
fEngineAcceleration=0,002
fEngineInertia=10,0
nDriveType=R
nEngineType=P
fBrakeDeceleration=0,004
fBrakeBias=0,53
bABS=0
fSteeringLock=35,0
fSuspensionForceLevel=1,1
fSuspensionDampingLevel=0,12
fSuspensionHighSpdComDamp=0,0
fSuspensionUpperLimit=0,28
fSuspensionLowerLimit=-0,17
fSuspensionBiasBetweenFrontAndRear=0,55
fSuspensionAntiDiveMultiplier=0,0
fSeatOffsetDistance=0,2
fCollisionDamageMultiplier=0,32
nMonetaryValue=25000
modelFlags=1073741824
handlingFlags=270532616
frontLight=0
rearLight=1
animGroup=0

Share this post


Link to post
Share on other sites
Silent

You're still using Handling Adder. That's the first thing you do wrong.

Share this post


Link to post
Share on other sites
fastman92

Silent, look, i edited the count to 2 now my game is crashing when i load a saved game or try to start a new game

 

 

[MAIN]

Count=2

 

[CAR_IDs]

613

 

[612]

index=11

fmass=7600,0

fTurnMass=6200,0

fDragMult=2,0

x=0,0

y=0,3

z=-0,1

nPercentSubmerged=75

fTractionMultiplier=0,75

fTractionLoss=0,85

fTractionBias=0,495

nNumberOfGears=5

fMaxVelocity=1,2259999

fEngineAcceleration=0,00552

fEngineInertia=250,0

nDriveType=R

nEngineType=P

fBrakeDeceleration=0,00192

fBrakeBias=0,53

bABS=0

fSteeringLock=35,0

fSuspensionForceLevel=0,8

fSuspensionDampingLevel=0,08

fSuspensionHighSpdComDamp=0,0

fSuspensionUpperLimit=0,28

fSuspensionLowerLimit=-0,191

fSuspensionBiasBetweenFrontAndRear=0,55

fSuspensionAntiDiveMultiplier=0,0

fSeatOffsetDistance=0,2

fCollisionDamageMultiplier=0,32

nMonetaryValue=25000

modelFlags=1073741824

handlingFlags=270532616

frontLight=0

rearLight=1

animGroup=0

[613]

index=11

fmass=1600,0

fTurnMass=4500,0

fDragMult=2,0

x=0,0

y=0,3

z=-0,15

nPercentSubmerged=75

fTractionMultiplier=0,75

fTractionLoss=0,85

fTractionBias=0,52

nNumberOfGears=5

fMaxVelocity=1,0333247

fEngineAcceleration=0,002

fEngineInertia=10,0

nDriveType=R

nEngineType=P

fBrakeDeceleration=0,004

fBrakeBias=0,53

bABS=0

fSteeringLock=35,0

fSuspensionForceLevel=1,1

fSuspensionDampingLevel=0,12

fSuspensionHighSpdComDamp=0,0

fSuspensionUpperLimit=0,28

fSuspensionLowerLimit=-0,17

fSuspensionBiasBetweenFrontAndRear=0,55

fSuspensionAntiDiveMultiplier=0,0

fSeatOffsetDistance=0,2

fCollisionDamageMultiplier=0,32

nMonetaryValue=25000

modelFlags=1073741824

handlingFlags=270532616

frontLight=0

rearLight=1

animGroup=0

http://gtaforums.com/topic/399977-tut-adding-cars-to-gta-sa/?p=1066494534

Share this post


Link to post
Share on other sites
Matheusroque

but handling adder is needed, if i dont use handling adder, my vehicles will not spawn in the game, i tried to start the game without handling adder, but my vehicle never spawn, what to do now ?

Share this post


Link to post
Share on other sites
Matheusroque

fas

 

 

Silent, look, i edited the count to 2 now my game is crashing when i load a saved game or try to start a new game


[MAIN]
Count=2

[CAR_IDs]
613

[612]
index=11
fmass=7600,0
fTurnMass=6200,0
fDragMult=2,0
x=0,0
y=0,3
z=-0,1
nPercentSubmerged=75
fTractionMultiplier=0,75
fTractionLoss=0,85
fTractionBias=0,495
nNumberOfGears=5
fMaxVelocity=1,2259999
fEngineAcceleration=0,00552
fEngineInertia=250,0
nDriveType=R
nEngineType=P
fBrakeDeceleration=0,00192
fBrakeBias=0,53
bABS=0
fSteeringLock=35,0
fSuspensionForceLevel=0,8
fSuspensionDampingLevel=0,08
fSuspensionHighSpdComDamp=0,0
fSuspensionUpperLimit=0,28
fSuspensionLowerLimit=-0,191
fSuspensionBiasBetweenFrontAndRear=0,55
fSuspensionAntiDiveMultiplier=0,0
fSeatOffsetDistance=0,2
fCollisionDamageMultiplier=0,32
nMonetaryValue=25000
modelFlags=1073741824
handlingFlags=270532616
frontLight=0
rearLight=1
animGroup=0
[613]
index=11
fmass=1600,0
fTurnMass=4500,0
fDragMult=2,0
x=0,0
y=0,3
z=-0,15
nPercentSubmerged=75
fTractionMultiplier=0,75
fTractionLoss=0,85
fTractionBias=0,52
nNumberOfGears=5
fMaxVelocity=1,0333247
fEngineAcceleration=0,002
fEngineInertia=10,0
nDriveType=R
nEngineType=P
fBrakeDeceleration=0,004
fBrakeBias=0,53
bABS=0
fSteeringLock=35,0
fSuspensionForceLevel=1,1
fSuspensionDampingLevel=0,12
fSuspensionHighSpdComDamp=0,0
fSuspensionUpperLimit=0,28
fSuspensionLowerLimit=-0,17
fSuspensionBiasBetweenFrontAndRear=0,55
fSuspensionAntiDiveMultiplier=0,0
fSeatOffsetDistance=0,2
fCollisionDamageMultiplier=0,32
nMonetaryValue=25000
modelFlags=1073741824
handlingFlags=270532616
frontLight=0
rearLight=1
animGroup=0

http://gtaforums.com/topic/399977-tut-adding-cars-to-gta-sa/?p=1066494534

 

fast man, help me to fix this ?

Share this post


Link to post
Share on other sites
Silent

He's linked you to a solution.

Share this post


Link to post
Share on other sites
fastman92

@Matheusroque, I don't care if you can or can't add handling lines. I don't really want to spend my time trying to teach you how to read.

Share this post


Link to post
Share on other sites
Matheusroque

i added two handling line on my handling.cfg ,

 

POLICE_LA2 7600.0 6200.0 2.0 0.0 0.3 -0.1 75 0.75 0.85 0.495 5 335.0 69.0 250.0 R P 4.8 0.53 0 35.0 0.8 0.08 0.0 0.28 -0.191 0.55 0.0 0.2 0.24 25000 40000000 10200008 0 1 0

 

POLICE_SF2 1600.0 4500.0 2.0 0.0 0.3 -0.15 75 0.75 0.85 0.52 5 200.0 25.0 10.0 R P 10.0 0.53 0 35.0 1.1 0.12 0.0 0.28 -0.17 0.55 0.0 0.2 0.24 25000 40000000 10200008 0 1 0

 

my new vehicles dont work without handling adder, in vehicles ide, handlingID is correct, but my game is not loading the handling from handling.cfg, only from handling adder

 

 

612, copcar2, copcar2, car, POLICE_LA2, POLICAR, null, ignore, 10, 0, 0, -1, 0.7, 0.7,
-1
613, copcar1, copcar1, car, POLICE_SF2, POLICAR, null, ignore, 10, 0, 0, -1, 0.8, 0.8, -1
this is my new two cop cars line on vehicles.ide
Edited by Matheusroque

Share this post


Link to post
Share on other sites
Matheusroque

http://steamcommunity.com/id/953481219/screenshots/?appid=12120&sort=newestfirst&browsefilter=myfiles&view=imagewall

 

i take screenshots, this two first, are the new vehicles without handling adder, but when start game with handling adder, only the mustang works fine, but the other car dont work, it spawn stuck on the ground and auto destroy, i have screenshots of the two vehicles working fine, but both dont work together, the problem is on my handlingadder.ini, i did something wrong or handlingadder can add only one handling line

 

this is the first added new car

http://steamcommunity.com/sharedfiles/filedetails/?id=367953317

 

and this is the second added new car

http://steamcommunity.com/sharedfiles/filedetails/?id=370679597

 

but, both cars handling working at same time dont works

Edited by Matheusroque

Share this post


Link to post
Share on other sites
Silent

The guide seems straightforward enough, so the issue's probably on yout side, not configuring the limit adjuster properly.

 

 

and, STOP USING HANDLING ADDER.

Edited by Silent

Share this post


Link to post
Share on other sites
Matheusroque

but i need handling adder, without handling adder, my new cars dont work,

 

i use this sa limit adjuster

; See explanation of limits at the end of the file
[sALIMITS]
PtrNodeSingle = unlimited
PtrNodeDouble = unlimited
EntryInfoNode = unlimited
Peds = 700
PedIntelligence = 700
Vehicles = 650
Buildings = 15000
Objects = 3500
Dummys = 9500
ColModel = unlimited
Task = unlimited
Event = unlimited
PointRoute = unlimited
PatrolRoute = unlimited
NodeRoute = unlimited
TaskAllocator = unlimited
PedAttractors = unlimited
MatrixList = unlimited
OutsideWorldWaterBlocks = 500
AlphaEntityList = unlimited
VisibleEntityPtrs = unlimited
VisibleLodPtrs = unlimited
StreamingObjectInstancesList = 7500
AtomicModels = unlimited
DamageAtomicModels = unlimited
TimeModels = unlimited
ClumpModels = unlimited
VehicleModels = unlimited
PedModels = unlimited
WeaponModels = unlimited
i added more than 20 peds with this limit adjuster

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.