Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Arena War
      2. After Hours
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA Next

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

2pacproducer2

[TuT] Adding cars to GTA SA

Recommended Posts

ramanjatt

So what way?

Share this post


Link to post
Share on other sites
ramanjatt

So,if there is no way to add handling.

I request great modders : DKK2pac,fastman92,AlexanderBlade,silent to make a Handling adder tool that works!

Share this post


Link to post
Share on other sites
Neddo

I think it may be possible with new limit adjusters coming

Share this post


Link to post
Share on other sites
ramanjatt

What Tool?

Share this post


Link to post
Share on other sites
Neddo

They are WIP I think and I don't know when they'll be finished

Share this post


Link to post
Share on other sites
meineliebe

Umm....A guy before said that if we add the handling lines to the very bottom of the handling file, it won't crash.

 

Anyone who has done this? Or has any other method of adding handling lines?

 

I've been adding cars and their handling lines using this method. All was going great, every added car had it's own unique handling. Then around the 30th added handling line it all went wrong, all the previously added cars suddenly acted like the last handling line, even after specifying they should use handling lines from vanilla SA cars. And worse, I can no longer add any more cars without the game acting weird, like hearing an invisible motorbike in some roads or random cleo scripts being disabled. :panic:

Share this post


Link to post
Share on other sites
Silent

Even a single line added that way messes up bikes. Just DON'T do it as then you're making use of an undefined behaviour.

Edited by Silent

Share this post


Link to post
Share on other sites
MacGeek

Thx help a lot

Share this post


Link to post
Share on other sites
ramanjatt

Yeah thats right, I add Handling line at very bottom of HANDLING file,but it causes many bug like:When enter a PCJ600 it bome invisible AND EXIT IT CJ 's body vanished. :blink:
and SILENT,can you make a handling adder plugin!

Edited by ramanjatt

Share this post


Link to post
Share on other sites
rad19dym

This is not easy, man.

Be patient.

 

Edit: I have a theory about added handling.

For example, I want to add a motorcycle. His vehicles.ide is:

463, freeway, freeway, bike, FREEWAY, FREEWAY, bikeh, motorbike, 10, 0, 0, 23, 0.68, 0.68, -1

I replaced this:

612, motor1, motor1, bike, INFERNUS, FREEWAY, bikeh, motorbike, 10, 0, 0, 23, 0.68, 0.68, -1

In handling.cfg I replace Infernus handling, earlier copying original handling.

After it I convert original handling in Handling Line Converter (i don't have a link, sorry) and paste it to HandlingAdder.ini.

Then i have edited a sound, cargrp.dat line.

Edited by rad19dym

Share this post


Link to post
Share on other sites
ramanjatt

I Don't understand!

Share this post


Link to post
Share on other sites
Overflod XD
Hey guys discovered how to add new lines without the annoying bug handling, Well just try to add a new line (the one in your car) and put it before or after the end of angel and add your line example:

; ANGEL 800.0 1.2 2.2 1.5 0.0 0.15 0.0 103 1.2 0.86 0.52 4 190.0 45.0 5.0 RP 12.0 0.55 0 35.0 0.65 0.20 0.3 0.24 10000 0.09 -0.11 0.55 0.0 1002000 0 1 1

ADDER 1880.0 3600.0 1.8 0.0 0.0 -0.3 80 1.1 1.1 0.5 5 407.0 35.0 15.0 RP 30.0 0.5 1 35.0 1.0 5.0 0.0 0.1 -0.05 0.5 1.0 0.2 0.4 1000000 400003 C0002004 2 2 1

; the end and that these all :lol:

Share this post


Link to post
Share on other sites
ramanjatt

It does'nt work. I added HANDLING Line after ANGEL,It works but it many problems with bikes like: PCJ 600.

Share this post


Link to post
Share on other sites
Cap'nFlappyJaw

Sooooo I've got this error and I followed everything perfectly

GTA:SA Crashed, Debug Info Follows:
GTA Info:
Version: US 1.0
Last File Loaded: DATA\VEHICLES.IDE
Last Library Loaded:
Error: Unknown
Assembly Info:
Exception At Address: 0x004C678E
Exception Code: 0xc0000005 (EXCEPTION_ACCESS_VIOLATION)
Registers:
EAX: 0x00000000 EBX: 0x008E2C64
ECX: 0x00B478F4 EDX: 0x00000000
ESI: 0x00B478F4 EDI: 0xFFFFFFFF
EBP: 0xFFFFFFFF ESP: 0x0028FB28

 

 

Not sure what went wrong, but kind of annoying. I tried adding cars a few years back and i remember I kept getting errors like this so I just gave up completely. I was using this car as a test to see if I could actually get it to work (it's a 1985 Mazda RX7 GSL-SE I downloaded from GTAInsider) because I'm making alternative versions of some vehicles and would like to keep the originals in the game too (Like my Picador GT mod, or whatever it's called on GTAGarage by my old affiliate AdamtheClown). I add cars to GTA IV and I really want to add to SA lol

Share this post


Link to post
Share on other sites
fastman92

Sooooo I've got this error and I followed everything perfectly

 

 

GTA:SA Crashed, Debug Info Follows:

 

 

 

GTA Info:

 

 

 

Version: US 1.0

 

Last File Loaded: DATA\VEHICLES.IDE

 

Last Library Loaded:

 

Error: Unknown

 

 

 

Assembly Info:

 

 

 

Exception At Address: 0x004C678E

 

Exception Code: 0xc0000005 (EXCEPTION_ACCESS_VIOLATION)

 

 

 

Registers:

 

EAX: 0x00000000 EBX: 0x008E2C64

 

ECX: 0x00B478F4 EDX: 0x00000000

 

ESI: 0x00B478F4 EDI: 0xFFFFFFFF

 

EBP: 0xFFFFFFFF ESP: 0x0028FB28

 

Not sure what went wrong, but kind of annoying. I tried adding cars a few years back and i remember I kept getting errors like this so I just gave up completely. I was using this car as a test to see if I could actually get it to work (it's a 1985 Mazda RX7 GSL-SE I downloaded from GTAInsider) because I'm making alternative versions of some vehicles and would like to keep the originals in the game too (Like my Picador GT mod, or whatever it's called on GTAGarage by my old affiliate AdamtheClown). I add cars to GTA IV and I really want to add to SA lol

 

IDE: cars limit exceeded.

 

 

You didn't increase a limit of 'IDE: cars'. SA More Vehicles could do this.

Share this post


Link to post
Share on other sites
Cap'nFlappyJaw

I have everything that I needed, and I followed it step by step so I don't know how I could increase it

Share this post


Link to post
Share on other sites
fastman92

I have everything that I needed, and I followed it step by step so I don't know how I could increase it

What do you have?

 

No ASI loader?

 

Using SALA and limit of Vehicle Models is not increased?

Edited by fastman92

Share this post


Link to post
Share on other sites
Cap'nFlappyJaw

I tried it with an ASI loader, with CLEO, and with both and they don't seem to work.

Share this post


Link to post
Share on other sites
fastman92

I tried it with an ASI loader, with CLEO, and with both and they don't seem to work.

You're doing something inherently wrong. There's no other way.

 

I can't help you.

Edited by fastman92

Share this post


Link to post
Share on other sites
Cap'nFlappyJaw

Well, i restarted from scratch, but it crashes when i have the added car in carcols or carmods. if i remove the name from those two files the game runs fine, but all car horns are now bicycle horns and the cars have no engine sound. I think i'm just gonna give up haha

Share this post


Link to post
Share on other sites
Cell Tennyson

Hi there!!

 

I've followed this tutorial and i have successfully added a new car. But the only problem is the sounds are not correct. Some problems are:-

 

1. When i press horn (in any vehicle) a cycle horn blows.

2. When i drive the car (any vehicle) Player falling down the ground sound comes..

3. When i open vehicles door (any vehicle) the sound of opening a maverick door comes.

 

Why is this happening??

Share this post


Link to post
Share on other sites
Cell Tennyson

@Cell tennyson Maybe you using vehicle audio editor by alxender blade,which is not good tool.Try this one by Fastman92:

http://www.gtainside.com/en/download.php?do=detail&cat=124&start=736&id=38587&orderBy=

I added almost 20 new vehicles by using this tool and this tool is very useful and easy.Have fun!

Yes thank you for your advice now i am using Fastman92's Audio loader.. It working in fact everything is working now.. :)

 

I want to know about ID's it says :-

 

1-6,8,42,65,74,86,208,265-273,289,329,340 (???), 374-383, 398, 399, 612-614, 699, 793-799, 907-909, 965, 999, 1326, 1573, 1657-1659, 1661, 1699, 2883-2884, 3136-3166, 3179-3186, 3188-3192,3194-3213, 3222-3240, 3245, 3247, 3248, 3251, 3254, 3429, 3610-3611, 3784, 3870, 3871, 3889, 3974, 4542-4549, 4763-4805, 5010-5104, 5376-5389, 5683-5702, 6011-6034, 6258-6279, 6526-6862, 7206-7208, 7220-7222, 7226, 7230, 7278-7280, 7289-7290, 7331-7333, 7974-7977, 9194-9204, 9479-9481, 10311-10314, 10745-10749, 11418-11420, 11682-12799, 13563-13589, 13668-13671, 13891-14382, 14644-14649, 14658, 14659, 14729-14734, 14766-14769, 14904-15024, 15065-15999, 16791-16999, 18113-18199, 18631-1900õ

 

So will i be able to add a new car with Id 615?? as it is mentioned there 612-614. If not then which id should i use after 614? 699 and then 793-799 like that??

And the last range is from 18631 to how much 19000??

Edited by Cell Tennyson

Share this post


Link to post
Share on other sites
fastman92

 

@Cell tennyson Maybe you using vehicle audio editor by alxender blade,which is not good tool.Try this one by Fastman92:

http://www.gtainside.com/en/download.php?do=detail&cat=124&start=736&id=38587&orderBy=

I added almost 20 new vehicles by using this tool and this tool is very useful and easy.Have fun!

Yes thank you for your advice now i am using Fastman92's Audio loader.. It working in fact everything is working now.. :)

 

I want to know about ID's it says :-

 

1-6,8,42,65,74,86,208,265-273,289,329,340 (???), 374-383, 398, 399, 612-614, 699, 793-799, 907-909, 965, 999, 1326, 1573, 1657-1659, 1661, 1699, 2883-2884, 3136-3166, 3179-3186, 3188-3192,3194-3213, 3222-3240, 3245, 3247, 3248, 3251, 3254, 3429, 3610-3611, 3784, 3870, 3871, 3889, 3974, 4542-4549, 4763-4805, 5010-5104, 5376-5389, 5683-5702, 6011-6034, 6258-6279, 6526-6862, 7206-7208, 7220-7222, 7226, 7230, 7278-7280, 7289-7290, 7331-7333, 7974-7977, 9194-9204, 9479-9481, 10311-10314, 10745-10749, 11418-11420, 11682-12799, 13563-13589, 13668-13671, 13891-14382, 14644-14649, 14658, 14659, 14729-14734, 14766-14769, 14904-15024, 15065-15999, 16791-16999, 18113-18199, 18631-1900õ

 

So will i be able to add a new car with Id 615?? as it is mentioned there 612-614. If not then which id should i use after 614? 699 and then 793-799 like that??

And the last range is from 18631 to how much 19000??

 

Download Free IDs list generator.

Google it out.

Share this post


Link to post
Share on other sites
_RJSingh_

or just rename 611 to 18631 and so on.....18632,18633,18634,18635...........!

Share this post


Link to post
Share on other sites
Cell Tennyson

Ok but i have very old version of sascm.ini and opcodes are very old where can i get new opcodes latest ones for cleo??

Share this post


Link to post
Share on other sites
Cell Tennyson

Thanks Mr RJSanModder now everything is just fine.. :)

 

Edit: Can these newly added cars be defined in the main.scm??

Edited by Cell Tennyson

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.