Jump to content

[TuT] Adding cars to GTA SA


2pacproducer2

Recommended Posts

bahraini_carguy

my game worked fine but i can't find my new car sad.gif

(sultanrs) is my new car

 

 

majestic, tahoma                # Gang 1 (BALLAS - BLACK)sultanrs           # Gang 2 (FAMILIES - PLAYER - BLACK)oceanic, tornado, hermes                 # Gang 3 (LSV - MEX)sabre, stallion, blade                 # Gang 4 (SFR - MEX) buccanee, manana, tampa                  # Gang 5 (DNB - VIETS)sentinel, admiral, feltzer              # Gang 6 (ITALIAN MAFIA)sultan, stratum, elegy             # Gang 7 (TRIAD)hermes, broadway, glendale             # Gang 8 (VLA - MEX)

 

Link to comment
Share on other sites

Pls tell me...Lets say i want to add a police car, how do i made it such that in game it will be a police driven car (when i get wanted, police will be driving that car) and not a civilian car, without replacing the existing police car. Is this possible? is yes can i do it for army, swat, etc.?

Link to comment
Share on other sites

  • 2 months later...
1: I can add a plane with HYDRA functions?

 

Is that I tried to add another hydra, but it behaves like a normal plane. if substituted for the original HYDRA, yes it is working properly

ID of hydra is hard-coded in exe, it is unknown where is that adress with ID.

I`ll try to create a plugin to have many hydra planes as soon as my knowledge will be adequate.

 

About spawning cars - use my car spawner with ability of ranges configurable in ini file, http://www.gtagarage.com/mods/show.php?id=13763

You can spawn any added cars after adding range to ini file.

have you done this plugin now?

i really want to add some other planes like f22 ,f14... lol.gif

Link to comment
Share on other sites

  • 5 weeks later...

Sorry for no response for too long... i'll make detailed tutorial for those who want to add vehicles in GTA SA. To be included also the tools required and a vehicle as sample... maybe i'll post it on sunday... to all filipino fans of "GTA SA pasensya na po" smile.gif

Link to comment
Share on other sites

Sorry for no response for too long... i'll make detailed tutorial for those who want to add vehicles in GTA SA. To be included also the tools required and a vehicle as sample... maybe i'll post it on sunday... to all filipino fans of "GTA SA pasensya na po" smile.gif

Isn't this tuto detailed enough?

Link to comment
Share on other sites

  • 2 weeks later...

 

when the car destroys the game closes pls reply:-( pls help

 

Here too. Its happens with someone else?

Link to comment
Share on other sites

  • 1 month later...
  • 4 weeks later...
MeatSafeMurderer

-bump-

I spent a while looking through both the vehicles.ide and handling.cfg and have managed to pull 24 free handling lines by removing redundant/duplicate lines, you will find them in a new section called unused/mods just after planes. One thing to note is that now all three cop cars share a single line, so if you mod one, you may need to mod them all! One great example of duplicates is the monster trucks, they all used different handling lines...which were identical. These spare lines can now be used to add new vehicles with custom handling, no vehicles have been removed, and if you can tell any difference...then well done?... tounge.gif

 

Free Handling Lines.rar

Edited by MeatSafeMurderer
Link to comment
Share on other sites

  • 4 weeks later...

anyone know how to add planes, or hydra, helicopters or boats without problems?. I have no problems to add cars. But when I try to add a plane or a a heli, those only goes forward or backward like a car.

Edited by anthsalmo
Link to comment
Share on other sites

  • 2 months later...
it is not advisable to use Vehicle Audio Editor Ultimate, instead use vehicle audio hooked by NAuthority. No more bike horns and all sounds will work, this tool also may help others to setup a car with police radio, ANY CAR EITHER AIRPLANES OR FOR OTHER EXISTING VEHICLES.

for those who interested download this : http://www.mediafire.com/?95h6cbd1yln3gg6

20mb file, all tools you need are all there and this : http://www.gtainside.com/en/download.php?d...wnload&id=25690 handling line converter by alexander, latest tool and big help for adding new handling inside handling adder, how to use? just copy given handling then paste it in the tool and press convert, then copy conveted output lines and paste to your handlingadder.ini, just don't forget to change "." to "," in a converted handling, "." can't be read inside handlingadder.ini, with this tool it will solve also problems about SUBMERGED problems. Any question? just ask cool.gif

Can someone upload VehicleAudioHook.xml cuz i can't find it anywhere and on GTA i can't download it.

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...

Hi, I got everything to work, but the car wont go forwards. it will only let me go backwords, :blink: and when it does go back it goes very very slow :panic:

do you think i need to change anything in the handling line?

what should I do?

Link to comment
Share on other sites

  • 2 weeks later...

Hello,

I did everything as it's said in the tutorial and my game freezes after a short time. I assume it's because the added vehicle spawns. Can anyone please tell me where I made a mistake?

Link to comment
Share on other sites

Does this works? I'm wanting to add 2 more hydras in my game (with the same hydra functions) but I'm not sure if it does works.

Link to comment
Share on other sites

  • 4 weeks later...

my game worked fine but i can't find my new car sad.gif

(sultanrs) is my new car

 

CODE majestic, tahoma # Gang 1 (BALLAS - BLACK)

sultanrs # Gang 2 (FAMILIES - PLAYER - BLACK)

oceanic, tornado, hermes # Gang 3 (LSV - MEX)

sabre, stallion, blade # Gang 4 (SFR - MEX)

buccanee, manana, tampa # Gang 5 (DNB - VIETS)

sentinel, admiral, feltzer # Gang 6 (ITALIAN MAFIA)

sultan, stratum, elegy # Gang 7 (TRIAD)

hermes, broadway, glendale # Gang 8 (VLA - MEX)

 

Identical problem here. I tried making a CLEO script to spawn it, but it DIDN'T :cry:

Edited by Jeansowaty

"Let death take my enemies by surprise; let them go down alive to the grave, for evil finds lodging among them."

Link to comment
Share on other sites

I tried making a CLEO script to spawn it, but it DIDN'T

 

 

then post the content of these files:

1. HandlingAdder.ini

2. vehicles.ide

3. carcols.dat

4. handling.cfg

5. your cleoscript

Edited by ZAZ
Link to comment
Share on other sites

Here? Or PM?

"Let death take my enemies by surprise; let them go down alive to the grave, for evil finds lodging among them."

Link to comment
Share on other sites

  • 2 weeks later...

Hi ! I added several cars to my game thanks to your tut !

But now, i want to add a new police car which will spawn like other police cars.

But I checked cargrp.dat and there is no #POPCYCLE_GROUP_COPS like in GTA IV... I checked most of files, I searched on lots of website forums but I didn't find anything :/

 

Someone know where these data are stored?

 

Thanks for your reply :)

 

tonito1996

Edited by tonito1996
Link to comment
Share on other sites

Hi ! I added several cars to my game thanks to your tut !

But now, i want to add a new police car which will spawn like other police cars.

But I checked cargrp.dat and there is no #POPCYCLE_GROUP_COPS like in GTA IV... I checked most of files, I searched on lots of website forums but I didn't find anything :/

 

Someone know where these data are stored?

 

Thanks for your reply :)

 

tonito1996

Nowhere. It's hardcoded.

Link to comment
Share on other sites

Help! I followed every single step, but when i click "New Game" the game loads for a millisecond and then crashes, with this message:

XUGvMLa.png

My model names are stratus.dff and stratus.txd

Handling:

STRATUS 1800.0 4500.0 2.1 0.0 0.1 -0.1 75 0.60 0.85 0.5 5 200.0 20.0 10.0 R P 7.0 0.5 0 30.0 1.0 0.15 0.0 0.28 -0.16 0.5 0.3 0.25 0.60 35000 2800 4000000 1 1 0

(i placed it after "ROLLER" - is that okay?)

Vehicles.ide:

612, stratus, stratus, car, STRATUS, STRATUS, null, richfamily, 7, 0, 0, -1, 0.7, 0.7, 1

(placed after "611")

Edited by Helomyname
Link to comment
Share on other sites

Help! I followed every single step, but when i click "New Game" the game loads for a millisecond and then crashes, with this message:

XUGvMLa.png

My model names are stratus.dff and stratus.txd

Handling:

STRATUS 1800.0 4500.0 2.1 0.0 0.1 -0.1 75 0.60 0.85 0.5 5 200.0 20.0 10.0 R P 7.0 0.5 0 30.0 1.0 0.15 0.0 0.28 -0.16 0.5 0.3 0.25 0.60 35000 2800 4000000 1 1 0

(i placed it after "ROLLER" - is that okay?)

Vehicles.ide:

612, stratus, stratus, car, STRATUS, STRATUS, null, richfamily, 7, 0, 0, -1, 0.7, 0.7, 1

(placed after "611")

Did you put stratus.dff and stratus.txd in loaded IMG archive?

 

Remember not to add any new entry to handling.cfg - game won't handle it correctly.

There's a hardcoded array of known vehicle handling names and their IDs in game executable.

Edited by fastman92
Link to comment
Share on other sites

My mistake. I removed the handling from handling.cfg, and added it using the handlingadder.ini, but it still crashes. Exact same error message.

It says "last file loaded: DATA\VEHICLES.IDE", so i thought maybe it's something to do with that. But there's nothing wrong.

NINJA EDIT:

I removed the # in the limits thing, and the game launches. The cars display but they are in the ground, like this:

HBqWeNW.png

And when enter is pressed around them, the game crashes with this message:

kBDzjpV.png

NINJA EDIT #2:

 

ISSUE FIXED! It was a problem in vehicles.ide.

Instead of 612, stratus, stratus, car, STRATUS, STRATUS, null, richfamily, 7, 0, 0, -1, 0.7, 0.7, 1

I put this: 612, stratus, stratus, car, STRATUM, STRATUS, null, richfamily, 7, 0, 0, -1, 0.7, 0.7, 1

As you can see i changed that one line from STRATUS to STRATUM, and it works.

 

However, now i have a different problem. The car has no sound.

Edited by Helomyname
Link to comment
Share on other sites

So far I added one car and one helicopter. They work, but have no sound.

Also the game crashes whenever i leave LS.

Link to comment
Share on other sites

silentkiller44

I have added cars perfectly, without any bugs\freezes. Just use the handling line of an existing vehicle. For example:

Suppose you're adding a car with the .dff and .txd as mustang.dff and mustang.txd. Your vehicle line should be:

 

612, mustang, mustang, car, BUFFALO, MUSTANG, e.t.c, e.t.c.

 

This will fix the 'cars stuck in the road' problem.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.