Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTAForums Annual Awards 2018

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Arena War
      2. After Hours
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA Next

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

2pacproducer2

[TuT] Adding cars to GTA SA

Recommended Posts

jeruthedamaja

 

I added the "612" into the VehicleAudioData.ini file. How ever, now all my cars sound like bicycles. Really annoying. Any help with this?

This. please.

 

Tried replacing all commas with decimals in vehicleaudiodata.ini and it didn't work for me =/

 

 

Also is there a way to make those extra cars tunable in transfender? I've added the line in carmods.dat and still can't enter transfender

Share this post


Link to post
Share on other sites
Fatalpipe
I added the "612" into the VehicleAudioData.ini file. How ever, now all my cars sound like bicycles. Really annoying. Any help with this?

This. please.

 

Tried replacing all commas with decimals in vehicleaudiodata.ini and it didn't work for me =/

 

 

Also is there a way to make those extra cars tunable in transfender? I've added the line in carmods.dat and still can't enter transfender

Don't use VehicleAudioEditorUltimate ,you have to use VehicleAudioHook and everything will run fine with sounds.

About Transfender,just dont use HandlingAdder too,just put your handling lines at the very bottom of handling.cfg ,just after >> ;the end << .

Share this post


Link to post
Share on other sites
jeruthedamaja

Thanks, that worked fine. Dunno why OP made it sound like that handlingadder thing was necessary =]

 

Now about paintjobs, I'm having the same problem but with another random texture, not from bandblack.txd. And the paintjobs are messed up for every car, including all the default ID's and files i didn't even touch.. dontgetit.gif

Share this post


Link to post
Share on other sites
EpicDeth

I've also noticed this custom paintjob issue. Oddly enough, Paintjobs always work just fine for replaced cars, but it would seem that the game doesn't recognize/read the extra txd files of added cars.

 

@Jeru: I've never experienced an issue like that, so I'm not sure what exactly the problem is. I'd guess that you may have made a mistake while editing carmods.dat? Try restoring it to its original state (I hope you keep a clean GTA folder around, or manually backup files you change) and seeing if that fixes the paintjobs for defaults.

Share this post


Link to post
Share on other sites
1stresponse
ALL ADDED VEHICLES IN-GAME CAN BE USE IN ANY MOD EVEN IN MISSIONS.  biggrin.gif  LIKE MY ADDED STRYKER, PENETRATES MYTHS, MONSTERS,OR TERRORIST

Well,so why can't I do the Taxi Missions when I'm driving a Taxi that was added in game by me?Press the button and nothing happens,same for Cop cars... Sadly,I was happy to have found this topic and modding SA to my son,but now things start to be limited...Random crashes is what I'm having.

I mean, you can use added vehicles as transport vehicle, get away ride during a mission, not for sub-missions, like ambulance, barracks, etc.

Share this post


Link to post
Share on other sites
1stresponse

And, until now, still others got engine sound errors or annoying bicycle horns, if you dont want to have errors like this then use the vehicle audio editor in my 20 mb file,..

Share this post


Link to post
Share on other sites
Markk

Well the game doesn't crash, that is a start!

 

The car doesn't show up when using a CLEO car spawner. It just goes to 611 then back to the landstalker. Does it have to do with me not using that audio plugin cause it completely messes up all vehicle sounds (the driving sound is a train, the horn is a bicycle bell). If I set that value to 0 at the top like the commentary says, I get an error in the asi.

 

Here are the lines I have:

 

Vehicles.ide (Focus on 612, the new car a.k.a a McLaren F1):

 

601,  swatvan,  swatvan,  car,  	SWATVAN,  SWATVAN,  van,  big,  	4,  0,	0,  -1,	1.366,	1.366,	-1602,	alpha,  alpha,  car,  	ALPHA,  ALPHA,  	null,  executive,  10,  0,	0,  -1,	0.7,	0.7,	0603,  phoenix,  phoenix,  car,  	PHOENIX,  PHOENIX,  null,  normal,  7,  0,	0,  -1,	0.7,	0.7,	0604,  glensh*t,  glensh*t,  car,  	GLENDALE,  GLENSHI,  null,  normal,  5,  0,	0,  -1,	0.7,	0.7,	-1605,	sadlsh*t,	sadlsh*t,	car,  	SADLER,  	SADLSHI,  null,  normal,  10,  0,	0,  -1,	0.7,	0.7,	-1606,  bagboxa,  bagboxa,  trailer,	BAGBOXA,  BAGBOXA,  null,  ignore,  	4,	0,	0,  -1,	0.6,	0.6,	-1607,  bagboxb,  bagboxb,  trailer,	BAGBOXB,  BAGBOXB,  null,  ignore,  	4,	0,	0,  -1,	0.6,	0.6,	-1608,  tugstair,  tugstair,  trailer,	STAIRS,  TUGSTAI,  null,  ignore,  	4,	0,	0,  -1,	0.6,	0.6,	-1609,  boxburg,  boxburg,  car,  	BOXBURG,	BOXBURG,  van,  worker,  10,  0,	0,  -1,	0.76,	0.76,	-1610,  farmtr1,  farmtr1,  trailer,	FARM_TR1,  FARMTR1,  null,  ignore,  	4,	0,	0,  -1,	0.32,	0.32,	-1611,  utiltr1,  utiltr1,  trailer,	UTIL_TR1,  UTILTR1,  null,  ignore,  	4,	0,	0,  -1,	0.68,	0.68,	-1612,  mcf1,  	mcf1,  	car,  	MCF1,  	MCF1,  	null,  executive,  3,  0,	0,  -1,	0.7,	0.7,	1end

 

 

Handling:

 

STAIRS    1000.0    2500.0   5.0    0.0 0.4 -0.2  70  1.00 0.85 0.5  	3 160.0 20.0 30.0 R E  5.0   0.50 0 30.0  	2.0  0.09  0.0   0.25 -0.10 0.5  0.0  0.26 0.50  9000  3100  4  	1  1	0BOXBURG      5500.0   23489.6   3.0    0.0 0.0  0.0  80  0.82 0.70 0.46  5 140.0 14.0 25.0 R D  4.5   0.60 0 30.0  	0.9  0.08  0.0   0.25 -0.25 0.35 0.6  0.36 0.40 22000  4009  201  	0  3	13FARM_TR1      400.0     400.0   5.0    0.0 -0.4 0.0  70  0.60 0.85 0.5  	3 160.0 20.0 30.0 R E  5.0   0.50 0 30.0  	1.0  0.10  0.0   0.25 -0.10 0.5  0.0  0.26 0.50  9000  3100  4  	1  1	0UTIL_TR1     1000.0    1354.2   5.0    0.0 0.0  0.0  70  1.00 0.85 0.5  	3 160.0 20.0 30.0 R E  5.0   0.50 0 30.0  	2.0  0.09  0.0   0.25 -0.10 0.5  0.0  0.26 0.50  9000  3100  4  	1  1	0ROLLER      1000.0    1354.2   4.0    0.0 0.0 -0.1  70  0.55 0.85 0.5  	3 160.0 15.0 30.0 4 E  13.0  0.50 0 30.0  	1.0  0.09  0.0   0.28 -0.13 0.5  0.0  0.26 0.50  9000  1100  8804  1  1	0;------- custom -------------------------------------;; A  B  C  D	F	G	H	I	J	K	L	M	N	O	P	Q	R	S	T	U	V      a	b	c	d	e	f	g  aa	ab	ac	af  ag	ah	ai	ajMCF1  2200.0  3398.3  0.85	0.0	0.07	-0.2	75	0.73	0.74	0.5	5	320.0	25.5	4.6	R	P	18.0	0.55	1	33.0  1.1	0.15	0.0	0.22	-0.10	0.5	0.35  0.25	0.45	363000  40112024	1044000	0	1	0;------- bikes -------------------------------------;; A  B  C  D	F	G	H	I	J	K	L	M	N	O	P	Q	R	S	T	U	V      a	b	c	d	e	f	g  aa	ab	ac	af  ag	ah	ai	ajBIKE  500.0  161.7  4.0	0.0	0.05	-0.09	103	1.6	0.9	0.48  5	190.0	50.0	5.0	R	P  15.0	0.50	0	35.0    0.85	0.15	0.0	0.15	-0.16	0.5	0.0  0.0	0.15	10000  1002000  0	1	1	4MOPED  350.0  160.0  5.0	0.0	0.0	-0.2	103	2.0	0.9	0.49	3	230.0	39.0	5.0	R	P	14.0	0.50	0	30.0  1.0	0.15	0.0	0.10	-0.07	0.5	0.0  0.1	0.001	10000	1000000  0	1	1	5

 

 

Carcols:

 

maverick, 0,0, 3,3, 50,50, 122,122, 53,53, 52,52, 44,44, 6,6mcf1,  20,1, 25,1, 36,1, 40,1 62,1, 75,1, 92,1, 0,1merit, 67,1, 72,1, 75,1, 83,1, 91,1, 101,1, 109,1, 20,1mesa, 75,84, 40,84, 40,110, 28,119, 25,119, 21,119, 13,119, 4,119

 

 

Carmods:

 

majestic, bntl_b_ov, bntl_b_sq, exh_b_l, exh_b_t, exh_b_ts, nto_b_l, nto_b_s, nto_b_tw, spl_b_bar_m, spl_b_bbb_m, spl_b_bbr_m, spl_b_mab_m, wg_l_b_sskmanana, exh_b_t, exh_b_m, exh_b_l, lgt_b_rspt, lgt_b_sspt, nto_b_l, nto_b_s, nto_b_tw, spl_b_bab_m, spl_b_bbb_m, spl_b_mab_m, wg_l_b_sskmcf1, nto_b_tw, spl_b_bab_m, spl_b_bbb_m, spl_b_mab_m, wg_l_b_ssk, spl_a_s_b, spl_c_s_b, spl_a_l_b, spl_c_l_b, spl_a_j_b, spl_c_j_bmerit, bnt_b_sc_l, exh_b_l, exh_b_m, exh_b_t, exh_b_ts, nto_b_l, nto_b_s, nto_b_tw, rf_b_sc_r, spl_b_bar_m, spl_b_bbb_m, spl_b_bbr_m, spl_b_mab_m

 

 

salimits:

 

#Timed Objects=227Vehicle Models=213#Ped Models=278#IDEs=14000#CarMods=70

 

 

HandlingAdder:

 

[MAIN]Count=1[CAR_IDs]612[612]index=11fmass=1400fTurnMass=2725,30004882813fDragMult=1,5x=0y=0z=-0,25nPercentSubmerged=70fTractionMultiplier=0,699999988079071fTractionLoss=0,800000011920929fTractionBias=0,5nNumberOfGears=5fMaxVelocity=1,22800159454346fEngineAcceleration=0,00119999994058162fEngineInertia=10nDriveType=4nEngineType=PfBrakeDeceleration=0,00439999997615814fBrakeBias=0,509999990463257bABS=0fSteeringLock=30fSuspensionForceLevel=1,20000004768372fSuspensionDampingLevel=0,189999997615814fSuspensionHighSpdComDamp=0fSuspensionUpperLimit=0,25fSuspensionLowerLimit=-0,100000001490116fSuspensionBiasBetweenFrontAndRear=0,5fSuspensionAntiDiveMultiplier=0,400000005960464fSeatOffsetDistance=0,370000004768372fCollisionDamageMultiplier=1,02857148647308nMonetaryValue=95000modelFlags=1073750020handlingFlags=12599296frontLight=1rearLight=1animGroup=1

 

 

Where did I go wrong?

Share this post


Link to post
Share on other sites
gynion

two questions:

 

 

1: I can add a plane with HYDRA functions?

 

Is that I tried to add another hydra, but it behaves like a normal plane. if substituted for the original HYDRA, yes it is working properly

 

 

 

2: Can you put a default song (on radio) on each car added?

 

Example:

 

A-Team van = The A-team theme

BTTF Delorean = BTTF theme

Ghostbusters Car = Ghostbusters song

Batmobile = Batman Theme

 

Etc.. biggrin.gif

 

 

 

 

 

Sorry for my English.

Edited by gynion

Share this post


Link to post
Share on other sites
FXR GF

Hello guys , I have a question : Is there anyway to add more paintjob on those "adding cars" ? mercie_blink.gif

If you have any tutorials , pls guide me blush.gif

Share this post


Link to post
Share on other sites
fastman92

 

1: I can add a plane with HYDRA functions?

 

Is that I tried to add another hydra, but it behaves like a normal plane. if substituted for the original HYDRA, yes it is working properly

ID of hydra is hard-coded in exe, it is unknown where is that adress with ID.

I`ll try to create a plugin to have many hydra planes as soon as my knowledge will be adequate.

 

About spawning cars - use my car spawner with ability of ranges configurable in ini file, http://www.gtagarage.com/mods/show.php?id=13763

You can spawn any added cars after adding range to ini file.

Edited by fastman92

Share this post


Link to post
Share on other sites
gynion
1: I can add a plane with HYDRA functions?

 

Is that I tried to add another hydra, but it behaves like a normal plane. if substituted for the original HYDRA, yes it is working properly

ID of hydra is hard-coded in exe, it is unknown where is that adress with ID.

I`ll try to create a plugin to have many hydra planes as soon as my knowledge will be adequate.

 

About spawning cars - use my car spawner with ability of ranges configurable in ini file, http://www.gtagarage.com/mods/show.php?id=13763

You can spawn any added cars after adding range to ini file.

Ok. Thanks Fastman.

 

If interested, I've configured as follows:

 

 

; Author of car spawner: Fastman92[MAIN]Ranges = 2; Below Them Are options to switch on / off (1 / 0)Hydraulics = 0Trailers = 1Peds_in_car = 0Put_player_in_car = 1Rotate_car = 1[1]start = 400end = 611[2]start = 18631end = 18650

 

Works fine.

Share this post


Link to post
Share on other sites
gellaps

PLEASE HEELP MEE..

 

i have follow what the tut says,

i have tried 4 times, 2times with the same vehicle, and the others with another vehicle..

 

but i have crash when loading game,

 

it is a warn from SA Limit adjuster

 

 

 

Last File Loaded: DATA\VEHICLE.IDE

 

Last Library Loaded: C:\WINDOWS\SYSTEM32\3deep.dll

 

Error: Unknown

 

 

 

Assembly Info:

 

 

 

Exception At Address: 0x004C672A

 

Exception Code: 0xc0000005 (EXCEPTION_ACCESS_VIOLATION)

 

 

 

Registers:

 

EAX: 0x00000000 EBX: 0x008E2C64

 

ECX: 0x00B1E15C EDX: 0x00480000

 

ESI: 0x00B1E15C EDI: 0x00000004

 

EBP: 0xFFFFFFFF ESP: 0x0022FBE8

 

 

my GTA version is v.1.0

and i can make sure that i'm not miss any step.

 

in salimit.ini

vehicle model = 212

i have change it to 213 and even 612

 

i have change handling-adder property following the handling.cfg that i have added for my vehicle (except the property that need to convert to hex)

 

but i'm sure that there is something wrong in vehicle.ide(like the error says).

and i'm sure that i have followed everything same as the tut says (add from the readme.txt file),and even i have tried to grab conf from another vehicle(in my case i want to add bike Hayabusa 1300 R that have a similarity to BF400)

 

i'm so confused and don't know what to fix again..

 

sorry for my bad eng..

i'm and ASIAN

 

please masters, help me, i really want to try it..

Share this post


Link to post
Share on other sites
ZAZ

 

but i have crash when loading game,

 

 

it crashes for me also with eu crack exe

but it works with us crack exe

Share this post


Link to post
Share on other sites
gellaps

 

but i have crash when loading game,

 

 

it crashes for me also with eu crack exe

but it works with us crack exe

how do i know my crack.exe version??

 

where can i download the us crack??

 

thanks

Share this post


Link to post
Share on other sites
gellaps

please friends, check my files,

and please let me know where is the error..

 

www.mediafire.com/?pl3fq564g6jq5t0

 

thank you very much

Share this post


Link to post
Share on other sites
ZAZ

 

please friends, check my files,

and please let me know where is the error..

 

www.mediafire.com/?pl3fq564g6jq5t0

 

thank you very much

why did you try a motorbike as your first test?

do it again, use a car, use the ID 612

use a model name with max. 7 charackter

 

edit the carmods.dat and cargroup.dat isn't required

use carspawner to find the car ingame

Car Spawner By Fastman92 (requires cleo4)

AddCar spawner (works with cleo3)

 

crack exe is not allowed to talk here, use google or write me a email

where do you live, which languge version do you have?

Share this post


Link to post
Share on other sites
gellaps
please friends, check my files,

and please let me know where is the error..

 

www.mediafire.com/?pl3fq564g6jq5t0

 

thank you very much

why did you try a motorbike as your first test?

do it again, use a car, use the ID 612

use a model name with max. 7 charackter

 

edit the carmods.dat and cargroup.dat isn't required

use carspawner to find the car ingame

Car Spawner By Fastman92 (requires cleo4)

AddCar spawner (works with cleo3)

 

crack exe is not allowed to talk here, use google or write me a email

where do you live, which languge version do you have?

oh, ok sorry about the crack,

 

btw, i finally knew what my version, because when my Game crash, it shown a log message, and it says ,

 

version : US v 1.0

 

bla bla bla..

 

 

ok i'll test a car, i just prefer add a bike than a car, and i will report u the result,

 

but i thing my problem is caused by handlingadder (maybe i put wrong property in this file), because when i delete the handlingadder.ini, it don't crash anymore, but the mod can't be spawned..

 

i'm an Asian..

 

thanks for helping

Share this post


Link to post
Share on other sites
gellaps

hey i di it smile.gif

 

i have follow everything u say, and i'm start with a car, and wonerfully i did it biggrin.gif ..

 

even when i try once again, with the bike that have an error before, and i don't know how it can, but once again, i really did it, it works..

 

 

but i have any problem, when i trying for the 3rd time, i add a bike again,

and it has no error or crash in game,,

but when i call it with spawner, it shown just for a second, and then disappear, and i realize that my sound(any sound, sound of car, step and even a gun except a menu sound) is disapear too..than

when i try delete this bike's sound in VehicleAudioHook.xml, the bike still same, appear but then disappear again, but not with the sound,

 

so what is my real problem??

is it because the .img file(txd and dff) or from my configuration (vehicle.ini, handling.cfg,carmods.dat,ect.)

 

 

can anyone help me??

thanks

Share this post


Link to post
Share on other sites
ILeeI

I have problem when i hit some car my gta it closes. sad.gifsad.gifsad.gifsad.gifsad.gifsad.gifsad.gifsad.gif

 

 

 

 

PLEASE HELP!!!!

PLEASE HELP!!!!

PLEASE HELP!!!!

PLEASE HELP!!!!

 

Sorry for bad english.

Share this post


Link to post
Share on other sites
aStiffSausage

Hi. Like in page 3 or smthing, there's stuff that only tools you need is MoreVehicles.asi and VehicleAudioLoader.asi. I've added 2 cars in-game, Honda S2000 and Toyota Supra with names STWOK and SUPRAIV, both got different handling lines and vehicles.ide-lines, I'm not getting any crashes but they are using Supra's handling notify.gif

 

Vehicles.ide

 

611,  utiltr1,  utiltr1,  trailer, UTIL_TR1,  UTILTR1,  null, ignore,  4, 0, 0,  -1, 0.68, 0.68,  -1

612, stwok, stwok, car,  STWOK,  STWOK,  null, executive,  10,  0, 0,  -1, 0.7, 0.7,  0

613,  supraiv,  supraiv,  car,  SUPRAIV,  SUPRAIV,  null, poorfamily, 10,  0, 0,  -1, 0.7, 0.7,  0

 

Handling.cfg

 

;the end

STWOK  1600.0    4500.0  0.1    0.0 0.0 -0.15 75  0.65 0.9  0.5  5 200.0 280.0 25.0 R P  7.0  0.52 0 30.0  1.1  0.09  0.0  0.30 -0.10 0.5  0.3  0.25 0.60 35000  40002800 0  1  1 19

SUPRAIV  1200.0    2000.0  0.1    0.0 0.15 -0.1  70  0.70 0.86 0.5  4 160.0 2.0 5.0  R P  8.0  0.60 0 30.0  1.4  0.12  0.0  0.30 -0.08 0.5  0.0  0.26 0.50 9000  40000000 2  0  0 0

 

Basically Honda S2000 has vehicles.ide and handling-line copied from Feltzer, and Supra has been copied from Cadrona, but as you can see, S2000 should have way more acceleration than any normal car and use different animation while getting in, and Supra has really slow acceleration, but both accelerate slowly.

 

 

Any advice? suicidal.gif

Share this post


Link to post
Share on other sites
Luten

I've some problem. I added new vehicle - bike (with ID 18900), everything works very good. I can spawn him via car spawner without any problems but when I want to spawn him via opcode in my main.scm or .cs file I've game crash when game is loadnig. I was trying to change ID on 612 but sill the same. I was thinking that is problem with bike and I added car but game crash too when game is loadnig.

 

I use this in my main.scm

 

014B: $ANGELX = init_parked_car_generator #ANGEL color -1 -1 0 alarm 0 door_lock 0 0 10000 at -93.07 -1580.46 10.1 angle 315.0 014C: set_parked_car_generator $ANGELX cars_to_generate_to 101

 

 

but when I use

 

Model.Load(#ANGEL)038B: load_requested_models not Model.Available(#ANGEL)[email protected] = Car.Create(#ANGEL, -1180.489, -40.9952, 10.5557)Car.Angle([email protected]) = 90.0

 

everything is ok

 

Solution found! If you use CLEO v4.1.1.30f you must change it to v4.1.1.30 or wait to new version. This looks like the problem in v4.1.1.30f with car_generator opcode.

Edited by Luten

Share this post


Link to post
Share on other sites
louka

another probleme, whene I and more than 7 cars, the 8 car dont have motor sound sad.gif all sound worke fine, but motor make a sound like "flap, flap, flap, flap"

 

and idéa ?

Share this post


Link to post
Share on other sites
louka
Hi. Like in page 3 or smthing, there's stuff that only tools you need is MoreVehicles.asi and VehicleAudioLoader.asi. I've added 2 cars in-game, Honda S2000 and Toyota Supra with names STWOK and SUPRAIV, both got different handling lines and vehicles.ide-lines, I'm not getting any crashes but they are using Supra's handling notify.gif

 

Vehicles.ide

 

611,  utiltr1,  utiltr1,  trailer, UTIL_TR1,  UTILTR1,  null, ignore,   4, 0, 0,  -1, 0.68, 0.68,  -1

612, stwok, stwok, car,   STWOK,   STWOK,   null, executive,  10,  0, 0,  -1, 0.7, 0.7,  0

613,  supraiv,  supraiv,  car,   SUPRAIV,  SUPRAIV,  null, poorfamily, 10,  0, 0,  -1, 0.7, 0.7,  0

 

Handling.cfg

 

;the end

STWOK   1600.0    4500.0   0.1    0.0 0.0 -0.15 75  0.65 0.9  0.5   5 200.0 280.0 25.0 R P  7.0   0.52 0 30.0   1.1  0.09  0.0   0.30 -0.10 0.5  0.3  0.25 0.60 35000  40002800 0   1  1 19

SUPRAIV  1200.0    2000.0   0.1    0.0 0.15 -0.1  70  0.70 0.86 0.5   4 160.0 2.0 5.0  R P  8.0   0.60 0 30.0   1.4  0.12  0.0   0.30 -0.08 0.5  0.0  0.26 0.50 9000   40000000 2   0  0 0

 

Basically Honda S2000 has vehicles.ide and handling-line copied from Feltzer, and Supra has been copied from Cadrona, but as you can see, S2000 should have way more acceleration than any normal car and use different animation while getting in, and Supra has really slow acceleration, but both accelerate slowly.

 

 

Any advice? suicidal.gif

so do you use handling adder ?

Share this post


Link to post
Share on other sites
aStiffSausage
Hi. Like in page 3 or smthing, there's stuff that only tools you need is MoreVehicles.asi and VehicleAudioLoader.asi. I've added 2 cars in-game, Honda S2000 and Toyota Supra with names STWOK and SUPRAIV, both got different handling lines and vehicles.ide-lines, I'm not getting any crashes but they are using Supra's handling  notify.gif

 

Vehicles.ide

 

611,  utiltr1,  utiltr1,  trailer, UTIL_TR1,  UTILTR1,  null, ignore,   4, 0, 0,  -1, 0.68, 0.68,  -1

612, stwok, stwok, car,   STWOK,   STWOK,   null, executive,  10,  0, 0,  -1, 0.7, 0.7,  0

613,  supraiv,  supraiv,  car,   SUPRAIV,  SUPRAIV,  null, poorfamily, 10,  0, 0,  -1, 0.7, 0.7,  0

 

Handling.cfg

 

;the end

STWOK   1600.0    4500.0   0.1    0.0 0.0 -0.15 75  0.65 0.9  0.5   5 200.0 280.0 25.0 R P  7.0   0.52 0 30.0   1.1  0.09  0.0   0.30 -0.10 0.5  0.3  0.25 0.60 35000  40002800 0   1  1 19

SUPRAIV  1200.0    2000.0   0.1    0.0 0.15 -0.1  70  0.70 0.86 0.5   4 160.0 2.0 5.0  R P  8.0   0.60 0 30.0   1.4  0.12  0.0   0.30 -0.08 0.5  0.0  0.26 0.50 9000   40000000 2   0  0 0

 

Basically Honda S2000 has vehicles.ide and handling-line copied from Feltzer, and Supra has been copied from Cadrona, but as you can see, S2000 should have way more acceleration than any normal car and use different animation while getting in, and Supra has really slow acceleration, but both accelerate slowly.

 

 

Any advice? suicidal.gif

so do you use handling adder ?

No, I'm adding handlings to the end of handling.cfg. Using HandlingAdder causes way to many crashes, and sharing handlings for many cars isn't ok for me confused.gif

Share this post


Link to post
Share on other sites
Silent

You can't add new handlings to handling.cfg file.

Share this post


Link to post
Share on other sites
louka

to add handling, you must use handling adder, if you want I have fond a converter handling line (handling CGF to handling.INI)

Share this post


Link to post
Share on other sites
aStiffSausage

I have handling converter, but it's still too buggy sad.gif

 

And adding new handlings would work if the limit of handling-lines would be breaken... But well, not many coders aren't interested about making a plug-in for that confused.gif

Share this post


Link to post
Share on other sites
louka

so I can't do anything for you sorry :s I'm a newbee in gta modding ^^

Share this post


Link to post
Share on other sites
Fatalpipe

 

You can't add new handlings to handling.cfg file.

Yes,we can,I did it and can say to you that surelly we can...

 

@louka : No,dont need to use this,just add lines to handling.cfg.

 

Dont know why people still talking about a lot of things,when all you need is MoreVehicles.asi and VehicleAudioHook.asi on main folder,Added_cars.fxt(or whatever the name you want,to show car name ingame) on CLEO/CLEO_TEXT folder,add/edit the lines on carcols.dat,carmods.dat,handling.cfg,vehicles.ide and,uhmm,let me see,what more I need... NOTHING,NEED NOTHING MORE THAN THIS!!!

I have about 30 cars and one quadbike with his own handling.cfg line,and everything works great.

And sorry,but we dont need the "20Mb file" from user 1stresponse,he dont even say to us what the hell are in this package...

Edited by Fatalpipe

Share this post


Link to post
Share on other sites
louka

can you give me an exemple for your added_cars.fxt please wink.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 Members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.