Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    2. News

    1. Red Dead Redemption 2

    1. GTA Online

      1. After Hours
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

2pacproducer2

[TuT] Adding cars to GTA SA

Recommended Posts

SkylineGTRFreak

sry, i dont want to read all this stuff on page 2-5, so sry if this question was already there... i wondered if this is possible with planes, also?

Share this post


Link to post
Share on other sites
1stresponse

yup,..its possible,..99%,..i add your STRATOTANKERS both kc-10 and the other one,..how about the remaining 1%? guess what,...it needs a MOUSE FLY instead of KEYS,..because there is something abnormal in the handling..,,overall,it's possible,..i add the stratotankers because i dont want to replace my C-130,..

 

Remember this,,the tools are made to add land vehicles only..but i manage,.if you are going to ask about HELICOPTERS,..1%chance,..you may see your HELI but when you fly,,NO LEAN LEFT AND RIGHT NOR FORWARD OR BACKWARDS,..we need a tool that can read special handling for flying vehicles. suicidal.gif

 

For the ADDED PLANES. You will not hide wheels, no cargo hold open. You need a Cleo script to do that. But still you can fly with your planes.

Edited by 1stresponse

Share this post


Link to post
Share on other sites
1stresponse

MAYBE NEXTWEEK I WILL UPLOAD AND SHOW HOW TO ADD THE "STRYKER" AND INCLUDE THE FILES. OWN CONVERTION

here are some PICS. http://i1211.photobucket.com/albums/cc422/...ponse1/EWEW.jpg

 

This pic shows that STRYKER can carry troops:

http://i1211.photobucket.com/albums/cc422/...ponse1/ASAS.jpg

http://i1211.photobucket.com/albums/cc422/...e1/cancarry.jpg

 

other pics:

http://i1211.photobucket.com/albums/cc422/...e1/Untitled.jpg

http://i1211.photobucket.com/albums/cc422/...troopisrush.jpg

http://i1211.photobucket.com/albums/cc422/...1/strykerrr.jpg

 

for suggestions and comments in the pics you are free to give just before it's release...

The release is NEAR.

 

It replace SWATVAN and i created extra ped_backseat to make it much REAL...mean as troop carrier and ground attack purposes.

Edited by 1stresponse

Share this post


Link to post
Share on other sites
nodata

i have a problem with jacob's car spawner. when i fire the game up and click inject and then click the game again it quits without giving an error. somebody else has this?

Share this post


Link to post
Share on other sites
fastman92

I created car spawner that lets you configure ranges with added vehicles: http://www.gtagarage.com/mods/show.php?id=13763

Configure ini file.

 

Another problem with adding vehicles is that if you add new entry in handling.cfg then e.g steering of motorcycles doesn`t work. For now solution is not to add entries in handling.cfg and use existing ones by not modifying handling parameter in vehicles.ide of this vehicle entry.

Share this post


Link to post
Share on other sites
skullfreak1987

hey guys i added (not replaced) a new car into san andreas the game loads and runs normally BUT when i press the buttons to spawn the car the game crashes back to the desktop and i get this error please let me know whats wrong thanks

 

 

GTA:SA Crashed, Debug Info Follows:

 

 

 

GTA Info:

 

 

 

Version: US 1.0

 

Last File Loaded: gta_sa.set

 

Last Library Loaded: powrprof.dll

 

Error: Unknown

 

 

 

Assembly Info:

 

 

 

Exception At Address: 0x0043A128

 

Exception Code: 0xc0000005 (EXCEPTION_ACCESS_VIOLATION)

 

 

 

Registers:

 

EAX: 0x0000006E EBX: 0x00000000

 

ECX: 0x0000006E EDX: 0x04AED9A8

 

ESI: 0x00000000 EDI: 0x000F4240

 

EBP: 0x01312D00 ESP: 0x0022FD3C

 

 

Share this post


Link to post
Share on other sites
bandiit3

how can i make the cops to drive my added car?

Share this post


Link to post
Share on other sites
1stresponse

the tool you have lookin like cops drives your car is outside of this topic,..and make sure that te ID of your car you register is an existing ID.. ex. ID 18631 is under Q:18631 inside the text file then make sure that you hit "Ctrl+Q" in -game otherwise your game will crash,.. and use secondary enter in your keyboard when attempting to spawn the car "enter key" down NUMPADS

Share this post


Link to post
Share on other sites
bandiit3

ok, thanks, but can you please tell me the name of the tool?

Share this post


Link to post
Share on other sites
uber1234

I added an ambulance and police car but when i spawn them in game they dont have the paramedic and police radios.

 

HELP?????

Share this post


Link to post
Share on other sites
1stresponse

if you read my 1st reply here, it contain a 20mb file of detailed tutorial, i have a tool include there, for vehicle engine sound police radio, actually, it is so easy to add cars any type of land vehicle with correspanding radio sounds, in that tool, just copy sound radio property of any police vehicle (e.g. swatvan) then paste to youar added car id sound property,.. wait it's here,

 

page 4 of this topic, 1st reply of 1stresponse (me)

http://www.gtaforums.com/index.php?showtopic=399977&st=60

 

it contains slightly wrong grammars, but still it does have ALL THINGS you're asking in terms of ADDING and customizing car radios (e.g. police radio sound for added military vehicle or government vehicle) monocle.gif

 

 

and about spawner tool i use, it is "JACOB'S CAR SPAWNER"

if you remember, it contains, two(2) file, 1 is the "exe." or executable file and the other 1 "hotkey.lst", actually you can open it with any text tool (e.g. notepad, wordpad)

inside of it:

 

sample:

 

W:470

S:430

 

means, when you are playing and try to spawn a car using together with JACOB'S SPAWNER

you just need to HIT "Ctrl+W" for patriot as sample above if you remember, the patriot ID is 470 and HIT "Ctrl+S" for barracks. this statement just want you to know that "W" listed above is for a "shortcut key" and the number right beside is pertaining for what car you want to spawn with.

 

"Ctrl+Shortcut Key=your CAR"

Edited by 1stresponse

Share this post


Link to post
Share on other sites
uber1234

i am using ur tutorial to add cars (i've added 50+ cars so far) but when i get into the added police car it just doesnt have a radio or sirens. confused.gif

 

how can i make the police to drive my added police car?

Edited by uber1234

Share this post


Link to post
Share on other sites
bandiit3

how do i fix ''submerged cars''

Share this post


Link to post
Share on other sites
gokussj

How to fix crashing audio? Horn sound is from BMX, engine from ped jump and door is from helicopter. All cars in SA have crash audio. confused.gif

Share this post


Link to post
Share on other sites
1stresponse

it is not advisable to use Vehicle Audio Editor Ultimate, instead use vehicle audio hooked by NAuthority. No more bike horns and all sounds will work, this tool also may help others to setup a car with police radio, ANY CAR EITHER AIRPLANES OR FOR OTHER EXISTING VEHICLES.

for those who interested download this : http://www.mediafire.com/?95h6cbd1yln3gg6

20mb file, all tools you need are all there and this : http://www.gtainside.com/en/download.php?d...wnload&id=25690 handling line converter by alexander, latest tool and big help for adding new handling inside handling adder, how to use? just copy given handling then paste it in the tool and press convert, then copy conveted output lines and paste to your handlingadder.ini, just don't forget to change "." to "," in a converted handling, "." can't be read inside handlingadder.ini, with this tool it will solve also problems about SUBMERGED problems. Any question? just ask cool.gif

Share this post


Link to post
Share on other sites
1stresponse

"vehicleaudiohooked.xml" can be open by notepad or any text tools, open it, you will see sound property of cars inside our game, example of vehicles that has police radio sound is barracks, enforcer, 3 city state police car, ambulan, rhino. just copy radio property of any of those stated vehicle and paste to your car radio sound property, save it and close. tadaah! you have now police radio sounds. i am using this method in my added military vehicles such as stryker the lav-25 etc. tomorrow detailed tutorial if you didn't get what i mean. wink.gif

 

you can get also sound property of infernus, alpha etc. for added sports cars and BF400 for added big bikes and angel for choppers

Edited by 1stresponse

Share this post


Link to post
Share on other sites
1stresponse

and for serens, sad to say but, we need another tool for that, just police radio sound.

i tried to have a test for serens but, no hope suicidal.gif

Share this post


Link to post
Share on other sites
uber1234

i did all that i opened the VehicleAudioHook.xml with notepad, i copied the sound from veh id 596 (copcarla). i then changed the id to 18685 the id i used for the police car but when i get into the car there is no police radio. I am using ur tutorial, i followed all the steps. i then used the sound from 597 (copcarsf) to see that had the radio but it didnt as well. nervous.gifconfused.gifcryani.gificon13.gif

 

Heres the two sound data both are the same except for the id

 


 

<vehicle id="596">

<cartype>0</cartype>

<engineonsound>87</engineonsound>

<engineoffsound>86</engineoffsound>

<unknown4>0</unknown4>

<unknown5>0.699999988079071</unknown5>

<unknown6>1</unknown6>

<horntone>2</horntone>

<hornhigh>1.05946314334869</hornhigh>

<doorsound>2</doorsound>

<radioid>13</radioid>

<radiotype>3</radiotype>

<unknown12>38</unknown12>

<unknown13>0</unknown13>

<unknown14>0</unknown14>

<unknown15>0</unknown15>

<unknown16>0</unknown16>

</vehicle>

 

<vehicle id="18685">

<cartype>0</cartype>

<engineonsound>87</engineonsound>

<engineoffsound>86</engineoffsound>

<unknown4>0</unknown4>

<unknown5>0.699999988079071</unknown5>

<unknown6>1</unknown6>

<horntone>2</horntone>

<hornhigh>1.05946314334869</hornhigh>

<doorsound>2</doorsound>

<radioid>13</radioid>

<radiotype>3</radiotype>

<unknown12>38</unknown12>

<unknown13>0</unknown13>

<unknown14>0</unknown14>

<unknown15>0</unknown15>

<unknown16>0</unknown16>

</vehicle>

Edited by uber1234

Share this post


Link to post
Share on other sites
gokussj

1stresponse how the password to file on mediafire.com? the Handling Line Converter not works, i paste line from handling.cfg and error confused.gif

Share this post


Link to post
Share on other sites
1stresponse

the PASSWORD is "MARYJOY",.. and what type of car you add? about the tool by alexander, it works for me 100 %,

here's a pic when you start

 

http://i1211.photobucket.com/albums/cc422/...eterandling.jpg

 

and here is the process

 

http://i1211.photobucket.com/albums/cc422/...se1/process.jpg

 

the output (MGS-STRYKER with police radio sound)

http://i1211.photobucket.com/albums/cc422/...ponseonduty.jpg

http://i1211.photobucket.com/albums/cc422/...omestrooble.jpg

http://i1211.photobucket.com/albums/cc422/...itniceagain.jpg

http://i1211.photobucket.com/albums/cc422/...MGS-STRYKER.jpg

 

example, you have a BMW POLICE CAR to be added, copy ALL copcarla sound property, then if you dont want the engine sound and what you want is like engine sound of "alpha" just copy then the two engine sound of alpha to yours,.so you have alpha engine sound for BMW POLICE together with police radio sound, this doesn't include police seren,.here's a indication that your car already have police radio, YOU WON'T SCROLL FOR THE NEXT RADIO STATION WHEN YOU ARE IN THAT CAR. monocle.gif

just ask and im ready to help you as long as i can. wink.gif

 

 

 

Share this post


Link to post
Share on other sites
1stresponse

and there is no point for crying,.. you just missed it, we are all the same even when i am just a beginner, lookin for somebodys help, there is a solution just missed it wink.gif

Share this post


Link to post
Share on other sites
gokussj

thanks, Vehicle Audio Hook works perfectly. Very thanks. This error in Handling line Converter:

user posted image

 

The password MARYJOY not work.

Edited by gokussj

Share this post


Link to post
Share on other sites
1stresponse

"maryjoy" i mean, smal letters, sorry, and about your problem regards to the tool, don't have any experience like what shown in the pic, and try other handling and uncheck the speedlimit

Edited by 1stresponse

Share this post


Link to post
Share on other sites
rcunha

Can I add new bikes? I,ve tried but not works. I need bike handling default.

Edited by rcunha

Share this post


Link to post
Share on other sites
at72

Just a question: The problem with random crashes when driving via handlingadder added cars already has been solved?

 

@rcunha: I added a couple of bikes, but I always use handling from original ones.

Share this post


Link to post
Share on other sites
rcunha

 

Just a question: The problem with random crashes when driving via handlingadder added cars already has been solved?

 

@rcunha: I added a couple of bikes, but I always use handling from original ones.

 

I have no problem with cars, only works fine with cars in my game, the bikes are not showing in the game using or not handlingadder.

 

Can you post an example please?

 

 

I've tried with a heli but the handling dont works fine still, only whit a plane I have sucess.

 

Sorry for bad english.

Edited by rcunha

Share this post


Link to post
Share on other sites
at72

Sure, a pretty simple example. You have to check whether the handling from an existing bike fits or not.

 

CARCOLS

add022, 0,1, 81,1, 151,1, 163,1, 105,1, 94,1, 89,1, 73,1 # 1979 Harley-Davidson Fat Boy

 

CARGROUP

bfinject, mesa, mrwhoop, add022 # POPCYCLE_GROUP_BEACHFOLK

 

VEHICLES

794, add022, add022, bike, WAYFARER, ADD022, wayfarer, motorbike, 6, 0, 0, 23, 0.75, 0.75, 0 # handling ok

 

HANDLING (wayfarer, from some downloaded similar looking bike)

WAYFARER 800.0 600.0 4.0 0.0 0.1 0.0 103 1.4 0.85 0.48 4 190.0 40.0 5.0 R P 20.0 0.55 0 35.0 0.65 0.20 0.0 0.08 -0.11 0.55 0.0 0.0 0.24 10000 41000000 702200 1 1 8

! WAYFARER 0.10 0.05 0.20 0.05 30.0 25.0 0.945 1.20 0.7 0.1 33.0 -55.0 -0.006 0.4 0.3

 

VEHICLEAUDIODATA

...

[iDs]

Number_of_pairs=1

FromID_1=119

ToID_1=909

...

[794]

CarType=1

EngineOnSound=140

EngineOffSound=139

Unknown4=2

Unknown5=0,649999976158142

Unknown6=1

HornTon=1

HornHigh=0,840896427631378

DoorSound=255

RadioNum=3

RadioType=0

Unknown12=29

Unknown13=0

Unknown14=0

Unknown15=0

Unknown16=0

 

and I use CLEO to give it a name. That's all.

 

I don't use handlingadder anymore, because I faced the problem that the more cars you add, the more unstable the game gets. My game often freezed when the added car touched a wall or another car.

I didn't add extra planes or helis until now.

Share this post


Link to post
Share on other sites
1stresponse
Sure, a pretty simple example. You have to check whether the handling from an existing bike fits or not.

 

CARCOLS

add022, 0,1, 81,1, 151,1, 163,1, 105,1, 94,1, 89,1, 73,1 # 1979 Harley-Davidson Fat Boy

 

CARGROUP

bfinject, mesa, mrwhoop, add022 # POPCYCLE_GROUP_BEACHFOLK

 

VEHICLES

794, add022, add022, bike, WAYFARER, ADD022, wayfarer, motorbike, 6, 0, 0, 23, 0.75, 0.75, 0 # handling ok

 

HANDLING (wayfarer, from some downloaded similar looking bike)

WAYFARER 800.0 600.0 4.0 0.0 0.1 0.0 103 1.4 0.85 0.48 4 190.0 40.0 5.0 R P 20.0 0.55 0 35.0 0.65 0.20 0.0 0.08 -0.11 0.55 0.0 0.0 0.24 10000 41000000 702200 1 1 8

! WAYFARER 0.10 0.05 0.20 0.05 30.0 25.0 0.945 1.20 0.7 0.1 33.0 -55.0 -0.006 0.4 0.3

 

VEHICLEAUDIODATA

...

[iDs]

Number_of_pairs=1

FromID_1=119

ToID_1=909

...

[794]

CarType=1

EngineOnSound=140

EngineOffSound=139

Unknown4=2

Unknown5=0,649999976158142

Unknown6=1

HornTon=1

HornHigh=0,840896427631378

DoorSound=255

RadioNum=3

RadioType=0

Unknown12=29

Unknown13=0

Unknown14=0

Unknown15=0

Unknown16=0

 

and I use CLEO to give it a name. That's all.

 

I don't use handlingadder anymore, because I faced the problem that the more cars you add, the more unstable the game gets. My game often freezed when the added car touched a wall or another car.

I didn't add extra planes or helis until now.

"DISAPPEAR when touch a wall or touch a car"? because of error INPUTS...in my 20mb file, it solves many

issues, except over speeding....handlingadder don't have problem,..just user...about bikes, i successfully add only 1 bike,.. the tricycle mod by my "KAPWA PINOY"..and it takes BUGLESS..ADDING AIRPLANES,..i already ADD 2 STRATOTANKERS,..it flew nice, the problem is NO ASI ENGINES FOR HIDING THE WHEELS, CLOSE OPEN RAMPS FOR CARGO PLANES,. NEED CLEO TO DO THAT. biggrin.gif

Share this post


Link to post
Share on other sites
1stresponse

in ADDING CARS, make sure that you back-up all your mods, and it is advisable if remove all mods and use a fresh GTA SA. At least in that case, you know where the problem is... icon13.gif

Share this post


Link to post
Share on other sites
at72

@1stresponse: Why not edit your posts? I also didn't write that my cars disappear when touching a wall. No, the game freezes! I don't encounter this problem with the first few added cars - they work fine with handlingadder. So I seem to make it right! But the more cars I put ingame, the more often and easier it freezes. Not only at highspeed-driving, but also when cruising.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.