Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (84,897 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

  • 0
Sign in to follow this  
itslogz

How to: Fix Seculauncher [2000] Error Guide

Question

itslogz

GTAIV Was working fine on my 32-Bit XP harddrive, but once I tryed 64-Bit, all hell broke loose. So if you're getting the error "Seculauncher: Failed to start application [2000], this may help you.

 

Step 1: Install GTAIV and get the error stated above.

 

Step 2: Navigate to Control panel > Add/Remove Programs.

 

Step 3: Locate Microsoft Visual C++ 2005 Redistributable, more importantly, one's that say something with x64 on end. Apparently this game runs on 32-bit? Im not completely sure, but 32-bit installer comes in the downloaded package once GTAIV is installed.

 

Step 4: Uninstall any Visual C++ 2005 Redistributable items listed in Add/Remove programs.

 

Step 5: Navigate to the GTAIV main folder, and locate the installers folder. (In my case its Program files > Steam > Steamapps >Common > Grand theft auto iv > installers. People using a disk it would be to right click on your DVD/CD drive in My computer, click explore, and find the folder named "Redistributable"

 

Step 6: Find "vcredist_x86.exe"

 

Step 7: Run this installer, complete the installation.

 

Step 8: Check Add/Remove programs to see that the new 2005 C++ was installed.

 

Step 9: Attempt to load GTAIV once more, through Social club Play button. This is as far as I got before I got a new error, the above got rid of my seculaunch error though.

 

Step 10: If you're receiving a new error titled "GTAIV FATAL ERROR: RMN40", continue these steps, if not, play the game (Hopefully this worked for you, I could NOT find a solution until I tryed this reccomended by "theunknownsd" on gtaforums.com. He was the one who I found the above solution from, but I figured I would re-do these steps and post them as many places as I could to help other people in the same place I was.

 

Step 11: If you did get the "GTAIV FATAL ERROR: RMN40" after doing the above, right click on LaunchGTAIV.exe in the main GTAIV folder, and GTAIV.exe in the main GTAIV folder, and make sure that under the Compatibility tab that "run this program in compatibility mode for:" is not checked on all of the launchers. At this point, I got a NEW error once I solved that one, so if you had the RMN40 error, and unchecking compatibility mode fixed it, you may have now received the error "GTAIV FATAL ERROR: WS10", if so continue reading.

 

Step 12: If you got the "GTAIV FATAL ERROR: WS10", check Add/Remove programs to make sure you have "Microsoft Games for Windows Live Redistributable installed, if you do and you still get the error, uninstall the program at this time.

 

Step 13: Navigate to Program files > Steam > Steamapps >Common > Grand theft auto iv > installers >xliveredist.msi (Or the redistributable folder when exploring the CD for people using a CD.

 

Step 14: WS10 error supposibly has to do with windows live, so you want to uninstall and reinstall if you already had it, or install it from the folders in step 13 if you didnt have it at all. After uninstalling run xliveredist.msi (Or if your just now installing) and complete the setup.

 

 

Step 15: If you still get the WS10 error, download the following GTAIV Patch (Normally downloaded through social club, but at the time it wouldnt let me login to social club, this way is probably faster anyway) http://files.filefront.com/GTAIV+PC+Patchz...;/fileinfo.html

 

Step 16: Unzip the GTAIV_PC_Patch folder, and run the Setup.exe

 

Step 17: Hopefully now, when you launch GTA through social club, it will load up with no errors. In my case, all of the above got me up and going, there needs to be a hardfix patch for all this BS but I took the time to write this up since I was so mad over it.

 

Hope this helps some people.

Edited by itslogz

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0
Armin3381994

nice but i have a question.

Do i need to unistall Microsoft Sync Framework Runtime

and Microsoft Sync Framework service?

please reply back sad.gif

Share this post


Link to post
Share on other sites
  • 0
Denneisk

I still get Error 2000. I tried everything. Should I unintsall the 2008-2012 C++ too? Because then i would know.

Share this post


Link to post
Share on other sites
  • 0
Cornwood

Got EFLC working on my win8.1(64bit) by setting the windows compatibility mode for steam to win 7.

 

I changed from win7 64bit to win8.1 64bit and got the SecuLauncher error message from GTAIV: Episodes from liberty city. GTAIV worked just fine. Reinstalling the Visual C++ 2005 Redistributable didnt do anything.

Setting compatibility mode on game on XP or Vista, and administrator mode I got it to Fatal Error.

 

Setting steam and game to compatibility mode to win7 and administrator mode it suddenly started working. I then removed the administrator modes and compatibility modes and it still works.

Share this post


Link to post
Share on other sites
  • 0
GrindoLindo

securom fix; (iphlpapi.dll)

 

works for games like Mirrors Edge and most other old securom games, found on another site but won't mention it because piracy blah blah.

 

http://www.mediafire.com/download/glo45hcas4enlhy/iphlpapi.7z

 

place dll in gta iv or eflc folder and the game will launch, bypassing securom & social club (useless now since mp is dead in this game)

 

it's not a virus or anything suspicious, if you are paranoid just scan it first and then post your false warnings.

 

mods just delete this if it's not allowed, but i don't see why not since it's not a crack or patched files, it leaves game files untouched.

 

I got IV to run without securom errors by installing all available patches in order, game runs fine with securom without the dll file as well, signs into social club etc, just doesn't work online because of gfwl.

 

at least we got citizen mp for online play for now.

Edited by GrindoLindo

Share this post


Link to post
Share on other sites
  • 0
r1jcowan

Found new fix Delete the game Of Steam And Redownload Then Run it. I had This Problem and found was missing files in game folder so I redownloaded and it worked fine

Share this post


Link to post
Share on other sites
  • 0
GrindoLindo

well i've leave the mediafire link up if anyone wants to try that. securom can be a real pain.

Share this post


Link to post
Share on other sites
  • 0

ERRO 2000"

 

1)INSTALL Visual C++ 2005 Redistributable AND THEN start game and if u still get error change compability mode

2)then play game this is what i did hope it works for u

 


Share this post


Link to post
Share on other sites
  • 0
ClaudeIzABadAzz

Thank you bruh! It works!! IT ACTUALLY WORKS!!!!

Share this post


Link to post
Share on other sites
  • 0
StormBreaker

There is no need to uninstall or install anything. Just run it as admin. (Right click -> Properties -> Compatability -> Run as administrator).

Also useful if you get errors like asi loader failed to start and stuff like that.

Share this post


Link to post
Share on other sites
  • 0
optimus4757

i dont have microsoft visual c++ 2005 redisstributable in my pc.when i tried to install it a message was showing like "The Windows Installer Service could not be accessed.This can occur if the Windows Installer is not correctly installed.Contact your support perssonal for assistance".what will i do to install it and what will i do to play gta4.plzzzzzz tell me plzzzzz.

Edited by optimus4757

Share this post


Link to post
Share on other sites
  • 0
StormBreaker

reboot your PC and run the setup again. of that doesn't work, reinstall the whole game

Edited by StormBreaker

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.