Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
      4. Frontier Pursuits
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Diamond Casino & Resort
      2. DLC
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA 6

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA IV Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA SA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA VC Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA III Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

listener

[REL|GTAIV] XLiveLess

Recommended Posts

MessedUpPro

I haven't seen hardly any of those options! wow.gif I don't know why!

I only have:

 

Video Mode

Aspect Ratio

Texture Quality

Render Quality

And the sliders at the bottom

Share this post


Link to post
Share on other sites
Girish

Ahh, you haven't patched your game. Those options were introduced in the second patch. I suggest you patch your game.

Share this post


Link to post
Share on other sites
MessedUpPro

Wow. Okay. I knew there was no way I could run this game on "Highest" settings. Now I know why. Thanks anyway man.

 

EDIT: I patched it and the music played longer, but it still messed up. I am going to reinstall it. Thanks again.

Edited by Tony_Florence

Share this post


Link to post
Share on other sites
raven_g20

Hello

 

1st off thnx for the effort...2nd i have a small problem...i run win7 64-bit...when i run the game i get the popular WS10 error...i remember last time i installed the game i patched it up to 1.0.4.0 and used other files and the game run ok...now that i patched it with 1.0.7.0 i get the error...i tried ALL of the solutions provided from other members but nothing..reinstall, uninstall same with gmfl etc etc...i remembered that the error comes from the xlive.dll file...i used the old one but didnt work...i tried the latest you have and again i get error...if i show u the log will u be able to fix? thnx again in advance.

 

 

12/06/2011 14:28:23.892 Log started (xliveless 0.999b7)

12/06/2011 14:28:23.892 GetModuleHandle returns 013e0000

12/06/2011 14:28:23.892 [EXE] unprotecting section '.text': addr = 0x00001000, size = 0x008ce000

12/06/2011 14:28:23.892 [EXE] unprotecting section '.rdata': addr = 0x008cf000, size = 0x00176000

12/06/2011 14:28:23.892 Unknown game version, skipping patches (signature = 0xc25de58b)

12/06/2011 14:28:24.060 XLiveInitialize

12/06/2011 14:28:24.060 XNetStartup

12/06/2011 14:28:24.060 XWSAStartup

12/06/2011 14:28:24.190 XWSACleanup

12/06/2011 14:28:24.190 xlive_52: XNetCleanup

 

 

 

p.s. btw when i run the game with either .dll file it just pops a cmd screen and then it closes. nothing happens...

Edited by raven_g20

Share this post


Link to post
Share on other sites
ikt

 

I notice some strange behavior in my game that seems related to Xlive.

 

I decide to play again, installed, but this time I updated to 1.0.4, and was using this old Xlive 0.95 and didn't bother to check about the support. The game runned from the Social Club frontend (I didn't remember how was before) and I just skiped. My old save was in the My Documents, but of course, the game didn't loaded from there, since the xlive and game version was incompatible. But I didn't know about that, and since I want to start from the beginning, I just didn't bother.

 

OK, enough with the story. After the new Xliveless 0.999b7, with the saves proper loading from My Documents folder, and no Social Club I notice that when I bump into peds when walking, they just bend over with the arms relaxed and move the head to my direction. Running in the stripclub made all the girls start to run like I was shooting or something, and the bouncers came close to me like I was doing something wrong. The first mission of Manny that he ask me to follow a guy and then clean up the warehouse, the front door that was suppose to be locked just open up with the lock floating in the air. Looks like Nico is being consider like a vehicle, I guess.  biggrin.gif

 

I download and tested all the versions os Xliveless that gives support to 1.0.4 and all do the same thing with the peds.

I cleaned up any other dll and asi to see if was a mod and nothing.

I change to asi loader or that old Xlive, both make the game run from the Social Club, start a new game and test by bumping into peds when on foot, and it's normal.

 

So, my guess that is something with Xlive + 1.0.4 version.

 

Sorry the long story, I tried to make myself clear.  biggrin.gif

Diggin in the past!

 

I still have this problem/bug with the peds, even with the newest version. Any fixes yet?

Edited by ikt

Share this post


Link to post
Share on other sites
heat84

Exactly how does this support EFLC? I still can't play them when not signed in.

Share this post


Link to post
Share on other sites
Threepwood

Have been playing a while now w/o xliveless. I use a Logitech Joypad, "Dual Action".

Now w/o xliveless I have had no problem with inverting the view stick movement (R-Stick), once I had set it in the menu, it was ok with every game start.

 

Now I have installed xliveless again (dunno which version, but I will latest right now and report back if smth changes forget it, found it: latest version.), GTA IV does not keep the "invert" setting. Now I have to go into the menu everytime and invert it.

 

Any idea? Is that known?

Share this post


Link to post
Share on other sites
Guns*R-Us

I have problem with setting control key when using Xliveless. In option menu I use "C" for crouch and "NumPad1" for look behind. But ingame when I press "C" button the character also crouch and the camera look behind at the same time. Any idea to fix that issue confused.gif

Share this post


Link to post
Share on other sites
mrhoshos96

My game just crashes everytime i try to use this mod i just can't figure out why, basically it crashes while loading through the loading images

Here are my specifications:

I5 2400 @3.1Ghz

HD 6950 1gb

4gb ddr3 ram

Windows 7 64bit service pack 1

Gta IV patched to 1.0.4.0

Share this post


Link to post
Share on other sites
FitbikeSTR2

169 done

 

i signed

Share this post


Link to post
Share on other sites
jeemuel_29

how do you fix the broken back problem when you hit or touch someone they bend over.

Share this post


Link to post
Share on other sites
nightwalker83

Is it just me or is using xliveless for the point of saving the game offline pointless if you installed GTAIV_1.0.7.0_Patch? I mean I saved my saved games using GFWL but I disconnected my internet connection and I was still able to load and save my game without trouble.

Share this post


Link to post
Share on other sites
ObamaGoesPostal

Thanks! Working great, no more dealing with GFWL and Rockstar Games Social Club (which came as a nice surprise). Now I can stay at Patch 1.0.4.0. smile.gif

Share this post


Link to post
Share on other sites
mikecyclexxx

HOW THE f*ck DOES THIS WORK WITH EFLC?! Ive downloaded and installed it about 5 times, put xlive.dll into the game directory but there wasn't one to replace it just added into the folder? Andddddd i reinstalled EFLC twice already!

Share this post


Link to post
Share on other sites
heat84
HOW THE f*ck DOES THIS WORK WITH EFLC?! Ive downloaded and installed it about 5 times, put xlive.dll into the game directory but there wasn't one to replace it just added into the folder? Andddddd i reinstalled EFLC twice already!

It doesn't apparently. It doesn't do anything for me with EFLC either.

Share this post


Link to post
Share on other sites
SilentAssassn87

I'm having a weird problem. I'm running Xliveless with no problems. Recently I edited the file playerped.rpf to change nico model for one I downloaded. Now when I load up the game, Xliveless doesn't load any ASI files (simple trainer and Superman). When I switch it back to the backup of playerped.rpf, it works fine. I know the playerped works because I see the model changes, but lose ASI support. Is there something I can do to fix this. It seems its an xliveless issue as I got it working with Alexanders ASI loader, but then my game just gets too bright with the ICEnhancer settings.

Share this post


Link to post
Share on other sites
robxu9
HOW THE f*ck DOES THIS WORK WITH EFLC?! Ive downloaded and installed it about 5 times, put xlive.dll into the game directory but there wasn't one to replace it just added into the folder?  Andddddd i reinstalled EFLC twice already!

It doesn't apparently. It doesn't do anything for me with EFLC either.

Really? because I'm using it with both EFLC and GTAIV... Are you sure that you put xlive.dll and have all the game updates?

(PS: there was never an xlive.dll in my game directory... so this should be a new file for you.)

Share this post


Link to post
Share on other sites
heat84
HOW THE f*ck DOES THIS WORK WITH EFLC?! Ive downloaded and installed it about 5 times, put xlive.dll into the game directory but there wasn't one to replace it just added into the folder?  Andddddd i reinstalled EFLC twice already!

It doesn't apparently. It doesn't do anything for me with EFLC either.

Really? because I'm using it with both EFLC and GTAIV... Are you sure that you put xlive.dll and have all the game updates?

(PS: there was never an xlive.dll in my game directory... so this should be a new file for you.)

I just have it in the GTAIV directory. When you click PLAY on the screen where it asks you to choose TLAD or TBOGT, nothing happens. confused.gifsad.gif

Share this post


Link to post
Share on other sites
chrispap

please i want help about xliveless.dll and i can't find the save game folder

please help into that

 

thanks

Share this post


Link to post
Share on other sites
Mattoropael

It works good except the very simple fact that it didn't load a single asi file as it should have been, rendering the entire thing hopelessly useless.

 

 

GTAIV CC is crying all over the place saying that GTA4CC.asi is not loaded. And yes I'm on v.1.0.7.0, with Xliveless v.0.999b7 and ScriptHook v.0.5.1.0

 

NVM, It suddenly decided to work.

Edited by *~CNR4806~*

Share this post


Link to post
Share on other sites
gayasarafe

hi...pls help me.......i have installed gta 4 but is says unable to launch......during the installation if umdf it says not enough storage.......so with the xliveless...i just have to replace the orignal one in program files.....??????

Share this post


Link to post
Share on other sites
Skeet1983

How can I save settings (Controls, Subtitles) in RFG (Red Faction Guerrilla) using xliveless?

Share this post


Link to post
Share on other sites
Lashley

wheres the link to the latest version?

Share this post


Link to post
Share on other sites
chinagreenelvis

This prevents GTA IV from saving controller configurations.

Share this post


Link to post
Share on other sites
Zeating

I backed up my GTA IV folder in local>Rockstar Games, and since I forgot to backup my xlive folder I can't load my save file. So I downloaded this hoping I could just load my save file but nothing happens. Boot up TBoGT and when I play it starts a new game. I have my save files in every place imaginable, my documents, local, rockstar games, everywhere it could possibly look for them. Why cant I load my save?

Share this post


Link to post
Share on other sites
Symbiote

Make sure you put the SGTA4## save files, not the user_e000blahblah folder, directly into My Documents\Rockstar Games\GTA IV\savegames.

Share this post


Link to post
Share on other sites
chinagreenelvis

Sorry but this still causes LaunchGTAIV.exe to run RGSC and the game won't run without it.

Share this post


Link to post
Share on other sites
westsidebud

 

This prevents GTA IV from saving controller configurations.

True

 

I'm working on this problem again and so far i don't have a fix.

It would be cool if Listener would give his opinions on this bug.

If you use xLiveless you *may not have ALL the controller settings saved persistently.

Remove xLiveless and controller settings are saved just fine..

 

I rewrote the code he (Listener posted) its similar to a bunch of other projects i've made (emulators/hooks etc)

And i've recently added some features and did some testing

First i added config file support and logging system i made that has categories filtered by the config

Today i added a patch to block the loading of gtaBrowser.exe so i don't see the News & Videos on start up

 

I've done a lot of work testing and verifying the patch edits and they all so far seem to work as intended

 

Lastly i should mention i have GTA4 but I'm only testing on EFLC v1.1.2.0 and only on TLAD right now

And if i get a fix for the controller working i will for sure share it (the code anyway)

 

Not sure why so many people say this don't work, aside from the controller bug it works fine for me

and i have NO GFWL loaded nor do i have xLive running, it won't load in game even after i went and downloaded it and installed it

 

Edited by westsidebud

Share this post


Link to post
Share on other sites
westsidebud

I just added custom save game folder support, now i can have my save files anywhere (as set in my config file)

And I added a config option to disable custom save game folders and revert to Rockstar's default directory.

 

I also added a config option to disable loading plugins.

 

The no browser loading feature was added to an "Offline" config file option.

Only problem with this is the start screen will be black except for Social Club logo in the bottom right corner.

But the clickable options along the bottom of the screen are there and work fine.

edit:

I just found the proper place to enable toggling offline mode (its says go online instead of showing videos & news)

 

This all uses a logging class i wrote that logs different color coded categories of info to a log file and/or a console window

with config options for append/overwrite, filtering toggle and Proccess ID toggle, Date/Time toggle (to the millisecond)

and customizable log file name too of course lol

 

I wanna do more work on making the game offline and fix the controller bug somehow

Also i'm not gonna post anything anywhere unless its ok with Listener

Edited by westsidebud

Share this post


Link to post
Share on other sites
nightwalker83

 

This prevents GTA IV from saving controller configurations.

True

 

I'm working on this problem again and so far i don't have a fix.

It would be cool if Listener would give his opinions on this bug.

If you use xLiveless you *may not have ALL the controller settings saved persistently.

Remove xLiveless and controller settings are saved just fine..

 

I rewrote the code he (Listener posted) its similar to a bunch of other projects i've made (emulators/hooks etc)

And i've recently added some features and did some testing

First i added config file support and logging system i made that has categories filtered by the config

Today i added a patch to block the loading of gtaBrowser.exe so i don't see the News & Videos on start up

 

I've done a lot of work testing and verifying the patch edits and they all so far seem to work as intended

 

Lastly i should mention i have GTA4 but I'm only testing on EFLC v1.1.2.0 and only on TLAD right now

And if i get a fix for the controller working i will for sure share it (the code anyway)

 

Not sure why so many people say this don't work, aside from the controller bug it works fine for me

and i have NO GFWL loaded nor do i have xLive running, it won't load in game even after i went and downloaded it and installed it

Where are the control settings saved? I know if you play the game without xliveless you just need to delete the settings.cfg file "\Rockstar Games\GTA IV\Settings" and it should work fine. However , I try with xliveless installed that doesn't seem to be the case.

 

Edit:

 

I solved the problem of why the settings reset when you use xliveless! For some strange reason it doesn't delete the default settings.cfg file. I will include a fix for that in the new release of my Xassist program as soon as I figure out if rest of the functions such as automatically copying the save games to the new location when xliveless is installed worked.

 

Damn, has the save game location been reverted back to the original location under Windows 7 because when I use xliveless I notice the save game folder and files are still under the appdata location although I don't need to login to GFWL.

Edited by nightwalker83

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 2 Users Currently Viewing
    0 members, 0 Anonymous, 2 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.