Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (84,976 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

GooD-NTS

General OpenIV Discussion and Announcements

Recommended Posts

jWILL253

Is it just me, or has the last update broken the game?

 

I can only seem to run the game after verifying the files every time I make changes in OpenIV. Otherwise, I get the corrupt game data error.

 

EDIT: Yeah, I can't seem to be able to mod the game's files anymore. Every time I make changes that I know are 100% correct and working, even installing backups that I know work for certain, the game will crash at startup. Something is wrong here.

Edited by jWILL253

Share this post


Link to post
Share on other sites
jWILL253

Okay, I figured out what the problem is. Something's gone haywire with the encryption on carcols.ymt. Prior to the last update, I could edit it with no issues. But ever since the beginning of October, I haven't been able to edit it at all without the game crashing. And even when I replace it with the original copy, it still crashes. I basically have to leave it completely untouched for the game to run.

Share this post


Link to post
Share on other sites
_CP_

Any news about OpenIV development?

Share this post


Link to post
Share on other sites
OpenIV Team

00.png



Today, we are releasing OpenIV 2.9.2. This version does not includes new features but contains important changes to provide support for the latest version of Grand Theft Auto V.

Grand Theft Auto V
First time since 2015, we have updated OpenIV.ASI - our plugin, which provides mods support for Grand Theft Auto V. The latest version of GTA V has some non-critical changes in the code, which affected by OpenIV.ASI, and we made similar changes in our code. Without those changes in OpenIV.ASI, your game had crash during loading screen in some very specific scenario, only when you have Simplified Chinese language selected in game. Use ASI Manager to update OpenIV.ASI in your game folder.

General changes, improvements, and fixes
  • We fixed an issue where sometimes OpenIV crashes while renaming folders inside archives.
  • We fixed an issue where import of texture image with 2x2 sizes was impossible due to infinite loading.
  • We fixed an issue where files was not shown in OpenIV after they was drag-and-dropped in game folder using Windows File Explorer.
You can find change log on our bug-tracker here.

UI Localization
We have written an instruction how to translate OpenIV into your own language and we are calling for you to do so. You can find the localization guide here on GitHub. This version does not have differences from 2.9.1.

downloadOIV.png

Share this post


Link to post
Share on other sites
OpenIV Team

01.png


Maintenance update is available for OpenIV 2.9.2 (Build 931).

Changelog:
  • We fixed an issue where OpenIV crash while importing unacceptable big texture.
  • We added log into ASI Manager, the log is disabled by default. To enable log run OpenIV with parameter like this: "OpenIV.exe /asi_manager_log", the log will appear in game folder.
OpenIV Team.

Share this post


Link to post
Share on other sites
Neos7
Posted (edited)

Is it normal that converting a BoundBox from .obn to .ybn, it randomly assigns different PolyFlags and MaterialColorIndex? I'm using this as tester and converting it back to .obn

Version 43 31{	Type BoundBox	Radius 4.55522000	AABBMax 3.50000000 2.50000000 1.50000000	AABBMin -3.50000000 -2.50000000 -1.50000000	Centroid 0.00000000 0.00000000 0.00000000	CG 0.00000000 0.00000000 0.00000000	Margin 0.04000000	Material	{		MaterialIndex 1		ProcId 2		RoomId 3		PedDensity 4		PolyFlags FORMATS_EMPTY_FLAGS		MaterialColorIndex 200	}}
Edited by Neos7

Share this post


Link to post
Share on other sites
OpenIV Team

02.png


Maintenance update is available for OpenIV 2.9.2 (Build 932).

Changelog:
  • Hopefully it fixes all the stuff we broke last time.
OpenIV Team.

Share this post


Link to post
Share on other sites
rollschuh2282

i try to add lines to the carcols.ymt, but openiv won´t let me save the changes. :/

 

 

LzXmyeD.png

Share this post


Link to post
Share on other sites
Remix1994PL
Hello, I do not understand a thing. Can I ask for an explanation?

 

illSZCzbRY_ngHMKi5yEPw.png

 

As you can see from the screen, I have two modifications installed.

One of them is:

<Item>dlcpacks:\wov\</Item>

 

<Item>dlcpacks:\wov_expansion\</Item>

 

The second one is:

 

<item qv="bill1">dlcpacks:\LA_Billboard_P1\</item>

 

<item qv="bill2">dlcpacks:\LA_Billboard_P2\</item>

 

<item qv="bill3">dlcpacks:\Extra_Mod\</item>

 

 

My question refers to this - why do the names of <item qv = "bill1"> <item qv = "bill3"> appear in the file dlclist.xml for this second modification?

 

Despite these differences, the modification is installed correctly. But I am wondering why and why these strange additions of names.

Is the use of these names correct or is it a mistake ??

 

https://pastebin.com/qYZ9edDk

 

Btw. If I install another modification of .OIV from the same author, these strange names are no longer shown.

Zs9WttJwSGOO5uqn9F6Iog.png

Edited by Remix1994PL

Share this post


Link to post
Share on other sites
OpenIV Team

@@Remix1994PL those values are added by the author, as you can see in the installation code:

 

<archive path="update\update.rpf" createIfNotExist="True" type="RPF7">	<xml path="common\data\dlclist.xml">		<remove xpath="/SMandatoryPacksData/Paths/item[@qv=bill1]"/>		<remove xpath="/SMandatoryPacksData/Paths/item[@qv=bill2]"/>		<remove xpath="/SMandatoryPacksData/Paths/item[@qv=bill3]"/>		<add xpath="/SMandatoryPacksData/Paths" append="Last">			<item qv='bill1'>dlcpacks:\LA_Billboard_P1\</item>		</add>		<add xpath="/SMandatoryPacksData/Paths" append="Last">			<item qv='bill2'>dlcpacks:\LA_Billboard_P2\</item>		</add>		<add xpath="/SMandatoryPacksData/Paths" append="Last">			<item qv='bill3'>dlcpacks:\Extra_Mod\</item>		</add>	</xml></archive>
He is using them to remove previos version of this mod if it was installed before. Those values should not affect game in any way.

Share this post


Link to post
Share on other sites
rollschuh2282

@@rollschuh2282 what exactly are trying to change? Can you please upload changed file content to https://pastebin.com/ ?

i am over the limit for pastebin, so i will give you text files with the content to download.

 

content i want to add: https://mega.nz/#!YtNxnRwZ!qNLkAQWztzqNJpAi8uiAlhptpuLu8CJoDtpA4wN6Gek

complete carcols with wanted content added: https://mega.nz/#!It0SmaTL!jBOvbhwHpRBuV3aLyrIdDqlS_SF9urbAbPmiH4XVIiM

 

i hope this helps.

Edited by rollschuh2282

Share this post


Link to post
Share on other sites
OpenIV Team

@@rollschuh2282 here:

 

<Item>	<kitName>290_jb700_modkit</kitName>	<id value="290"/>	<kitType>MKT_SPECIAL</kitType>	...</Item>
The "id" value might not be more than 255.

Share this post


Link to post
Share on other sites
rollschuh2282

@@rollschuh2282 here:

<Item>	<kitName>290_jb700_modkit</kitName>	<id value="290"/>	<kitType>MKT_SPECIAL</kitType>	...</Item>
The "id" value might not be more than 255.

 

but R* increased the limit with the doomsday heist dlc, it´s now possible up to 1024.

btw. with smuggler run R* added a modkit for the cuban800 to add bombs to it, and that does have id: 285, so it shouldn´be a problem.

is this a limit in openiv that needs to be increased after the doomsday dlc?

Edited by rollschuh2282

Share this post


Link to post
Share on other sites
OpenIV Team

@@rollschuh2282 well... as for now, you can use XML version of the file to have IDs more than 255.

Share this post


Link to post
Share on other sites
rollschuh2282

@@rollschuh2282 well... as for now, you can use XML version of the file to have IDs more than 255.

Do you mean, simply rename the .xml file to .ymt, and it will work?

Share this post


Link to post
Share on other sites
OpenIV Team

Yeah, it should work [in game] as long as file is valid.

Share this post


Link to post
Share on other sites
Redman''

hey there. all the badges/emblems/patches on story characters (decl_000_u.ydd) are missing ingame as soon as asi tool is installed.

 

i'm not the only one. any help there or do i have to install something else? thanks.

Share this post


Link to post
Share on other sites
rollschuh2282

i found a new bug: when you copy a folder with other folders in it with the windows file explorer to the game folder while openiv is open, it shows the folders but you can´t open them without restarting openiv.

note that the folders aren´t even listed in the "file list"

66vLmkM.png

Share this post


Link to post
Share on other sites
OpenIV Team

hey there. all the badges/emblems/patches on story characters (decl_000_u.ydd) are missing ingame as soon as asi tool is installed.

 

i'm not the only one. any help there or do i have to install something else? thanks.

Can you please provide the exact steps to reproduce for this issue?

Because it's very unlikely that anything from ASI manager can cause this issue.

 

 

 

i found a new bug: when you copy a folder with other folders in it with the windows file explorer to the game folder while openiv is open, it shows the folders but you can´t open them without restarting openiv.

note that the folders aren´t even listed in the "file list"

How exactly you copy those folder? Drag-n-drop? Copy/paste? Cut/paste?

Are they copied from same disk volume or from another?

Share this post


Link to post
Share on other sites
rollschuh2282

 

i found a new bug: when you copy a folder with other folders in it with the windows file explorer to the game folder while openiv is open, it shows the folders but you can´t open them without restarting openiv.

note that the folders aren´t even listed in the "file list"

How exactly you copy those folder? Drag-n-drop? Copy/paste? Cut/paste?

Are they copied from same disk volume or from another?

 

 

drag-n-drop from same disk volume

Share this post


Link to post
Share on other sites
OpenIV Team

OpenIV Discord server

00.png


We now have Discord server for OpenIV, you can join if you want.

Join

Share this post


Link to post
Share on other sites
kBlaise

Forgive me if this is common knowledge but I'm somewhat new and a bit of a noob to this wonderful tool, but - is it possible to export GTA V cutscene data (character / prop and camera animations, etc.) and import them into 3DS Max somehow?

Share this post


Link to post
Share on other sites
OpenIV Team

You can export models (peds/props), but there is no way to export animations yet.

Share this post


Link to post
Share on other sites
rollschuh2282

 

 

i found a new bug: when you copy a folder with other folders in it with the windows file explorer to the game folder while openiv is open, it shows the folders but you can´t open them without restarting openiv.

note that the folders aren´t even listed in the "file list"

How exactly you copy those folder? Drag-n-drop? Copy/paste? Cut/paste?

Are they copied from same disk volume or from another?

 

 

drag-n-drop from same disk volume

 

 

could you reproduce the Bug, and will it get fixed?

Share this post


Link to post
Share on other sites
OpenIV Team

Yes, will try to fix it in the next update.

Share this post


Link to post
Share on other sites
Redman''

 

hey there. all the badges/emblems/patches on story characters (decl_000_u.ydd) are missing ingame as soon as asi tool is installed.

 

i'm not the only one. any help there or do i have to install something else? thanks.

Can you please provide the exact steps to reproduce for this issue?

Because it's very unlikely that anything from ASI manager can cause this issue.

 

not really:

 

1 - install a fresh and untouched gta5.

2 - go ingame - pe: number on franklin's basketball jersey is there.

3 - install openIV and asi tool

4 - go ingame - number on franklin's basketball jersey is gone.

 

5 - number only shows up again, when i start a fresh installed game. just uninstalling asi tool has no effect.

 

 

that's all i can say about, absolute no idea why this is happening.

Edited by Redman''

Share this post


Link to post
Share on other sites
P2FX

So sometimes openiv.exe seems to stay running in the background after some carcols.ymt editing even though I closed it. Can you look into this?

Edited by P2FX

Share this post


Link to post
Share on other sites
OpenIV Team

5 - number only shows up again, when i start a fresh installed game. just uninstalling asi tool has no effect.

Installing OpenIV or anything from ASI Manager does not affect your game files permanently unless you edit something.

 

 

 

So sometimes openiv.exe seems to stay running in the background after some carcols.ymt editing even though I closed it. Can you look into this?

There was any errors while work or not?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.