Jump to content

fatal error zlib20


Phundamental

Recommended Posts

i play the game for about 15 mins then it crashes. and i get this error code ZLIB20 confused.gifconfused.gif

PC specs? Driver versions? DX versions?

 

Help us to help you. Moved to a more suitable location.

Link to comment
Share on other sites

i play the game for about 15 mins then it crashes. and i get this error code ZLIB20 confused.gifconfused.gif

I receive the same bull crap, any causes or incompatibilities known yet?

Link to comment
Share on other sites

As per the other thread I just posted in,

 

Get your hands on another set of installation media, and reinstall using that.

 

Confirmed working.

 

I was LANing this weekend just gone. A friend was having the trouble you speak of. We did a bit of searching. ZLib is a commonly used compression library. We figured it was probably an error uncompressing something. Given his crash always happens in a few given areas of the map, we figured it's probably a corrupted texture or some such.

 

He had reinstalled 3 or 4 times using his disks. Never worked properly. He reinstalled using mine, worked perfectly.

 

Enjoy the game! (I know I am!)

Link to comment
Share on other sites

As per the other thread I just posted in,

 

Get your hands on another set of installation media, and reinstall using that.

 

Confirmed working.

 

I was LANing this weekend just gone. A friend was having the trouble you speak of. We did a bit of searching. ZLib is a commonly used compression library. We figured it was probably an error uncompressing something. Given his crash always happens in a few given areas of the map, we figured it's probably a corrupted texture or some such.

 

He had reinstalled 3 or 4 times using his disks. Never worked properly. He reinstalled using mine, worked perfectly.

 

Enjoy the game! (I know I am!)

THANK YOU GREATLY, But damn you Rockstar :_( i wish they fix it in the patch, i'll wait and see before replacing my disk.

Link to comment
Share on other sites

So the only known way to fix this so far is to reinstall using someone elses disks? what a crock of sh*t this games turned out to be

Link to comment
Share on other sites

As per the other thread I just posted in,

 

Get your hands on another set of installation media, and reinstall using that.

 

Confirmed working.

 

I was LANing this weekend just gone. A friend was having the trouble you speak of. We did a bit of searching. ZLib is a commonly used compression library. We figured it was probably an error uncompressing something. Given his crash always happens in a few given areas of the map, we figured it's probably a corrupted texture or some such.

 

He had reinstalled 3 or 4 times using his disks. Never worked properly. He reinstalled using mine, worked perfectly.

 

Enjoy the game! (I know I am!)

THANK YOU GREATLY, But damn you Rockstar :_( i wish they fix it in the patch, i'll wait and see before replacing my disk.

eh. If it's what I think it is (A corrupted file on the DVD, perhaps a corrupted cab file or texture etc), then a patch isn't going to fix anything.

Link to comment
Share on other sites

As per the other thread I just posted in,

 

Get your hands on another set of installation media, and reinstall using that.

 

Confirmed working.

 

I was LANing this weekend just gone. A friend was having the trouble you speak of. We did a bit of searching. ZLib is a commonly used compression library. We figured it was probably an error uncompressing something. Given his crash always happens in a few given areas of the map, we figured it's probably a corrupted texture or some such.

 

He had reinstalled 3 or 4 times using his disks. Never worked properly. He reinstalled using mine, worked perfectly.

 

Enjoy the game! (I know I am!)

THANK YOU GREATLY, But damn you Rockstar :_( i wish they fix it in the patch, i'll wait and see before replacing my disk.

eh. If it's what I think it is (A corrupted file on the DVD, perhaps a corrupted cab file or texture etc), then a patch isn't going to fix anything.

Yes but perhaps it isn't that?, No one has mentioned what this error actually is, so i'll wait a few days for patch, if that doesn't work i'll return it, and go from there

 

 

 

suicidal.gifrahkstar2.gif

Link to comment
Share on other sites

 

So the only known way to fix this so far is to reinstall using someone elses disks? what a crock of sh*t this games turned out to be

Nope. I had exatly the same error message and game crashed every 5 min. R* answer to problem is reinstall the game, i did that and it worked fine 2 hours but then the game started crashing again, then i downloaded the game from the internet and no crashes so far. I wonder what i should do with the original game discs, since obviously patch aint gonna help at all, smash the game discs with a hammer or thrown this piece of sh*t out of window?

Link to comment
Share on other sites

same problem as you guys... so i can just reinstall the game and hope that everything' ll work fine?! dammit, another crap R*'s joke

Link to comment
Share on other sites

I try to make a "control of integriti of cache" on GTA 4 with STEAM, and the game is making an Update !

 

2.3MB/s but it's long ...

Link to comment
Share on other sites

Completely bugged ! The game wait wait wait and never start ... I uninstal it , i'm downloading on steam right now.

Link to comment
Share on other sites

This error is BS, R* best sort this one out as there seems to be no fix suggested by anyone. I cant belive that it is simply a case of the brand new disks being screwed. I'm getting sick of the people who can play it whining about fps and how R* must sort it out in the patch, when I've got a decent set up (E8400, HD4850, 4GB OCZ Platinum RAM) and paid £25 for a new game that does'nt work. I'm not expecting to play the game and get 200 fps at high settings, I just would like to play the game for more than 30 mins without a crash to desktop.

Link to comment
Share on other sites

This error is BS, R* best sort this one out as there seems to be no fix suggested by anyone. I cant belive that it is simply a case of the brand new disks being screwed. I'm getting sick of the people who can play it whining about fps and how R* must sort it out in the patch, when I've got a decent set up (E8400, HD4850, 4GB OCZ Platinum RAM) and paid £25 for a new game that does'nt work. I'm not expecting to play the game and get 200 fps at high settings, I just would like to play the game for more than 30 mins without a crash to desktop.

EXACTLY , i bought the day after release and the disc has no scratches, no visible problems and yet this bullsh*t still pops up all the time.

 

 

So they shipped faulty copies and don't want to acknowledge it?

Link to comment
Share on other sites

THE GAME CRASHES!!!! I CAN'T STAND IT ANYMORE!!! PLEASE DO SOMETHING ROCKSTAR PLEASE!! I HAVE THE RETAIL VERSION AND THA GAME CRASHES TO THE DESKTOP AFTER 10-20 MINUTES OF GAMEPLAY. I HAVE THE NEWEST DRIVERS OF ANY DEVICE ON MY PC BUT STILL THE SAME PROBLEM!!! PLEASE HELP ME. GOD DAMN ZLIB20 ERROR!!! I'M SO FURSTRATED!!

 

 

 

PC Specs:

Intel Q6600 @3.0Ghz

Nvidia GeForce 8800GTX

2GB RAM 1066Mhz

Vista Premium 32Bit

 

 

HELLPPPPPPPPPPP!!

Link to comment
Share on other sites

TheRealDadBeard

i have my original copy of gta 4 lying here but when i install from the disk i always get that error, got a version from the net and played for about an hour without problems, i seriously think rockstar has to change the cds

Link to comment
Share on other sites

Fatal error zlib20 come up every 2 minutes. Some time blues screen of dead. I can't even play.

 

My PC Spec IS

OS: Windows Vista Ultimate Service Pack 1

Processor: Intel Core 2 Quad CPU Q6600 @ 2.4GHz

Memory(RAM): 4.00GB (OCZ DDR2 PC2-8500 / 1066 MHz 2GB Module) X

Video Card: PNY 9600 GT 512mb DDR3

 

It crashed even in the lowest Resolution. cryani.gif

 

Link to comment
Share on other sites

I want that damn patch, otherwise might replace my disks/ go find a torrent

 

WAY TO GO ROCKSTAR, SUPPORTING PIRACY

Link to comment
Share on other sites

I`m getting the error from my disk too...

 

I`m now downloading the game and i`ll see if that fix`s things.

Come back when your done.

Link to comment
Share on other sites

TheRealDadBeard
I`m getting the error from my disk too...

 

I`m now downloading the game and i`ll see if that fix`s things.

Come back when your done.

fo myself the disks from the net worked...played for about an hour without crashes or something...before it was like i played 15 minutes and bam...zlib20....

Link to comment
Share on other sites

 

I`m getting the error from my disk too...

 

I`m now downloading the game and i`ll see if that fix`s things.

Come back when your done.

fo myself the disks from the net worked...played for about an hour without crashes or something...before it was like i played 15 minutes and bam...zlib20....

hmmmm,i can't be bothered downloading 14 GB and waiting a few days for it, i might go replace my disk, i'll just wait for the patch to be able to see if it improves it,

 

thankyou though

Link to comment
Share on other sites

I`m getting the error from my disk too...

 

I`m now downloading the game and i`ll see if that fix`s things.

Come back when your done.

installing now, be back with the results.

Link to comment
Share on other sites

i bought the game, im getting either zlib20 or general failure (gta iv has stopped working)

 

the only other option that i've been told by rockstar is to copy both game discs to a folder on my harddrive and install directly from there. im going to try this now and see if it works.

 

the other option they suggested was to return the game discs. i cant drive an hour to the closest store to do so, so i will have to try option 1 first.

 

im not here to complain, i just want to play.

 

specs (in case there are system specific causes of this issue):

mobo: k9a2 platinum

mem: kingston hyperx @ 1066 2.2v 5-5-5-15

proc: amd phenom 9850 (no overclock)

data hd: seagate barracud 7200.11 in raid-0

video: sapphire radeon hd 4850, catalyst 8.12, driver 8.561 (newest, which in my case doesnt support crossfire so i took my second card out)

sound: external m-audio fast track ultra 8inx8out USB interface

 

 

Link to comment
Share on other sites

after installing the game from different disks, i have crashed to the desktop countless times, and got the forever loading bug, but i didn't get the zlib20 error so i don't know if this fixes things, i don't even think i was able to play long enough to get the zlib error...

 

i'm pissed off at how sh*tty this game's running, if the patch doesn't fix things I'm getting my money back for this garbage. I've wasted too much time with this...

 

good luck to you guys.

Link to comment
Share on other sites

Some potential ideas you may want to try:

 

1) Install DAEMON TOOLS - Chance of working: low-med

This is a virtual dvd application that emulates DVD drives. Create an image of the GTA IV dvd using any suitable application (Alcohol 120% (shareware/30-day trial) and similar). Mount this image in Daemon Tools and play with the emulators. For instance, you could enable (or disable?) the SecuROM emulation, install the game and see if it changes anything.

 

2) Use Sysinteral's FileMon Application - Chance of working: med-high

Google for Sysinternals (this is a part of Microsoft) and grab yourself the application called FileMon (or for vista users the more complicated Process Monitor). I will not go into more speciffic instructions for how to use this application here, as it's rather easy to use (Capture/Clear log is the only things you need to know now, they are both in the toolbar). Start capturing with FileMon (you'll see alot of activity in the log immediately). Start GTA IV and wait for it to crash. Immediately rush to FileMon and turn off capturing. Look for any errors in the log (it should now be among the 1000 or so last lines). If you find a file that looks like it may be the cause of the problem, and it's a suitable size you can rush over to a friend and copy this file hoping it will fix it. If nothing else then we have atleast identified it, and we may be able to do something else about it.

 

NOTE: SecuROM doesn't like either of those solutions and it's possible that you won't be able to launch the game after using either one. If this is the case you need to uninstall Daemon Tools and/or reboot your computer to unload the temporary kernel driver installed by FileMon.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.