Jump to content

Car components position problem in game


SolarGoldRaptor

Recommended Posts

SolarGoldRaptor

Hi,

 

I've finally managed to put my WIP (Ferrari 512BB) in game but there I must have done something wrong because the car components are misplaced mercie_blink.gif . Here are two picture showing what I'm meaning. :

Picture one The components are huge and the model is halfway through the floor making it hard to drive. All parts are misplaced.

Picture two After a bit of tweaking in 3DS Max the chassis and doors seems to have the right size, but the other parts are too small and totally misplaced.

The car shows correctly in DFFViewer bored.gif

 

I'm not sure but it might come from the way 3DS Max controls the position of the different objects of a scene.

 

Thanks for the help,

Bye

Link to comment
Share on other sites

I am not using 3Ds Max but I know what is your problem.

1.Try to attach all the objects that are from the same group. For example the chasis must be only one model. the windows, doors apart.

2.Another thing is that the pivot of the model and the dummy must match.

try to find out how move only the pivot in 3ds max.

 

Advice: Try to put on the textures before U can step to point 1.

Link to comment
Share on other sites

SolarGoldRaptor
I am not using 3Ds Max but I know what is your problem.

1.Try to attach all the objects that are from the same group. For example the chasis must be only one model. the windows, doors apart.

2.Another thing is that the pivot of the model and the dummy must match.

try to find out how move only the pivot in 3ds max.

 

Advice: Try to put on the textures before U can step to point 1.

Step 1 is already done (doors open when I get in the car, all the parts go away when the car explodes, ect...).

 

Step 2 might be the problem, I'll check it out wink.gif

 

Thanks

Link to comment
Share on other sites

 

I am not using 3Ds Max but I know what is your problem.

1.Try to attach all the objects that are from the same group. For example the chasis must be only one model. the windows, doors apart.

2.Another thing is that the pivot of the model and the dummy must match.

try to find out how move only the pivot in 3ds max.

 

Advice: Try to put on the textures before U can step to point 1.

i do pal, and i can help, this is a common problem, but once you know how to solve it, it's hard to repeat it, this also matters to you as it involves basic 3D editing:

 

@SolarGoldRaptor

 

Congratulations, now that you are into the marvelous world of bugs it's time for you learn how to solve them (if not all, at least most of them)

 

1.- First, into 3D Studio (or any other editor) broke all your hierarchy (you were able to export the model with independent parts, so i assume you know how to manage hierarchy), then go to your Modifier Panel and look for "Reset X-Form" Modifier, look around, i'm sure you will find it.(here's where maybe other editors have it's differences, but the idea is to get the "Reset Xform" modifier) this will fix the size of the parts (you must apply this modifier to every mesh/component of you car (it don't affect dummies but just for avoid future problems don't apply the Reset X-Form to them)

 

2.- At this point you should have hierarchy broke, it's important, VERY important that if you will place a part of your car, move or modify, you do it while you have it with no hierarchy defined, once you link all your parts (making the hierarchy) there is no way back (well yes, unlink all the objects from it's parent) this will fix your problem with the misplaced parts.

 

Also never modify pivots if a hierarchy exist, and hierarchy must be your very last move before export, now attention, when you have a dummy, this actually have direction by itself, so if you rotate it's pivot, or the dummy, the result will be also buggy, try only moving them and nothing else than that, and i repeat, only when no hierarchy exist

 

Edit:

IF you have already dummies for boot,bonnet,doors and anything else, i recommend you to delete them, after you do the past step, use kams editing tool to create new dummies, and i hope you didn't made the *_dam parts, cause you will have to move them according with it's corresponding *_ok parts.

 

----------------

Now playing: Chris Vrenna - Pandemonium

via FoxyTunes

Edited by H13N.H3N
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.