Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
      4. Frontier Pursuits
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. DLC
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
      7. The Diamond Casino Heist
    2. Grand Theft Auto Series

    3. GTA 6

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA IV Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA SA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA VC Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA III Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

Loste.One

Rain/Thunderstorm Bug

Recommended Posts

Loste.One

So has there been a definite fix for the rain bug? For those who don't know, the rain bug is when it's raining and all you can hear is the radio and the rain but cannot hear the car engine, cutscene dialogue, gunfire, or any dialogue in general. I have tried getting the latest audio drivers for my Realtek HD Audio onboard. That did not solve anything, I tried lowering my sound acceleration to basic but when there is rain, my frame rate drops (although I can hear things when it rains). So my question is; is there any patch fix or anything like that I can use so I can at full sound hardware acceleration while still hearing sound when it rains?

Share this post


Link to post
Share on other sites
Ryan

What are you talking about. I've never heard of this so called bug. monocle.gif

 

Do you have a downloaded version of the game?

Share this post


Link to post
Share on other sites
Loste.One
What are you talking about. I've never heard of this so called bug. monocle.gif

 

Do you have a downloaded version of the game?

No it's an actual bug, when R* released the 1.01 patch, they even addressed that they fixed this "Thunderstorm/Rain Bug", but I do not want to update to 1.01 because I would not be able to mod it.

Share this post


Link to post
Share on other sites
Ryan
but I do not want to update to 1.01 because I would not be able to mod it.

Yeah you would.

 

Just install the patch, and then use the downgrader patch which allows you to mod version 2 of San Andreas.

Share this post


Link to post
Share on other sites
aFinn

I have the same problem and I am using v2 of the game.

Share this post


Link to post
Share on other sites
Ryan
I have the same problem and I am using v2 of the game.

Really? dontgetit.gif

 

I've never had the problem, nor heard of it.

Share this post


Link to post
Share on other sites
aFinn

I've read quite a lot about it here, been interested about it since I have that problem. I've read it's supposed to be fixed with 1.01 and v2, but I still have it. I have not updated my drivers though, but since OP did and it didn't help, I'd be interested to know the solution also.

 

I have store bought version of game, unmodified. I also have Realtek HD Audio.

Edited by aFinn

Share this post


Link to post
Share on other sites
Loste.One
but I do not want to update to 1.01 because I would not be able to mod it.

Yeah you would.

 

Just install the patch, and then use the downgrader patch which allows you to mod version 2 of San Andreas.

Correct me if I'm wrong, but once you downgrade, doesn't that mean you are back to San Andreas 1.0?

Share this post


Link to post
Share on other sites
Road Kill Cafe

I've had this problem in the past with my onboard Realtek audio too.

 

Sound Fix

 

Just backup your eax.dll, then download and replace it with the eax.dll in the archive. Hope it solves your dilemma.

Share this post


Link to post
Share on other sites
Ryan
Correct me if I'm wrong, but once you downgrade, doesn't that mean you are back to San Andreas 1.0?

NO. It doesn't That is the big thing that people don't understand about the downgrader. They think it turns their game into a version 1 game. It's not that simple. All the downgrader does is allows you to mod the game. It replaces some files here and there which in turn allow you to mod V2 of SA.

 

If you were to go and downlaod a V1 save after downgrading it wouldn't work for you as your game is still V2.

Share this post


Link to post
Share on other sites
Doomed_Space_Marine
If you were to go and downlaod a V1 save after downgrading it wouldn't work for you as your game is still V2.

Isn't this because of main.scm version?

Share this post


Link to post
Share on other sites
crazyanurag
If you were to go and downlaod a V1 save after downgrading it wouldn't work for you as your game is still V2.

Isn't this because of main.scm version?

Yes, true.

 

But this is related to the downgrader question in that if a player were to downgrade from V2 to V1, it's only a cosmetic fix to make the game moddable. It doesn't change the scripts.

 

Anyhow, thisis going way off-topic, if you ask me. Let's just stick to the bug discussion.

 

You'll Never Walk Alone

Share this post


Link to post
Share on other sites
Loste.One
I've had this problem in the past with my onboard Realtek audio too.

 

Sound Fix

 

Just backup your eax.dll, then download and replace it with the eax.dll in the archive. Hope it solves your dilemma.

Thanks for trying to help. smile.gif

But unfortunetly it did not work. I did not notice a difference from using the different versions of eax.dll.

Share this post


Link to post
Share on other sites
midwestfan

I have the same problem. Pretty much makes the game unplayable. facedesk.gif

Edited by midwestfan

Share this post


Link to post
Share on other sites
Girish
I have the same problem. Pretty much makes the game unplayable. facedesk.gif

Have you tried changing your sound acceleration to basic or none?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.