Jump to content

Problem With Steam Version and Existing Save Files


thor79

Recommended Posts

Ok so I bought and downloaded the GTA pack off of Steam. The game runs just fine...but the controller doesn't work quite like the way my ps2 controller worked when I first bought SA (I sold it and the ps2 a while ago)...so I suck at the lowrider challenge (The Ceasar mission early in the game). I tried downloading the save files for that mission but none of them work. They all crash the game to desktop. I've tried running them through the id converter as well and no go. The game shows version 3.00 on the menus so perhaps something else has changed with the save games...like maybe they have a new id like version 2 had a new id from version 1. Anyone willing to check out a save file from the new version to see if there is indeed a difference from version 2? Or does anyone have any suggestions for getting version 2 save games to work on version 3?

Edited by thor79
Link to comment
Share on other sites

Getting older version saves to work on the steam version is probably possible, but I'd need to see a couple things in order to tell you what to do.

 

1st) Any save file. Just fire up a new game, beat big smoke, and then upload the save to http://gtasnp.com and post the link here or PM it to me.

 

2nd) The mission scripts. That is the two files main.scm and script.img found in the data/script directory. Zip em up and upload it somewhere and again send me the link.

 

If you can do that, I'll try my best to come up with a way to use v1 and/or v2 saves on v3.

Link to comment
Share on other sites

here's the other files requested:

http://www.thunder-god.net/stuff/game/gtas...ion_scripts.zip

 

and here's the save file:

http://www.thunder-god.net/stuff/game/gtasa/GTASAsf1.b

 

I uploaded the save file as well just in case the other site tried to convert it or something...

 

 

Thanks for whatever help you can offer. This version 1/version 2 stuff wasn't around when I first played SA.

Link to comment
Share on other sites

Tried save #7 (Cesar Vialpando) and it worked fine. Thanks.

 

What's the difference in the files in that thread? Just that they are originally version 1 with version 2 mission scripts with the id changed to match version 2?

 

 

Sure wish Rockstar would release patches to bring everything to one version...would make this crap a hell of a lot easier.

Link to comment
Share on other sites

Yeah, those files were made on the v1 executable using the v2 mission scripts and then patched to have the v2 ID. Note that there is a bit of a problem with that process regarding some map objects so the bridge barriers might not show up and there might be some weirdness regarding the crack factory seen in the mission Yay Ka-Boom-Boom.

 

Because of this there are actually two better options for you.

 

The first is using a save from a set of "true" v2 saves made with the v2 executable. Ryan92 posted a set of these but I had forgotten about them until just now. blush.gif

 

The other is to post a Save N Play request in the Mission Help forum where you upload your save, someone does the mission for you, then you download that save and continue from there. Since it appears version 3 is pretty much exactly the same as version 2 as far as the script & saves go, you would note in the topic that the helper needs to use the v2 scripts.

Link to comment
Share on other sites

Very cool...thanks a lot biggrin.gif

 

One of the most helpful communities I've run into in a while smile.gif

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.