Jump to content

VCMP Health bar & Names not shown


barroombrawler

Recommended Posts

barroombrawler

I installed the 0.3z (newest to my knowledge) VC:MP and I cant see anyones name or health bar in littlewhiteys server. Its like playing blind. I have no clue to who is around me or what their health status is.

I ask if other in the server could see them & the ones that answered said they could.

What could the problem be? I assume its on my end or a install issue?

Can anyone help me out?

All else works perfect except I cant see player names above their heads nor there health status.

Link to comment
Share on other sites

barroombrawler

I tired the f4 key but it still isnt working. My f5,f6,&f12 key all work.

Any other ideas?

Clean install maybe?

Link to comment
Share on other sites

When you install VCMP for the first time, the health bar and names are there by default!

 

OK, try to see if your F4 key works in Windows?

Link to comment
Share on other sites

barroombrawler

Yes that what I figured that they would work by default but f4 is the only one that wont work. I forgot to mention that the f4 key will work in my internet 6 browser.

I can get all the other f keys to work expect the f4 suicidal.gif

Im running the newest graphics driver as well for the video card.

Is there something in the config file that needs to be messed with?

It has me completely baffled as to why it wont work.

Im running firefox as my default browser. Maybe a setting in firefox that is blocking the function of this f4?

Any ideas?

 

Just made IE6 my default browser again and clean out my temp files and user.dat files.

I can provide screenshots if you want to see the f5 key and other work. But I still cant get the f4 key to respond. I tried the f4 key in firefox and ie and it works just fine.

Edited by barroombrawler
Link to comment
Share on other sites

  • 2 weeks later...

Try uninstalling VCMP, delete the main folder, delete all HKCU/HKLM registry entries associated with it, and reinstall VCMP 0.3z. Now try pressing F4.

Edited by Ring_of_Fire
Link to comment
Share on other sites

barroombrawler

 

Did you ever manage to get your f4 working? Just curious.

No not at all.

All other f keys work.

On another site they suggested it was a video card and asked what I was running. Which is a AGP XFX Force Card with a Nvidia chipset. It supports DVI,TV,VGA. I think is was made in 2004. I bought it in 2005 or 06. I never used it for vice city but it doesnt seem to have any conflicts when I try the game out in single player.

Device Manager Details it as follows;

Nvidia Ge Force FX5500. Im running the latest Nvidia Driver dated:9/07 Driver Version 6.14.11.6371

They suggested using older drivers and seeing what that comes up with but Im having a hard time finding older drivers for it. I never backed them up except for the one on the cd that the card came with. They also asked about my keyboard which is brand new. Its a microsoft Natural Ergonomic 4000. I tried the newest driver for that as well not knowing if it matter or not but that was one thing I thought of. Not sure how they rated the keyboard but its nice and comfy for my paws.

I was wondering if directx 9.0c was causing a conflict. Although vice city runs just fine with it. Actually with this video card and directx 9 c the game looks better now then it did back in 03 when I first got it. lol.

 

RingOfFire, Thanks Ill try your next idea and will post to let you know. Do you know how many registry entries there are? Im not that familiar with the entries. I know how to open the registry (regeidt) but not sure what folder vcmp entries would be in. Thanks for helping.

 

*Update* Eh! I think I need a little more help in finding the reg keys R.O.F.. Can you direct me to where I can find them?

So far this is all I found HKEY Current User,Software,VCMP folder,Default-gtalc_exe-gatvc_exe-& player name

thanks!

Edited by barroombrawler
Link to comment
Share on other sites

Look for "Grand Theft Auto", "Vice City", "Rockstar Games", "Vice City Mutliplayer", "VCMP" in:

 

1. HKLM (Local Machine)

2. HKCU (Current User)

 

Note: If there are subkeys, make sure you delete the root of the entire directory. This assumes you did a *fresh install* already using my steps!

 

After doing this, make sure your F4 key is working in Windows and reinstall VCMP now! http://www.vicecitymultiplayer.com

 

 

Now press on the F4 key ocne you connect to the Littlewhitey server, if and only if there are no Player HP's showing up.
Edited by Ring_of_Fire
Link to comment
Share on other sites

barroombrawler

R.O.F. Would these entries still be on my os drive even if I have the game installed on a storage drive?

Basically I have 2 drives one which has xp installed on it. I keep my programs on it and use it for surfing the net.

The Storage drive is mainly for installing games on it. So I have a dedicated game drive.

When I click control panel, and go to add/remove programs GTA isnt listed on my Xp drive.

When I installed the game, I changed the directory to my storage drive and let it install there.

So far I have found anything in the HKLM or HKCU folders in the registry only what I posted above.

Link to comment
Share on other sites

 

R.O.F. Would these entries still be on my os drive even if I have the game installed on a storage drive?

Basically I have 2 drives one which has xp installed on it. I keep my programs on it and use it for surfing the net.

The Storage drive is mainly for installing games on it. So I have a dedicated game drive.

When I click control panel, and go to add/remove programs GTA isnt listed on my Xp drive.

When I installed the game, I changed the directory to my storage drive and let it install there.

So far I have found anything in the HKLM or HKCU folders in the registry only what I posted above.

Just do what I said, you don't have to worry about it. Plus there's System Restore to undo the "damage" you did to the registry.

Link to comment
Share on other sites

barroombrawler

Well Im sh*t outta luck on this. Tired everything & it still doesnt work.

Guess Ill have to wait for it to possibly get fixed in 0.4 version of vcmp if that is in the workings.

Enjoyed playing vcmp though. It was cool.

Link to comment
Share on other sites

 

Guess Ill have to wait for it to possibly get fixed in 0.4 version of vcmp if that is in the workings.

That's utter rubbish. VCMP don't provide support for the F4 feature that's already working for millions of players. It's your fault.

Link to comment
Share on other sites

barroombrawler

 

That's utter rubbish. VCMP don't provide support for the F4 feature that's already working for millions of players. It's your fault.

 

I wish it was rubbish. But it doesn't work. I would love to invite you over to my house and let you see what I see on my monitor when I play vcmp. Fack! maybe you can figure it out for me then.That would be great for me. Then I wouldn't have to play around trying to get it to work. Playing pussy foot of install,uninstall, remove lines from the registry and so on.

I don't post on thread forums to see what I type for nothing. Or to up my post count. I've been a member here since '03 and when I post it's for a reason.

VCMP may be providing support to millions of players but I know 2 players that don't have the f4 key working. It ain't my fault my nor my friends that our systems or video cards aren't responding.

Something in the code for vcmp is not compatible with xfx video cards is my best and only guess.

I'll even post you some pictures since you believe I'm doing something wrong.

Samp works just fine for me. I see health bars and name tags. So figure that out.

Let me ask you this? What video card are you running?

Link to comment
Share on other sites

All you have to do is to PRESS F4 and it will show up. I can repeat this INFINITE AMOUNT OF TIMES. You don't seem to realize that the programmers of VCMP coded it so that ->

IF KeyPress=F4 then SHOW HealthBarNames END IF

 

 

"Let me ask you this? What video card are you running?"

"Something in the code for vcmp is not compatible with xfx video cards is my best and only guess."

Radeon X1950 PRO. Graphics card has nothing to do with the inability to use input/user-interaction controls.

 

Alright, login into your VCMP account and tell everyone if they ever had problems with their F4 key, and post back your results! devil.gif

 

Or go on the VCMP forums or the Littlewhitey server forum and set up a poll about this.

 

 

VCMP may be providing support to millions of players but I know 2 players that don't have the f4 key working. It ain't my fault my nor my friends that our systems or video cards aren't responding.

 

I'll even post you some pictures since you believe I'm doing something wrong.

Only 2 persons? rolleyes.gif I bet his/her keyboard is plain and simple damaged. Pictures ain't gonna help for something that you have to press.

 

 

I wish it was rubbish. But it doesn't work. I would love to invite you over to my house and let you see what I see on my monitor when I play vcmp. Fack! maybe you can figure it out for me then.That would be great for me. Then I wouldn't have to play around trying to get it to work. Playing pussy foot of install,uninstall, remove lines from the registry and so on.

Perhaps if you could give me a Remote Assistance invite. But anyway, there is only 1 advice for your problem (ignoring what you said about your F4 key working in SAMP). The advice is to make sure your keyboard layout in Control Panel is correct for both your country and keyboard.

Edited by Ring_of_Fire
Link to comment
Share on other sites

barroombrawler

 

Alright, login into your VCMP account and tell everyone if they ever had problems with their F4 key, and post back your results!

Already did this the first time I saw that my key wasnt working in game. I then tried it in my browser and found out f4 worked there. Process of elimination. After I went thru all ideas I could think of I posted on a couple forums. After that I tried a few other servers and talked with people there.

Keyboard isnt damaged, all set the correct way. No other problems except in vcmp.

Just for sh*ts and giggles here are a couple pictures.

First one is with trying to get the key working second is of pressing f5.

Obviously you nor I will ever figure out what the fack is wrong with it so fack it. Ill just stick to samp. There's more people there anyway.

 

user posted image

 

user posted image

Edited by barroombrawler
Link to comment
Share on other sites

Can you still tell me why my F4 key is working then, but not yours? Did it work before? Can you tell me what your keyboard is and if you are using the Windows native drivers for it?

 

Anyway, regarding the screenshots above - press F4 once to show the health bar and names. alien.gif

 

It's only because of this thread why I am going to ask you now to update all your system drivers including chipset, sound, video, CPU, and BIOS. Make sure to delete [.set] file.

 

 

IMPORTANT: Make sure you know that the F4 key for other programs are conflict-free! I also hope your GTAVC isn't modded and that you don't have trainers running at the same time. And please note that the health bar names and tags can be easily rendered on any graphics card, and that feature is enabled by default in VCMP without ever having to use F4!

I am trying my best to recreate your problem, and I am wondering how you manage to allow problems like this to occur?

 

 

I downloaded an upgraded keyboard driver

1. Uninstall any keyboard-related software in Add/Remove Programs

2. Right-click My Computer

3. Properties

4. Hardware

5. Device Manager

6. Double-click "Keyboards"

7. Right-click your keyboard name and select UNINSTALL

8. Reboot.

 

1. Start menu

2. Control Panel

3. Regional and Language Options

4. "Languages" tab

5. "Details" button

6. In the "Settings" tab, make sure that the keyboard input device listed is for your specific country and language ONLY - otherwise remove all of them and leave only or setup the correct one. (Most people use an input language of English United States, and a keyboard layout of United States Dvorak.)

Edited by Ring_of_Fire
Link to comment
Share on other sites

barroombrawler

R.O.F, I know your only trying to help me out here and believe me if it worked I wouldn't pursue this as I have better things to do with my time then try to get someone to believe me that there is a problem if there really isn't.

Im glad that you offered to help me out on it.

I bought a web cam today to actually show you that Im pressing the f4 key in and nothings happens. Ill post a link when I record it. Ill probably load it up on you tube once I get it all set up.

 

Ever since I installed vcmp, that key, (f4) never worked. So I called my friend and emailed him the link to get vcmp. Figured I would see if his f4 key would work after he installed it. A few days later he installed vcmp and told me he couldn't get it working either. We have almost the same system with the exception of a few differences. He's got 512Mb of ram and a cathode ray monitor. Which none of that matters. I have 256mb of ram an a view sonic 19 in.flat screen monitor from new egg 2006.

 

Ok as for my keyboard I never loaded the driver in for it in the beginning when I first installed vcmp. After I saw the f4 key not working in vcmp, I then downloaded the newest driver for the microsoft natural keyboard 4000. I didnt set any hot keys up. I just installed the driver and everything states its working correctly. As I said the f4 key works in my internet browser.

 

That screenshot was taken after I hit the f4 key. Nothing responded. My F12 key which makes the navigation map different sizes in your lower left side of the screen even works. The f4 is the only one that is unresponsive.

 

I am trying my best to recreate your problem, and I am wondering how you manage to allow problems like this to occur?

 

I would love to know how this happened as well because all I did was download and install vcmp and open my gta vice city. I asked several people in several servers if the no cd cracked exe is the cause and alot of players told me they are running the same exe.

 

Going to follow your uninstall instructions for the keyboard driver.

 

Ok I uninstalled the keyboard and rebooted. Check the regional & lang.tab, lang. tab, details tab, and in the setting tab this is what is listed

in the default input lang. English (United States) - US

 

Tired it out and still no good. Ill post a video showing all this hopefully tomorrow 12-10-07

Edited by barroombrawler
Link to comment
Share on other sites

That's insanly wierd. I've never heard of your problem at all. The only thing I can possibly think of is maybe you've got a messed up copy of vc-mp? Where di you download it from?

Link to comment
Share on other sites

THE POSSIBLY LAST, LAST AND FINAL SUGGESTION!

 

IF this doesn't work, then GOD doesn't know how to fix your problem! No one will be able to fix your problem (not on GTAForums, not on VCMP, not on the World Wide Web). I am giving out the best of the best advice that you can ever get! moto_whistle.gifBuying a new computer works like a charm or reformatting the entire operating system, and then starting over fresh.

 

Before I begin, your system specs and drivers have absolutely nothing to do with your F4 key not working. It's either a keyboard hardware settings or a VCMP file structure attribute issue...

 

 

1. Download Vice City Multiplayer v0.3z CLIENT here! -> http://www.vicecitymultiplayer.com

2. Assuming you have full administrative access, install it and MAKE SURE you put it in C:\Program Files\Rockstar Games\Grand Theft Auto Vice City!

3. VCMP will install these files and folders:

 

In the DATA directory -> vcmp_maps, VCMP.SCM, vcmp_d.dat, vcmp_w.dat

 

 

In the MSS directory -> vc-mp.flt

 

 

In the TXD directory -> ldvcmp0.txd

 

 

In the root directory -> vc-mp.exe, vcmpfnt.dat, vcmpfnt.png.

 

4. Right click ALL ITEMS and uncheck "READ-ONLY" and "Unblock" (if that option is there) and Apply and OK!

5. Now turn off your 3rd-Party FIREWALLS, including Windows Firewall (because I am not sure you allowed VCMP full access) and then test your F4 key!  devil.gif

Edited by Ring_of_Fire
Link to comment
Share on other sites

barroombrawler

 

Where di you download it from?

All I did was type in vcmp in google and it brought up this link http://www.vicecitymultiplayer.com/

I downloaded the 3z client. And just installed from there.

Its been frustrating the hell outta me since I installed it. I dont know what else to do with it. Believe me there were plenty of times I felt like just stickin my fist thru it or throwin the hole thing out the window and watch the cars run over my pc.

 

R.O.F. Ill try out the last suggestion and just for note, Im not running any firewalls. Just a free antivirus program.

Ill let you know.

Link to comment
Share on other sites

I think I already failed. Making all the files read-only doesn't make a difference on my machine - in an attempt to simulate your problem. I am not even gonna bother try to go further by deleting and editing the core files. Do you as a thread starter know what will work?

 

Remember this, you somehow manage to get SAMP to work and it has almost similiar GUI and coding like VCMP (I think). Also, remember this!

 

 

VC-MP.EXE---------IF KeyPress=F4 then SHOW HealthBarNamesEND IF

 

Why is your problem here disagreeing with the code?

Edited by Ring_of_Fire
Link to comment
Share on other sites

barroombrawler

Im addin my camera software now. Like I said Im not at all sure why it wont work. That was why I posted on a couple forums thinking someone out there would have a problem like me. Now Im hoping someone beside my friend and I are the only two out here with it not working.

Ill post a video of everything so you can see I aint bullshatin ya. wink.gif

Link to comment
Share on other sites

I would recommend talking to the official programmer of VCMP at the VCMP forums. If he doesn't have a possible clue as to what may cause it, it's safe to assume that you are lying and just making this thread up so as to increase your post count and give us a hard time!

 

Anyway, bring along the video...

 

 

What I realize about the F4 feature in VCMP is that it has some sort of 3D graphical effect in it. Pressing the F4 key in a way IS actually doing something, but no graphics are showing up on top of players, so it just MIGHT be your graphics card and will I will ask you to obviously update the drivers for it, delete [.set] file, and set the resolution to [interest] x [interest] x 32 bit

 

VIQ: (VERY IMPORTANT QUESTION) Are you experiencing ANY graphics problem at all in Vice City single player? Give me some examples like flickering skies, textures, etc.

 

 

vcmpfnt.png

Not sure if that's where the graphic is coded. Could problaby be in the other files like perhaps the VC-MP executable itself. Anyway, thiis is why I wanted you to reinstall VCMP in the same folder as Vice City, so that we can get rid of the idea that it is corrupted files causing it...

 

And I also think you might even have to uninstall/reinstall Vice City including the main folder fully, so as to perhaps get rid of mods? This could explain why SAMP is working - maybe you manage to install San Andreas itself and SAMP correctly? moto_whistle.gif

 

 

lol.gif I can keep continuing!

 

So we already know for a fact that formatting the computer and reinstalling everything back OR buying a new computer is sure to give you are working VCMP copy, right? So let's say perhaps BAD SECTORS are on the hard drive and thus I would recommend using the SCAN/CHECKDISK/DEFRAG utility. Try installing Vice City and VCMP into another location, AWAY from this bad sector! Remember that hard drive can still read the data, but it might read it in a horrible way and will produce horrible results like someone's F4 key not working.

 

^ If bad sectors are on the hard drive, the operating system could be damaged. Buy a new hard drive maybe? How about making the switch to Vista if XP is giving you problems? You can try Windows 98/2000/NT/Me - Vice City and VCMP supports Windows 98 and even San Andreas.

 

 

UP TILL NOW I DON'T SEE THE VIDEO OF YOUR HANDS PRESSING ON THE F4 KEY! yawn.gif

Edited by Ring_of_Fire
Link to comment
Share on other sites

barroombrawler

 

that you are lying and just making this thread up so as to increase your post count and give us a hard time!

Fackin a man thats harsh! But I ain't worried I got video to prove that I aint so the judges ain't gonna throw away the jail key on me. lol.gif

I put together a small video and here is the link. Yea it's a bit dark but that's the best I could get for right now. I plan on getting a longer version and a better screen resolution as well. But this is a quick shot. I asked for plenty of people to not shoot me while I did this but none listened and I ended up having to rush it. So there will be a better version coming.

But this is hard evidence that has my finger pushing the f4 key.

YouTube f4 key in vcmp doesnt work for mehttp://www.youtube.com/watch?v=9S34i_4Tnw0

 

Also a picture of the keyboard I have so you can see where the f4 key is located.

user posted image

Im still learning this camera so bare with me. Im no computer tech and do work another job.

 

As I said before, I install all my game software on a storage drive which is my F:drive. None of my games are on my operating xp system drive. I always use a seperate hdd for my games.

 

 

I would recommend talking to the official programmer of VCMP at the VCMP forums
Where can his email or contact information be found?

 

thiis is why I wanted you to reinstall VCMP in the same folder as Vice City
I got it there. Here's a picture.

user posted image

 

And I also think you might even have to uninstall/reinstall Vice City including the main folder fully, so as to perhaps get rid of mods? 

I did this a few times already with the same effect. Im not running any type of mods at all except for the no cd exe. I havent played this game since I completed it back in 03 or 04. VCMP is the only reason I brought it back out.

 

 

SCAN/CHECKDISK/DEFRAG utility

I use scan disk all the time. When I try to use check disk it refers me to use scan disk. I have norton utilities installed as well which I defrag the system as soon as 10% is fragmented. I always keep the drive in top shape including the gaming drive. I uninstall a game I defrag the drive.

 

 

This could explain why SAMP is working - maybe you manage to install San Andreas itself and SAMP correctly?

 

To be honest here, I installed san andreas only to play samp. I bought san andreas and really didnt have time to play the single player game. But when my friend asked me to join samp and play with him I loaded it and then I loaded samp in. Ive been playing samp well over one year now. This december makes is a full 12 months. I just installed everything one time and all worked flawlessly. Like I said I aint posting here to give anyone a hard time. And I can careless about my post count as Ive been a member since 03. If you check out my post I think its under 20 since 4 years ago. lol.gif All my post threads are legit anyway. I dont know you from the guy in the next post so why would I want to give you a hard time or worry that I only have under 20 posts since 03?

Not to mention,l I was the first guy to say the dev team did a great job on vcmp when someone came in vcmp lw server and said samp wrecks this. I also was happy to find vcmp multiplayer as at least I can play that map for fun and not only do missions. Im just finding out that you can add lcmp's map but have yet the time to do it. Im not a pc techie but Im not newb at the pc either. I do know what Im doing on it and how to fix it when a piece of hardware is broken, running tests, and stuff like that. Im a hardcore gamer since atari 2600 came out. But I also spend a ton of time doing other interests too.

 

 

UP TILL NOW I DON'T SEE THE VIDEO OF YOUR HANDS PRESSING ON THE F4 KEY!

 

^Now you do^ and Ill definitely have a drink to that one tonight. cool.gif

Link to comment
Share on other sites

Alright, you listened to us in a positive manner.

 

Anyway, it seems obvious to me that your keyboard doesn't have an F4 key. If it does something similar (I doubt that), VCMP probably doesn't seem to be recognizing it very well. I say buy a normal keyboard! turn.gif

 

Oops, sorry about that. Hold on

 

EDIT: Can you tell me the model number for that keyboard???

 

QUESTION: I see that the NEW button is where F4 is supposed to be. What exactly is the difference of how the F4 and the NEW commands are initiated?

 

Anyway, I bet if you buy a normal keyboard it will work. I don't like the looks of the layout of that Microsoft keyboard...

 

By the way, what about the tweaking of your display drivers? You didn't quoted that part... I had also several questions you didn't answer.

 

 

Ok I uninstalled the keyboard and rebooted

You uninstalled the keyboard driver in Device Manager? If you did, so how about the IntelliType Pro keyboard software in Add/Remove Programs?

Edited by Ring_of_Fire
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.