Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Diamond Casino Heist
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA 6

      1. St Andrews Cathedral
    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

    3. Suggestions

Please be aware that this is not a tutorial request forum! Use the appropriate topic for the effect.
silvermanblue

Adding (not replacing) cars to GTA SA

Recommended Posts

J16D

 

When I try to get in the car the game crashes. Someone know what did I do wrong?

maybe you have an error in the vehicle.ide

I show you:

 

612, infernus, infernus, car, INFERNUS, INFERNU, null, executive, 5, 0, 0, -1, 0.7, 0.7, 0

 

- the blue color es the number of the car to continue in the vehicle.ide

- the red color are the name of the ".dff" and ".txd" files

- the green color is the type of car

- the purple color is the name in the ID handling (if you use the sacky limits maybe that is the problem) if you don't use, you do not modify

Share this post


Link to post
Share on other sites
~Rammstein!?~

is there a way to do this with weapons? dontgetit.gif

Share this post


Link to post
Share on other sites
CMM

If I don't use HandlingID Adder, any car I add becomes undrivable/crashes game. Using the HandlingID Adder cause weirdness though, vehicles disappear/peds disappear/crashing game. How to add working handling lines w/out the need for HandlingID Adder?

Share this post


Link to post
Share on other sites
wenhan1000

I got a slight problem with the modding. I added a vehical that is based on a vortex (the lcac mod site:http://ryosuke.my-sv.net/mapmod/lcac/index.html) and the noob sh*t started thinking it a plane and thus 1st. Won't turn, 2nd. sinks into the water. Any fix on that will be appreciate, even if it means hacking the scm or making cleo3s.

Share this post


Link to post
Share on other sites
scarface1994
Help! Can't find "hot key" file. DL and extracted all tools but can't find the hot key file in the main dir

you need jacob's car spawner search it in gta forums

Share this post


Link to post
Share on other sites
scarface1994
I got a slight problem with the modding. I added a vehical that is based on a vortex (the lcac mod site:http://ryosuke.my-sv.net/mapmod/lcac/index.html) and the noob sh*t started thinking it a plane and thus 1st. Won't turn, 2nd. sinks into the water. Any fix on that will be appreciate, even if it means hacking the scm or making cleo3s.

handling adder is very buddy so we have to wait for a fix

Share this post


Link to post
Share on other sites
undo

Is there any similar procedure to add cars into Vice City?

Share this post


Link to post
Share on other sites
superninja

Hello.I tried your method and after long time in front of the pc it worked.But i have 2 problems.I spawn the car and there is no sound.I tried your plug in for sound but then my car and all other NPC cars sound like 'BMX bike'.The horn is 'BMX bike' and some other things.My second problem is that i cannot add new motorbikes.I tried and in game it says car spawned and there is no bike.Why is that? nervous.gif

 

thanks

Share this post


Link to post
Share on other sites
muzamilsumra

Hey guys, i have been roaming around dtaforums for a while now and hadnt come to this thing b4...i mean adding cars to san andreas without just replacing them...well so far i had been replacing all cars in san andreas which was kinda pain tounge.gif...

 

But now my problem is tht i have done everything right in adding a car to the game but when i start the game it starts properly and while playing around for just not may b even a min the game crashes and it gives me the following error.

 

GTA:SA Crashed, Debug Info Follows:

 

 

 

GTA Info:

 

 

 

Version: US 1.0

 

Last File Loaded: AUDIO\STREAMS\MR

 

Last Library Loaded: OLEAUT32.DLL

 

Error: Unknown

 

 

 

Assembly Info:

 

 

 

Exception At Address: 0x004FE652

 

Exception Code: 0xc0000005 (EXCEPTION_ACCESS_VIOLATION)

 

 

 

Registers:

 

EAX: 0x00000000 EBX: 0x00001000

 

ECX: 0x00000000 EDX: 0xFF000000

 

ESI: 0x015A9021 EDI: 0x08000001

 

EBP: 0x090023FB ESP: 0x0023FBA1

 

 

Can Anyone Please Help.

 

Share this post


Link to post
Share on other sites
muzamilsumra

Ok Guys My Complain Above is solved...what i did was to just remove the d3d9.dll from the GTA San Andreas Main Directory..well the game works perfect and the cars too.

 

Now i have another problem..The cars have no sound! well i tired changing the "vehicles id" to some other in built cars "id" guess what...IT works...but now the other car does not have sound...i am using the vehicle audio editor ultimate.

 

Any help plz?

Share this post


Link to post
Share on other sites
J16D
Ok Guys My Complain Above is solved...what i did was to just remove the d3d9.dll from the GTA San Andreas Main Directory..well the game works perfect and the cars too.

 

Now i have another problem..The cars have no sound! well i tired changing the "vehicles id" to some other in built cars "id" guess what...IT works...but now the other car does not have sound...i am using the vehicle audio editor ultimate.

 

Any help plz?

the vehicle.ide has nothing to do, to my don´t work the vehicle audio editor ultimate... i have to use the [sA]VehicleAudioEditor.exe it does is to patch the gta_sa.exe but it work fine sigh.gif

Share this post


Link to post
Share on other sites
Rassipassi

how can i add that value,I can only change the entry name.

Share this post


Link to post
Share on other sites
DaDonYordel

Well I followed all instructions... and got a car into the game..unfortunately it had no sound so I downloaded the VehicleAudioEditorUltimate tool, didn't work the way I wanted it to(planes lost their sound).. so I deleted it..

 

So I have a soundless vehicle..driving it around Las Venturas dodging the law..wrecked the car then..ran around with a Police Bike and then on foot and then my game crash

 

here is the errordump

 

 

 

GTA:SA Crashed, Debug Info Follows:GTA Info:Version: US 1.0Last File Loaded: AUDIO\STREAMS\AALast Library Loaded: OLEAUT32.DLLError: UnknownAssembly Info:Exception At Address: 0x00000002Exception Code: 0xc0000005 (EXCEPTION_ACCESS_VIOLATION)Registers:EAX: 0x00000000	EBX: 0x00000000ECX: 0x00000004	EDX: 0x008E4C00ESI: 0x0000E3D8	EDI: 0x00000000EBP: 0x7E42DEB2	ESP: 0x0022FD94

 

 

also there was a crash before this, it was something about the Ambience..

 

can anybody give some assistance to my predicament?

Share this post


Link to post
Share on other sites
DaDonYordel

Is there any limit to how many new cars I can add in the game?

Share this post


Link to post
Share on other sites
darkzwesjel

i cant add vehicles

Open up the handling names file witch file is that ?HandlingAdder.ini?

Share this post


Link to post
Share on other sites
solocord

what the hell is the handling names file called? man this sh*t is just annoying im stuck on step 3 and i dont know what the hell you are talking about.

 

EDIT where do i get the handling names file from? because i have seen other members have it but i don't know where to get.

Edited by solocord

Share this post


Link to post
Share on other sites
nm69

Wot do u guys mean by "up it by 1" in the second step??? rolleyes.gif

am i supposed to hit the backspace infront of "Models" to get it to the previous line or sumthing??

Do reply and thanks tounge.gif

Share this post


Link to post
Share on other sites
wenhan1000

I can't find HandlingNames too but i remembered it working last time with a old ver of the handling adder. Alexender Blade must have deleted it in the newer version. Silvermanblue, hope you can fix this crap.

Share this post


Link to post
Share on other sites
Dodo-Pilot

 

I can't find HandlingNames too but i remembered it working last time with a old ver of the handling adder. Alexender Blade must have deleted it in the newer version. Silvermanblue, hope you can fix this crap.

I`m having troubles with handling adder myself... I`ve tried to contact Alexander Blade on Yahoo and GTAF 3 days ago and still nothing whatsthat.gif

 

I have also created topic about it. Here is the link: http://www.gtaforums.com/index.php?showtopic=373091 (http://www.gtaforums.com/index.php?showtopic=373091)

Edited by Jasenko

Share this post


Link to post
Share on other sites
scarfaceZZ

Can someone post the tutorial video?

Where can i find handlingnames.ini?

Edited by scarfaceZZ

Share this post


Link to post
Share on other sites
wenhan1000

You can't. Akexender Blade removed the handlingnames.ini in the new version of handling adder. Lets just wait for an update.

Share this post


Link to post
Share on other sites
scarfaceZZ

My car cant spawn.

What can i do?

Share this post


Link to post
Share on other sites
Dodo-Pilot
You can't. Akexender Blade removed the handlingnames.ini in the new version of handling adder. Lets just wait for an update.

I don`t think there is going to be newer version. The only reason why this (new version) exist is because of major problems in old one.

But, let`s face it: anyone who is going to add 30-40 new handlings, don`t have time/and or patience to "decompile" data as HandlingAdder requires.

Share this post


Link to post
Share on other sites
wenhan1000

An update from sivermanblue I mean. And what can't of data needs to be decompiled?

Share this post


Link to post
Share on other sites
Dodo-Pilot

 

An update from sivermanblue I mean. And what can't of data needs to be decompiled?

This is handling format used by NEW version of handling adder:

 

 [411]index=11fmass=1400fTurnMass=2725,30004882813fDragMult=1,5x=0y=0z=-0,25nPercentSubmerged=70fTractionMultiplier=0,699999988079071fTractionLoss=0,800000011920929fTractionBias=0,5nNumberOfGears=5fMaxVelocity=1,22800159454346fEngineAcceleration=0,00119999994058162fEngineInertia=10nDriveType=4nEngineType=PfBrakeDeceleration=0,00439999997615814fBrakeBias=0,509999990463257bABS=0fSteeringLock=30fSuspensionForceLevel=1,20000004768372fSuspensionDampingLevel=0,189999997615814fSuspensionHighSpdComDamp=0fSuspensionUpperLimit=0,25fSuspensionLowerLimit=-0,100000001490116fSuspensionBiasBetweenFrontAndRear=0,5fSuspensionAntiDiveMultiplier=0,400000005960464fSeatOffsetDistance=0,370000004768372fCollisionDamageMultiplier=1,02857148647308nMonetaryValue=95000modelFlags=1073750020handlingFlags=12599296frontLight=1rearLight=1animGroup=1

 

 

If you use original handling configuration like this

 

1800.0 3800.0 2.0 0.0 0.2 0.0 75 0.65 0.85 0.52 4 165.0 16.0 25.0 R P 5.0 0.60 0 30.0 1.0 0.1 0.0 0.20 -0.10 0.5 0.2 0.24 0.48 18000 2020 1 1 3 0

game will most probably crash.

Share this post


Link to post
Share on other sites
wenhan1000

So it works as long as you jam the handling like this?

 

[411]index=11fmass=1400fTurnMass=2725,30004882813fDragMult=1,5x=0y=0z=-0,25nPercentSubmerged=70fTractionMultiplier=0,699999988079071fTractionLoss=0,800000011920929fTractionBias=0,5nNumberOfGears=5fMaxVelocity=1,22800159454346fEngineAcceleration=0,00119999994058162fEngineInertia=10nDriveType=4nEngineType=PfBrakeDeceleration=0,00439999997615814fBrakeBias=0,509999990463257bABS=0fSteeringLock=30fSuspensionForceLevel=1,20000004768372fSuspensionDampingLevel=0,189999997615814fSuspensionHighSpdComDamp=0fSuspensionUpperLimit=0,25fSuspensionLowerLimit=-0,100000001490116fSuspensionBiasBetweenFrontAndRear=0,5fSuspensionAntiDiveMultiplier=0,400000005960464fSeatOffsetDistance=0,370000004768372fCollisionDamageMultiplier=1,02857148647308nMonetaryValue=95000modelFlags=1073750020handlingFlags=12599296frontLight=1rearLight=1animGroup=1

 

Share this post


Link to post
Share on other sites
Dodo-Pilot
So it works as long as you jam the handling like this?

 

[411]index=11fmass=1400fTurnMass=2725,30004882813fDragMult=1,5x=0y=0z=-0,25nPercentSubmerged=70fTractionMultiplier=0,699999988079071fTractionLoss=0,800000011920929fTractionBias=0,5nNumberOfGears=5fMaxVelocity=1,22800159454346fEngineAcceleration=0,00119999994058162fEngineInertia=10nDriveType=4nEngineType=PfBrakeDeceleration=0,00439999997615814fBrakeBias=0,509999990463257bABS=0fSteeringLock=30fSuspensionForceLevel=1,20000004768372fSuspensionDampingLevel=0,189999997615814fSuspensionHighSpdComDamp=0fSuspensionUpperLimit=0,25fSuspensionLowerLimit=-0,100000001490116fSuspensionBiasBetweenFrontAndRear=0,5fSuspensionAntiDiveMultiplier=0,400000005960464fSeatOffsetDistance=0,370000004768372fCollisionDamageMultiplier=1,02857148647308nMonetaryValue=95000modelFlags=1073750020handlingFlags=12599296frontLight=1rearLight=1animGroup=1

 

Yes.

Share this post


Link to post
Share on other sites
wenhan1000

Woohoo! Thanks for the information!!! Silvermanblue please update the guide. I can't wait to jam in whatever i need to jam into GTA San Andy cool.gif

 

Edit: As Expected, I screwed up miserably... Take a look at the handling adder:

 

[MAIN]Count=1[CAR_IDs]612[AUDIRA]index=162fmass=1900fTurnMass=5725,3fDragMult=1,6x=0y=0z=-0,25nPercentSubmerged=70fTractionMultiplier=0,80fTractionLoss=0,80fTractionBias=0,50nNumberOfGears=5fMaxVelocity=320,0fEngineAcceleration=30,0fEngineInertia=5,0nDriveType=4nEngineType=PfBrakeDeceleration=16,0fBrakeBias=0,51bABS=1fSteeringLock=30fSuspensionForceLevel=1,2fSuspensionDampingLevel=0,19fSuspensionHighSpdComDamp=0fSuspensionUpperLimit=0,25fSuspensionLowerLimit=-0,08fSuspensionBiasBetweenFrontAndRear=0,5fSuspensionAntiDiveMultiplier=0,4fSeatOffsetDistance=0,37fCollisionDamageMultiplier=0,72nMonetaryValue=95000modelFlags=40112000handlingFlags=170000FfrontLight=1rearLight=0animGroup=1

 

The car was meant to replace comet so there is 4 crap: comet.txd comet1.txd comet2.txd and comet.dff. The name in the handling and everything else is AUDIRA. Please help...

Edited by wenhan1000

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 2 Users Currently Viewing
    0 members, 0 Anonymous, 2 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.