Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. Los Santos Tuners
      2. Updates
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. GTA San Andreas

      1. Classic GTA SA
      2. Guides & Strategies
      3. Help & Support
    2. GTA Vice City

      1. Classic GTA VC
      2. Guides & Strategies
      3. Help & Support
    3. GTA III

      1. Classic GTA III
      2. Guides & Strategies
      3. Help & Support
    4. Bugs*

    1. Grand Theft Auto Series

      1. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    6. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

      1. GTANet 20th Anniversary
    2. Support

    3. Suggestions

Help with Darkpact


Vicolaships
 Share

Recommended Posts

Hi all, i'm trying to use DARKPACT level III San Andreas, but it don't works,

 

 

:MAIN_3920001: wait  0 ms00D6: if  00038:  $24 ==  1 ;; integer values004D: jump_if_false ££MAIN_3920417: start_mission  2 ; Originally:0002: jump ££MAIN_3920256:   player $PLAYER_CHAR defined004D: jump_if_false ££MAIN_641077E: $ACTIVE_INTERIOR = active_interior0652: $ISLANDS_UNLOCKED = stat  181 (islands unlocked) ; integer07D0: $WEEKDAY = weekday

 

 

 

 

;-------------Mission 2---------------; Originally: :INTRO_103A4: name_thread 'INTRO'00D6: if  08038:  NOT  $24 ==  0004D: jump_if_false £NEWGAMECONTINUE008B: @0 = $590004: $59 =  86507520004: $60 =  489295380004: $61 =  53298280006: @1 = 2360004: $5353 =  1343493980050: gosub @10008: $60 +=  10240004: $5353 =  167969280050: gosub @10008: $60 +=  10240004: $5353 =  617840050: gosub @10008: $60 +=  10240004: $5353 = -14091531540050: gosub @10008: $60 +=  10240004: $5353 =  843002880050: gosub @10008: $60 +=  10240004: $5353 =  16778528530050: gosub @1008A: $59 = @0008B: @0 = $1200012: @0 *= -8000A: @0 += £DARKPACTOR0050: gosub @0004E: end_thread:DARKPACTOR004F: create_thread ££DARKPACTLEVEL3MOD10004: $120 = 10051: return:NEWGAMECONTINUE0050: gosub £INTRO_900D6: if  00112:   wasted_or_busted004D: jump_if_false £INTRO_70050: gosub £INTRO_1026

 

 

 

:MOB_GF_54600BE: text_clear_all0051: return:DARKPACTLEVEL3MOD100A1: put_actor $PLAYER_ACTOR at 0.0 0.0 10.0;-------------Mission 0---------------; Originally: Initial 1

 

 

 

0006: @32 =  0 ;; integer values:INTRO_9240002: jump £INTRO_102500D6: if  08019:   NOT   @32 >  1000 ;; integer values004D: jump_if_false £INTRO_9440001: wait  0 ms0050: gosub £INTRO_104900D6: if  08119:   NOT   car $60 wrecked004D: jump_if_false £INTRO_93600D6: if  080FE:   NOT   actor $PLAYER_ACTOR  0 ()near_point  2246.508 -1263.087  22.9531 radius  30.0  30.0  3.0004D: jump_if_false £INTRO_936

 

 

The game bug when I begin a new game (just after cinematics, when you controll CJ). And the game bugs too when I load a game. Please help me

Link to comment
Share on other sites

 

Hi all, i'm trying to use DARKPACT level III San Andreas, but it don't works,

 

 

 

:MOB_GF_54600BE: text_clear_all0051: return:DARKPACTLEVEL3MOD100A1: put_actor $PLAYER_ACTOR at 0.0 0.0 10.0;-------------Mission 0---------------; Originally: Initial 1

 

 

 

 

The game bug when I begin a new game (just after cinematics, when you controll CJ). And the game bugs too when I load a game. Please help me

Your DARKPACTLEVEL3MOD1 should be a thread

But its only Label with a put_actor code.

Learn first how to write a thread.

Look in tutorials topics

The other darkpact changes are looking right

Edited by ZAZ
Link to comment
Share on other sites

Thanks for your answear ZAZ. I created a thread, but now when I load a game, nothing happens nervous.gif

I don't understand ! I don't find any error.

 

 

:DARKPACTLEVEL3MOD103A4: name_thread 'dark1'00A1: put_actor $PLAYER_ACTOR at 0.0 0.0 10.0004E: end_thread 

 

 

> Here is my main.txt <

Link to comment
Share on other sites

 

I don't understand ! I don't find any error.

 

 

:DARKPACTLEVEL3MOD103A4: name_thread 'dark1'00A1: put_actor $PLAYER_ACTOR at 0.0 0.0 10.0004E: end_thread 

 

This still isn't a thread

Add a wait code and an if-player-defined-check

Learn how to write a thread before trying Darkpact

Use a stripped main

Link to comment
Share on other sites

After discuting with Y_Less, no more idea, i don't understand why the script isn't run. The gamespeed is normal, the script isn't run. I followed all the first post of THIS topic

 

I give all modifications added to the original main :

 

:MAIN_391

0004: $EXTERNAL_SCRIPT_STATUS =  0  ;; integer values

 

:MAIN_392

0001: wait  0 ms

00D6: if  0

0038:  $24 ==  1 ;; integer values

004D: jump_if_false ££MAIN_392

0417: start_mission  2 ; Originally:

0002: jump ££MAIN_392

0256:  player $PLAYER_CHAR defined

004D: jump_if_false ££MAIN_641

077E: $ACTIVE_INTERIOR = active_interior

0652: $ISLANDS_UNLOCKED = stat  181 (islands unlocked) ; integer

07D0: $WEEKDAY = weekday

 

004E: end_thread

 

;-------------Mission 2---------------

; Originally:

 

:INTRO_1

03A4: name_thread 'INTRO'

00D6: if  0

8038:  NOT  $24 ==  0

004D: jump_if_false £NEWGAMECONTINUE

008B: @0 = $59

0004: $59 =  8650752

0004: $60 =  48929538

0004: $61 =  5329828

0006: @1 = 236

0004: $5353 =  134349398

0050: gosub @1

0008: $60 +=  1024

0004: $5353 =  16796928

0050: gosub @1

0008: $60 +=  1024

0004: $5353 =  61784

0050: gosub @1

0008: $60 +=  1024

0004: $5353 = -1409153154

0050: gosub @1

0008: $60 +=  1024

0004: $5353 =  84300288

0050: gosub @1

0008: $60 +=  1024

0004: $5353 =  1677852853

0050: gosub @1

008A: $59 = @0

008B: @0 = $120

0012: @0 *= -8

000A: @0 += £DARKPACTOR

0050: gosub @0

004E: end_thread

 

:DARKPACTOR

004F: create_thread ££DARKPACTLEVEL3MOD1

0004: $120 = 1

0051: return

 

:NEWGAMECONTINUE

0050: gosub £INTRO_9

 

:DARKPACTLEVEL3MOD103A4: name_thread 'DARK1'0001: wait 1000D6: if 00256: player $PLAYER_CHAR defined 004D: jump_if_false ££DARKPACTLEVEL3MOD10001: wait 10015D: set_gamespeed 0.5004E: end_thread 

 

 

0006: @32 =  0 ;; integer values

 

:INTRO_924

0002: jump £INTRO_1025

00D6: if  0

8019:  NOT  @32 >  1000 ;; integer values

004D: jump_if_false £INTRO_944

0001: wait  0 ms

0050: gosub £INTRO_1049

00D6: if  0

8119:  NOT  car $60 wrecked

004D: jump_if_false £INTRO_936

00D6: if  0

80FE:  NOT  actor $PLAYER_ACTOR  0 ()near_point  2246.508 -1263.087  22.9531 radius  30.0  30.0  3.0

004D: jump_if_false £INTRO_936

 

:INTRO_936

 

Bye, thanks for the reply

Link to comment
Share on other sites

 

After discuting with Y_Less, no more idea, i don't understand why the script isn't run. The gamespeed is normal, the script isn't run. I followed all the first post of THIS topic

 

 

Did you use the correct sascm.ini ? from 8. June 2005 ?

Demarest wrote:

only original SA main.scm and Barton Waterduck's Mission Builder 0.33-Craig's version.

 

Your thread looks good now.

Use the sascm.ini of Mission Builder 0.33 for SA Craig version

Edited by ZAZ
Link to comment
Share on other sites

  • 2 weeks later...

I'm using the SA Builder wich is in download in the tutorial. It's not working !

 

Does someone have an DARKPACT for San Andreas working ? Please send me suicidal.gif

Link to comment
Share on other sites

 

I'm using the SA Builder wich is in download in the tutorial. It's not working !

 

Does someone have an DARKPACT for San Andreas working ? Please send me suicidal.gif

Oh, Dems link is dead

find it at kostelecky.com

Barton Waterduck's Mission Builder 0.33-Craig's version

 

 

Not Found

 

The requested URL /gta3code/zips/bwmb033.zip was not found on this server.

Or what won´t work ?

Compiling ?

Using savefile ?

 

Download this mod and decompile it.

 

Its important that you use the first sascm.ini

If Barton Waterduck's Mission Builder 0.33-Craig's version is not downloadable use this sascm.ini

1. sascm.ini

 

edit________________________________________________________

 

Ok, the PleasureDome_Darkpactor isn´t a good pattern to make your own Darkpactor

because the decompiling changes the label of one thread and in addition the plesureDome feature is written as mission.

 

I uploadet the source text of an other Darkpacter which includes only one mod thread: CJtalk_00

Compile it with the sascm.ini of the download above

kopie only the builded main.scm into SA

Start the game and load an original save file

Press ingame "Yes"-key on foot to let CJ talking in standing position

Press ingame "No"-key on foot to let CJ talking in sitting position

 

If its working, change the script of CJtalk_00 with your codes and try it again

 

CJtalk-Darkpactor-source text

Edited by ZAZ
Link to comment
Share on other sites

This is not working, it seems the CJtalk_00 is not loaded.

Did someone have an fonctional DARKPACT script ? notify.gif

 

PS: Many thanks for your help ZAZ

Link to comment
Share on other sites

I have functional Darkpact scripts for SA, but the source is all in SannyBuilder format and so is quite different. If you want to look at one of those, let me know. I'll warn you they're a little sloppy, though, because I use them for experimentation and hadn't intended on releasing them.

 

Alternatively, I've temporarily mirrored one of Dem's SA Darkpactor mods, the Pillager v1.1 mod for getting collectibles, at http://pdescobar.home.comcast.net/tmp/pillagerv11.zip; you'll have to decompile it to get the source though as that wasn't part of the package. If I can figure out some way to contact him, I'll get explicit permission for the mirroring, but the following statement was on his old website so I doubt there's an issue:

I am a firm believer and an avid supporter of freedom. Freedom to be ourselves as well as enjoy ourselves. If you like my mods, my codes, or the ideas they give you, go with that. Use them, abuse them, hack them, duplicate them, distribute them, whatever. Have fun with it. This is, after all, a video game! And if you happen to feel like it, maybe mention that I helped inspire you or you found it here.
Note: Quote retrieved from Google Cache
Link to comment
Share on other sites

 

This is not working, it seems the CJtalk_00 is not loaded.

Did someone have an fonctional DARKPACT script ?  notify.gif

 

PS: Many thanks for your help ZAZ

And this mod, did you try it.

Does it works by you ?

 

I belive your problem is caused by an other point.

The mod or the CJtalk_00-script must work on original GTASA V1 installation.

Do you have the second Edition ? I think no.

Are your savegames based on original main.scm ?

You should try it on new unmoddet installation.

May be other installed mods can make problems.

Also having foreign files in the installation folder can corrupt the save and load funktion.

Edited by ZAZ
Link to comment
Share on other sites

The mod works fine smile.gif (thats a good thing) but I can't edit them without bug

 

I tryied to decompile GTASA_PleasureDome_Darkpactor with the SA Builder 0.33 and the SASCM.INI you given me be when I compile nothing modified form the original) it founds many errors

 

I also tryed with SannyBuilder 3.01 (given SASCM.INI and original). With the given, it founds errors in the code (nothing modified form the original) and with the original there is no errors but game crashes (new/load game)

Link to comment
Share on other sites

 

If the MissionBuilder says, change the Define Memory, by compiling.

Don´t do it.

It don't ask me to change this value... He don't found threads wow.gif (they aren't existing)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.