Jump to content

Unstable models


JohnPro

Recommended Posts

I've been making a lot of new models but for some reason some of the models flicker on and off kinda sad.gif ,

 

The Lods work great i can see them from miles but the problem is as you move around sometimes the models will disappear for a few seconds. I made a race track and while you drive around it, it disappears and it looks like the car is flying dontgetit.gif The Mountain i make also disappears sometimes and so does this other thing.

 

Info-

*New IDE, IPL and IMG

*Models made using 3ds max and Uv Mapped no other lighting, etc done.

*Adjusted brightness and lighting on cols

*Created Lods for these models except 1 so i dont think its a lod problem although i would like to know how to make lods disappear when your near them biggrin.gif

*Draw Distance on these models are 299

*Models are very big (only because of the +5 Limit on San Andreas)

 

Any help appreciated greatly

Link to comment
Share on other sites

SmokingCookie

Does it disappear at specific points? (e.g. X feet from the start position, in a turn)

Link to comment
Share on other sites

How many poly's do they contain?

 

[edit]

It could be that on your actual model with the draw distance of 299 the textures aren't visable, so that when you come near your model, the LOD disappears for a second as he ought to do. Normally you then would see the normal model, but because your textures doesn't work you dont see a damn thing tounge.gif.

 

Just a theory tounge.gif

Edited by Jorge F.
Link to comment
Share on other sites

 

Does it disappear at specific points? (e.g. X feet from the start position, in a turn)

I think so but its pretty random at times.

 

 

How many poly's do they contain?

Under 30,000 plys, one of them has around 15,000 but still disappears and yeah 15,000 is still a lot smile.gif

Link to comment
Share on other sites

Does it disappear at specific points? (e.g. X feet from the start position, in a turn)

I think so but its pretty random at times.

 

 

How many poly's do they contain?

Under 30,000 plys, one of them has around 15,000 but still disappears and yeah 15,000 is still a lot smile.gif

15.000 is way to much. A dff file can handel more then 300.000 poly's but the col file not. Its recommend that you reduce the amount of poly's for your col file around the 3000 poly's. If youre col file is under the 3000 and your dff file contains 15.000 it runs smoothly tounge.gif.

Link to comment
Share on other sites

SmokingCookie
How many poly's do they contain?

 

[edit]

It could be that on your actual model with the draw distance of 299 the textures aren't visable, so that when you come near your model, the LOD disappears for a second as he ought to do. Normally you then would see the normal model, but because your textures doesn't work you dont see a damn thing tounge.gif.

 

Just a theory tounge.gif

No that's not the point: if you have LOD objects, and you come whithin range of the normal model (mostly 299 units, don't know whether it's in meters/feet/other units), it will automatically switch to normal models, no matter how big the Draw Distance (short: DD) is. You can place an LOD model without a normal model and the LOD doesn't disappear

Link to comment
Share on other sites

ok so his theory is out of the question but the faces might be a solution.

 

How would i go about reducing the col poly's?

Edited by JohnPro
Link to comment
Share on other sites

 

Thank you, how would i go about reducing the col poly's?

Just load your dff file, then all the unnesecary (how do you spell that tounge.gif) poly's you can delete. Like if one wall contains 12 poly's which you added for the textures, you can make that 4 poly's by replacing it for a plane.

But the best way is (as I do most of the time) to split your models.

 

@SmookingCookie,

I don't know how the LODS react in San Andreas, but in Vice City they did disappear if I set the draw distance to 3000 wink.gif

Edited by Jorge F.
Link to comment
Share on other sites

SmokingCookie

necessary??

 

I have experience with San Andreas LODs

Edited by SmokingCookie
Link to comment
Share on other sites

lol im getting messed up, we are all online and skipping posts.

 

Can i delete polys using Col Editor? 3ds max would take a while as i have many models lol.

Link to comment
Share on other sites

 

lol im getting messed up, we are all online and skipping posts.

 

Can i delete polys using Col Editor, 3ds max would take a while as i have many models lol.

 

Whats a Poly??? I use 3ds max to count them but is it the same as faces?

For example, if you have a plane, the edges of that plane are called poly's. A plane contains four of them. A box contains 8 wink.gif.

 

And I would recommend you to use 3ds max for the poly deleting tounge.gif.

Link to comment
Share on other sites

SmokingCookie

Do you mean "hoekpunten"? (Think of Mathematics)

 

PS: Mathematics=SCHOOL HORROR!!

Link to comment
Share on other sites

Do you mean "hoekpunten"? (Think of Mathematics)

 

PS: Mathematics=SCHOOL HORROR!!

Yes thats exactly what I mean wink.gif.

Hoekpunten = edge

Link to comment
Share on other sites

SmokingCookie

Well, if some1 is learning Dutch, it's pretty important to let that person see the difference between 1 or more tounge.gif but let's go back to the point

Link to comment
Share on other sites

The point is i dont wanna change my cols and do all that work for nothing tounge2.gif

 

ill wait to see what the others have to say

Link to comment
Share on other sites

The point is i dont wanna change my cols and do all that work for nothing tounge2.gif

 

ill wait to see what the others have to say

Just split your models, then you dont have to change your col file but you will have more then 5 models. But I thought there was a boundary hack for San Andreas that allows you to add more then 5 models wink.gif.

Link to comment
Share on other sites

lol i already have 21 new models and the maximum i can add is around 25 so by splitting them i wont have space.

Anyway if your 100% sure this is the solution i guess i have no choice then. I could however try it on only one of the models and see how i go from that model

 

thanks

Link to comment
Share on other sites

not sure if you guys know this but flicker can be caused when the main model and the lod model have different ipl coord's , and that includes the rotation coord's .

 

here is an example of what i mean .......

 

 

12240, illcom_c4_r7, 0, -98.319, 117.361, -3.0, 0.0, 0.0, 0.0, 1.0, 112241, lodcom_c4_r7, 0, -98.319, 117.361, -3.0, 0.0, 0.0, 0.0, 1.0, -1

 

 

as a general rule, identical coord's for both main model and lod model ipl entries.

 

 

 

Link to comment
Share on other sites

Yep the cords are different i know that for a fact as i only used med blush.gif I'll try that for sure today. thanks

 

btw my lods are treelod instead of lodtree, is this ok?

Link to comment
Share on other sites

It didnt work. The models still flicker and is that exact length to make you crash and once you crash it appears suicidal.gif

Link to comment
Share on other sites

haaah...!! i know the cause

your model is crossed the SA boundary

hmmm...for example

your half model is in sa boundary and half out of boundary

 

if you put your entire model out of boundary then it wont appear

i had the same problem, but after some xperiments i solved it

so i hope thats the solution of the problem

 

 

Link to comment
Share on other sites

Yeah Xmen thats what i thought but they are not over the boundry, Im thinking maybe I have too many high poly models in a certain area, lets say 5 buildings with 15000+ faces, could this be the cause? And the game has difficulty displaying them

Link to comment
Share on other sites

nope i think faces not the problem , in my island i had a model that had 22000 faces and it had LOD too

then 44000 faces in 50x50 area, and i havnt any problem

can you show me the cords of your model??

Link to comment
Share on other sites

ok good cause i wasnt looking forward to exporting, importing then deleting faces etc. lol

 

Uhmm im sure its not over boundary as my mountain which is near the beach also flickers at some times.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.