Jump to content

Vehicles are red where they shouldn't be


ArtCrazy

Recommended Posts

When you run the game, low, max whatever, it runs perfectly, but for some reason, most vehicles are fully red, some are partially red (normally where before there was white) including motorbikes. I think it's problems with the shadow because if we point a strong light at the vehicles (like by using the lights in other cars) the real color is there so it IS loading the texture, and when the vehicle is far away we see the textures perfectly too, it's as if the red was some kind of "shadow" and it only applied it when they come close to the character.

 

Anyways, the GPU is a Geforce 6600 256MB, on a 1.5Ghz CPU, Windows XP SP2 with all drivers updated to final versions (Forceware 94.21 I think).

512MB RAM

DirectX is also latest Runtime (June 2007 if I remember correctly)

 

The weird thing is, the game worked fine with the same board on another computer, and I used to play the game there, but that computer broke and as the problem wasn't with the GPU, I put it into my older computer and now use it on my weekend house. Since it's on that computer it's been giving this problem. We can play perfectly fine, but that's annoying tounge.gif

 

Screenshot:

user posted image

 

Thanks for your time,

ArtCrazy

Edited by ArtCrazy
Link to comment
Share on other sites

Ring_of_Fire

1. Did you used cheats?

2. Is your game modded?

 

If those questions are false, then try and reset the monitor settings to the factory defaults (it's a button you press on the monitor to get into the main menu).

Link to comment
Share on other sites

Cheats: I only used HESOYAM a few times (250k money, full health and armor) but it has no other effect...

 

And no, this is a clean install

 

Why would resetting the monitor do anything? I mean, ONLY the vehicles are red, and ONLY this game... And I played the game (connected to my newer computer that stopped working) with the same gpu and screen.

 

Anyways... I DID reset the screen, and no it didn't fix the bug.

 

thanks for the help tough

Link to comment
Share on other sites

Ring_of_Fire

Well, delete the [.set] file and make sure all the settings in ForceWare Control Panel are to the defaults. If doesn't help, try the latest drivers here (http://www.nvidia.com/object/winxp_2k_162.18.html). And make sure to uninstall previous drivers first.

 

And if that doesn't work, use the Omega nVidia drivers. If still doesn't , reconfigure the settings in the 'Display' menu of San Andreas.

Link to comment
Share on other sites

@RoF: This looks like an in game lighting problem. It's like every light in the game has a red bulb. Notice the bike is black in the black areas and pinkish in the white areas, and the Taxi is orange.

 

@ArtCrazy: If it isn't too much trouble, try a complete uninstall and delete the User Files folder within "My Documents". Then reinstall the game. Let us know how this turns out.

Link to comment
Share on other sites

Ring_of_Fire

You sure that ain't normal? As I said, set ForceWare conrtrol panel to defaults, and use 32-bit color (max resolution and AA). Now let the Texture Quality be set to "Very High" and the draw distance.

 

If still no luck, install Patch 1.01. I think the RGB rendering features for your graphics card is probably messed up.

Link to comment
Share on other sites

@RoF: Positive.

 

What RoF said about the RGB being messed up could be partially correct, but only the light overlay functions. If a full reinstall doesn't work, do try the 1.01 patch. It may help. On the other hand, dropping down the detail one notch may be all you need to do to disable the reflective light overlay.

Link to comment
Share on other sites

Ring_of_Fire

It might be a shader issue with the GeForce 6 Series. Even though they support DX9.0c, they don't support a lot of the better graphical features that the GeForce 7/8 series have. My recommendation would probably be to buy better graphics hardware or ask yourself these very simple questions:

 

"Was it working before?"

 

"Did I played around with the compatibility options for [gta-sa.exe] even when my game was already working fine?"

Link to comment
Share on other sites

 

Well, delete the [.set] file and make sure all the settings in ForceWare Control Panel are to the defaults. If doesn't help, try the latest drivers here (http://www.nvidia.com/object/winxp_2k_162.18.html). And make sure to uninstall previous drivers first.

 

And if that doesn't work, use the Omega nVidia drivers. If still doesn't , reconfigure the settings in the 'Display' menu of San Andreas.

 

Did all that, doesn't fix it... Even tried lowering the configs to min to turn off lightning and it's still there...

 

 

@ArtCrazy: If it isn't too much trouble, try a complete uninstall and delete the User Files folder within "My Documents". Then reinstall the game. Let us know how this turns out.

 

I can't reinstall the game currently but will do later (next chance I'll get will be in about 3 to 4 weeks tough)

 

 

You sure that ain't normal? As I said, set ForceWare conrtrol panel to defaults, and use 32-bit color (max resolution and AA). Now let the Texture Quality be set to "Very High" and the draw distance.

 

If still no luck, install Patch 1.01. I think the RGB rendering features for your graphics card is probably messed up.

All is defaulted and I tried both max and min settings.

I'm going to install Patch 1.01 now and will report back.

 

 

What RoF said about the RGB being messed up could be partially correct, but only the light overlay functions. If a full reinstall doesn't work, do try the 1.01 patch. It may help. On the other hand, dropping down the detail one notch may be all you need to do to disable the reflective light overlay.

It's just wierd that this is the only game where this doesn't work... Not that I tried many games, but I'd think the few I have here should have shown similar problems?

And as said before, I'll be installing Patch 1.01 now...

 

 

"Was it working before?"

 

I played the game from first to last mission on the SAME GPU (not same model, ACTUALLY the same GPU) but on a different computer (only thing that was the same was the GPU) but then replaced my computer and put this GPU on an one-year-older computer I had and installed GTA. Since then it has been like this...

 

 

"Did I played around with the compatibility options for [gta-sa.exe] even when my game was already working fine?"

 

NOT BEFORE, as since I first ran GTA on this computer it's been like this... But I tried that out as a possible fix... eh it could've worked tounge.gif

 

 

Anyhow, once the patching ends I'll try it out and report back!

 

Thanks for your time

 

EDIT: Patched, didn't fix anything sad.gif

Edited by ArtCrazy
Link to comment
Share on other sites

  • 2 weeks later...
Flowmaster40

Hey i have the same problem, and ive tried almost everything, i even reformatted my pc and re unistalled gta san Andreas like 5 times and tried some other drivers and still didn't work . my video card a E vga 6200 LE 256MB

 

 

Edited by Flowmaster40
Link to comment
Share on other sites

Ring_of_Fire

 

I played the game from first to last mission on the SAME GPU (not same model, ACTUALLY the same GPU) but on a different computer (only thing that was the same was the GPU) but then replaced my computer and put this GPU on an one-year-older computer I had and installed GTA. Since then it has been like this...

The fix would be to...

 

1. Uninstall game in "Add/Remove Programs" (might have to restart).

2. Delete the entire contents of "C:\Program Files\Rockstar Games\San Andreas"

3. Empty recycle bin.

4. Reinstall game and install everything.

5. Delete [.set] file in "My Documents" folder.

6. Launch game, reconfigure graphics, and test things out.

 

Note: You might want to use a different resolution or color quality bitrate, and turn on/off frame limiter, mip-mapping and anti-aliasing.

 

 

Hey i have the same problem, and ive tried almost everything, i even reformatted my pc and re unistalled gta san Andreas like 5 times and tried some other drivers and still didn't work . my video card a E vga 6200 LE 256MB

Could probably be a shader issue with the GF6, which may require that you tweak around in FW Control Panel or tune down the "Hardware Acceleration" by one or two notches. But the easiest of solutions is to buy new graphics hardware (GeForce 7/8 recommended or a Radeon X1950 PRO).

Edited by Ring_of_Fire
Link to comment
Share on other sites

try emulating lighting with 3D Analyze.

I did that and it works perfectly, other than being like at 10FPS... So we know the problem, faulty TnL... Is there any way to fix it?

Link to comment
Share on other sites

I read that thread and it seems that downgrading to 7x.xx forceware fixed the problem. I'll try this weekend... Thank you very much!

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.