Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (92,104 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Deniska

SA path tool

Recommended Posts

Harmalarm

Sorry for bumping this rather old topic... eh eh...

 

First off, Deniska, I LOVE your scripts. (both the dff export for the vertex lighting, and the pathtool) I've finally got the the hang of it, and it's actually very easy to use and make the proces of building paths and testing them a LOT faster. (mostly because of the automatic compiler!) Really, Great work icon14.gif

 

But I have a question. My trafficlights seem to act a bit weird. They work, but when cars take a green light and then go around the corner, they wait for the other red light sometimes. (the other direction, 90 degrees rotated towards the previous light) I have a nod in the middle of the cross section, just like in the original SA, and I apply all directions correctly I hope. (the light facing the orientation) Is there any way to solve my little problem? confused.gif

 

 

Share this post


Link to post
Share on other sites
johnhurc

sorry bump the link is dead

Share this post


Link to post
Share on other sites
supermortalhuman

It works, you need to click the link then click the same link on the following page. It is an error page or something, or a page about hotlinking, I don't know, I can't read russian.

 

Tool is in English, thankfully. Just look at the download link, and see that link on the page where it led to, it will work.

Share this post


Link to post
Share on other sites
Parsa.h

link is corupted.

Share this post


Link to post
Share on other sites
ZAZ

 

Out of curiosity, how big is your mod, Den?

 

in IMG about 4000 new objects by me (not convert from anywhere)

and about 1500 made by Myhajlo and team...

I working with east and team working with west side of map...

 

So about paths... look at picture

 

user posted image

 

This just main roads for cars and some ped paths...beleave me - its working...

As you see - selected shape not few meters (its few kilometers)... So i dont

know why its not working for AAD... Also one way traffic and highway working too...

Yes, have 2 limits for path shapes

1 - only 1 spline

2 - shapes must be opened

 

I dont think what it is error...

 

 

For instance, with the (off topic) dff script, no matter what settings I choose, it ALWAYS export very bright dff, so I must export only 1 dff at a time with Kams

 

May be you have very ligth prelit, or white NVC... So PM me how you prelit your model

and ill try help you...

would you help please, what do i wrong?

ingame i must wait 1 minute till cars appear, then they drive around the first point

 

download maxfiles (3dmax7) and nodes.dat

 

could you show again a screenshot with correct splines

 

user posted image

no traffic lights created, i just set pathwith to 1.0 and left lanes to 0, then pressed store button

 

 

Edited by ZAZ

Share this post


Link to post
Share on other sites
aad

maybe weird to bump this topic but lately im getting this error > see screeny

 

http://s187.photobucket.com/albums/x185/Aa...t=bug_paths.png

 

user posted image

 

it only conflicts at 1 newly created line, recreating that line and trying again doesnt work also i have tried

 

- creating new max file and draw lines in there and export ( sometimes it works sometimes it doesnt work) and i get the same error

 

so i was hoping that someone could help me out with this strange error.

 

 

Share this post


Link to post
Share on other sites
Swoorup

 

QUOTE (steve-m @ Jul 5 2007, 17:33) That happened with my tool as well, though. I guess we're missing something in the file format. What I remember is that this happened at area borders, where a node is connected to a node of another file. I managed to get rid of some of them by avoiding navi node links across borders, but that didn't solve the problem completely.

 

As for the delayed crashes, SA streams path area files on demand, so it's likely there's an error in (at least) one of the files and the game crashes when you get near it, but works fine when you're not.

all point in navi nodes - lets make compare between 2 nodes

1 node = (areaID1, nodeID1)

2 node = (areaID2, nodeID2)

 

So 1>2 if areaID1>areaID2 or else if nodeID1>nodeID2

 

Now - navi node always have direction from 2 to 1 if 2>1 and

from 1 to 2 if 1>2

 

And more info -

navi links for each node must be sorted too...

 

I tested special at borders of zones - and no crashes for me...

 

question - did you try my tool ?

 

QUOTE But I can imagine that the "intersection behaviour" is just a flag that makes cars continue driving till they reached the next node. Maybe it is like the TrafficLights with N S W E

 

in original SA paths - this parameter is "1" if TRAF LIGHT have direction same as

navi node.... And "0" - if another...

 

-------------------------------------------------------------------------------------------------------

 

 

 

Can someone please explain this again. Is an old thread but I am having the issue of "super sonic car speed/warping".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.