Jump to content

Irregular Mouse Undetectable, Then Freezes


samasama2

Recommended Posts

Hello,

 

I just installed Vice City a couple of weeks ago after purchasing my new computer and I encountered these very annoying problems:

 

Scenario 1:

 

Sometimes, after a new "scene", my mouse will be undetectable. For example, when I get off a car, the next "scene", I can only strafe left and right. Or, when I exit a building, the same thing happens.

 

Whenever this happens, I would press Esc, and resume game, sometimes things will resume back to normal. However, there are also several times when I press Esc, and the screen just turns black, while there is still audio (background noise, not sure if it's repeating audio or not). Task manager reveals that VC has stopped responding and I have to restart the game all over agian.

 

Scenario 2:

 

Sometimes when I press Esc, into the menu screen, my mouse will also be undetectable. So I click Resume Game, (or any other option on the menu) nothing happens. Hence, I have to press Enter manually to resume game, and likewise, I will get a black screen. Task manager also reveal that VC stops responding.

 

The following are the specs of my computer:

 

PC,

Windows Vista Home Premium,

VC version 1.0

AMB Athlon x2 4200+

2 GIG RAM

256 MB GeForce 7300 LE

DirectX Version 9.0

Sigmatel High Definition Audio CODEC (Soundcard)

 

Current situation and Measures I have tried (in vain) to rectify the problem:

 

This is my second install. The first install I had this problem as well, so I went to look for a patch for VC, but the "patch" turns out to be the 2.1 Ultimate Vice City Car Mod. It didn't solve the problem.

 

I subsequently deleted the .SET file, and uninstalled the VC, and re-installed VC again.

 

The second install I do not include any mods.

 

I have turned on frame limiting, and installed the optional radio station for both times.

 

I have tried changing my windows display to 600 x 800, chose to run VC under 640 x 480, disabled visual themes, desktop composition, display scaling, all didn't work out.

 

I have tried the compatibility with Windows 98 / Me as advised. But this made things even worse. I cannot even run the game due to an unhandled exception error. (Not to mention my saved games are inaccessible under this option.)

 

-------------------------------------------------------------

 

Please help, because this is very frustrating. Too often, I was doing missions until the point where they were almost complete, then this kind of thing happened and I would have to re-do the missions all over again.

 

Thanks!

Link to comment
Share on other sites

I have not used Vista (and don't plan on it any time soon), and have very limited esperience in VC PC... however just off the top of my head, it sounds like some type of conflict between programs or low system resource issues...

 

I'd go into your task manager and just start turning off everything running in the background-- perhaps Vista IDs programs better then XP does-- if not, I know there are programs out there you can download (I don't know their names) that will tell you all the things running in the background (what they actually are)-- so you know what you are turning off-- obviously there are things that you don't want to turn off.... (hopefully those programs out there will run on Vista)..

 

Its possible that just turning off stuff will free up enough resources to avoid the problem...

 

HTH...

 
7744.png

"I want to design a video game where you take care of all the people shot in all the

other video games.... It's called Busy Hospital II" -- Demetri Martin

RIP BDP

Link to comment
Share on other sites

Hi,

 

Thanks for the reply.

 

I've freed up basically almost all non-essential programs running on the background. In fact I am currently only using up 600 MB of RAM (Windows Vista is memory intensive) with 1.4 Gig of RAM free.

 

However, I just encountered the problem again! When I was in the menu, my mouse can move the arrow about, but when I clicked resume game, nothing happens. So i used my keyboard to press Enter, and black screen again. This doesn't happen everytime when I am in the menu, though, but frequent enough to be really frustrating.

 

please advise, thanks.

Link to comment
Share on other sites

Hi,

 

I was just surfing through my problem and I came across the following page:

 

http://www.gamespot.com/pc/action/gta4/sho...1132&pid=924362

 

Apparently the poster has the exact same problem as me, though he is running SA instead of VC.

 

And also I think I changed the compatibility to Windows 98 / Me before I deleted the .SET and reinstalled the game (Hence the "unhandled exception" error).

 

Now my game can run fine after changing the compatibility. The only gripe I have is that all my save games are gone. But at least I can run the game normally now.

 

I'm putting this up just to let others know, in case they have the same problem.

 

Thanks anyway for the help.

Link to comment
Share on other sites

The saves shouldn't have been affected by a reinstall (I don't think anyway)-- shouldn't be under the same directory as the game files.

 
7744.png

"I want to design a video game where you take care of all the people shot in all the

other video games.... It's called Busy Hospital II" -- Demetri Martin

RIP BDP

Link to comment
Share on other sites

Hi,

 

You are right. The save files are not affected at all. I'm so sorry... It's just that because I changed compatibility with windows 98, the save files are stored in another User of the OS. Hence I couldn't access the previous saved files. But when I copy them and paste them into the other folder, i could play them normally.

 

Thanks all for the help. I can now play VC normally now.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.