Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Arena War
      2. After Hours
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA Next

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

  • 0
TonyResta

Sound Delays & Skips

Question

TonyResta

SYSTEM SPECIFICATIONS (EVEREST):

 

PLATFORM: PC (Windows XP + Service Pack 2)

VERSION: 1.00 LEGIT Copy Of Vice City

CPU TYPE: Mobile Intel Pentium M 730J, 1600 MHz (12 x 133)

MEMORY: 502 MB (DDR2-533 DDR2 SDRAM)

VIDEO ADAPTER: Mobile Intel® 915GM/GMS,910GML Express Chipset Family (128 MB)

DIRECT X: 9.0c

AUDIO ADAPTER: Intel 82801FBM ICH6-M - AC'97 Audio Controller [b-2]

 

PROBLEM:

 

Hi, im expierancing a problem with my vice city pc version that has never happened on any other occasions that i had to reinstall. I will try and be specific of what is happenning.

 

The first time i bought my vice city, everything worked properly except of an error that occured straight after installation, something about wrong volume in the drive (trying to translate since my laptop is in italian). Then i started the gta_vc.exe but the cd spinning icon appeared but nothing happened, so i looked up the problem and what fixed it was the compatibility thing under properties. After all this hassle, i was finally able to play smoothly, no problems whatsoever, then after a month i started installing quite alot of mods but no problems. After about 3-4 months, i decided to reinstall becuase of the lag and glitches i was getting from the 100 or so mods i had installed. Once the 2nd installation finished i got the same volume error from before, so i pressed continue out of the options like i did last time. Once i set up everything again i started playing with nothing wrong, after another couple of months i decided to unninstall the game becuase i was getting san andreas and i wanted more space for it. After about 4 months of playing san andreas, i decided to install vice city again. Everything went through like it always did including the error i always had. BUT, for some reason, the sound effects (cars, motorbike, helicopters, guns, walking, etc...) wasnt working, only the radio stations and interior music and cutscenes were, so i reinstalled and same problem, then i reinstalled again but this time on the first menu that comes up, i go under audio and change the hardware settings from "Auto-Detect" to "Rad Game Tools RSX 3D Audio" for no reason, just to see if it was any differensce, and to my surprise, all the sounds worked, but were all delayed, for example, i press W to accelerate and the acceleration sound comes after 2 seconds. Also, now, the radio stations dont play properly, they are always skipping, lagging and it gets annoying, so i decided to try and put the hardware settings back to "Auto Detect" but everytime i do, the game freezes and i cant change it anymore.

 

So thats the detailed story of my problem:

 

-The sounds dont work when on auto detect but they used to.

-I cant change the hardware settings back to normal (i think i have to delete the SET file)

 

Thanks for reading and i really apreciate the help.

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0
Ben

Do you have problems with sound in any other games or any other applications?

 

I too had a similar problem a while back - my PC suddenly decided that my sound card didn't support hardware buffering. I'm not exactly sure what it meant, but it did stop my sounds from playing properly. And the Rad Game Tools setting was the only one that I was able to select.

 

To be sure that this is the problem, go to Start -> Run -> and type dxdiag and then hit OK. In the new window that appears, go to the Sound 1 tab (assuming you have more than one sound thingy). Then, on that page, click "Test Directsound". Your PC will then run a small series of tests - at some stage you'll most likely get the message that "your sound card does not support hardware buffering".

 

Assuming that is your problem, we come the next issue - the fix. And this is what's really strange - I wasn't able to figure out how to fix it. I tried updating my drivers, but something somewhere was corrupted and they wouldn't install properly - I had to roll them back confused.gif.

 

The problem for me has been fixed though - it happened when I got a minor upgrade in the form of a new HD and a few other things. The new HD was set as my master, so the drivers had to be reinstalled on it - I ended up with the updated ones and everything's been dandy smile.gif. So if you can't manage to update the drivers, the only other suggestion I have is to get a new sound card. Unless you're a die hard gamer who can only have the best sound, you can pick up a new card for pretty cheap that should suit your needs just fine.

 

I hope that helps you out a bit - good luck smile.gif.

Share this post


Link to post
Share on other sites
  • 0
Justin

Simply because it's an audio issue, I suggest:

 

Start -> Run -> dxdiag (as Ben said), and then in the Sound tab(s), change the hardware acceleration to a different setting (i.e. move the slider).

Share this post


Link to post
Share on other sites
  • 0
TonyResta

thanks for the help guys, first im going to try the sound test under dxdiag, then the acceleration tab (ive already tried max and no acceleration, now i just have to try the other ones) and if nothing works, i might have to buy the sound card, its wierd though, my san andreas works perfectly and my vice city used to work perfectly too. Ill post back with an update soon. Thanks biggrin.gif

 

 

EDIT: Ive tried the sound test and at the end it said the buffer error you said would come up.

 

EDIT 2: I went to try and play the game again and no cars appear around me, only parked cars, but yesterday it was fine.

Edited by tony-resta

Share this post


Link to post
Share on other sites
  • 0
Ben

No worries on the help wink.gif. I didn't have SA when I had this problem, but GTA3 worked fine for me at the time - VC must use a different "sound engine thingy" tounge.gif.

 

The game is still playable without the SFX - in fact, in my experience, everything else in the game loaded faster and gameplay was more efficient (that was without anything set in the Audio options). But if you want the SFX, then I think the sound card (or a format) might be your only options - I'd suggest talking to someone at a PC shop about it in case they have any other suggestions smile.gif.

 

As for your latest bug, I've got no idea - it's definitely not related to the sound (well, as far as I can tell anyway) confused.gif.

Share this post


Link to post
Share on other sites
  • 0
TonyResta

Ok, ive tried all the acceleration options and nothing changes, ive deleted the SET file and the audio hardware selection goes back to Auto Detect but no sound effects, if i do have to get another sound card i dont know how, what do i need to do? are all the sound cards compatible with my laptop or do i need a specific one?

Share this post


Link to post
Share on other sites
  • 0
Ben

No idea - that's something you'd have to get checked out at a computer store methinks. Unless anyone else has got some advice about it...

 

Good luck anyway smile.gif.

Share this post


Link to post
Share on other sites
  • 0
TonyResta

thanks for the help

Share this post


Link to post
Share on other sites
  • 0
TonyResta

Sorry for the double post, but i have another problem now (why am i so unlucky) and i thought it would be best to not create another thread for it.

 

Everytime i save game, then close vice city and put it back on again, the saved game doesnt have any cars or pedestrians spawning, but when i start a new game it works, does anybody know whats wrong?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.