Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Arena War
      2. After Hours
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA Next

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

  • 0
Sign in to follow this  
guv

Sounds echo

Question

guv

I've a problem with Vicy City on PC that I've not seen addressed yet. When I play the game the sound of NPCs/peds voices is extremely echoey. I've tried fiddling with speaker settings in the Options menu but to no avail. Music and cut-scenes are perfect.

Share this post


Link to post
Share on other sites

22 answers to this question

Recommended Posts

  • 0
segvirion

 

I've a problem with Vicy City on PC that I've not seen addressed yet.  When I play the game the sound of NPCs/peds voices is extremely echoey.  I've tried fiddling with speaker settings in the Options menu but to no avail.  Music and cut-scenes are perfect.

I've had this problem too. My soundcard is onboard - Realtek AC'97 - and I managed to fix this problem by changing the speaker configuration (sorry if this is not correct, my Windows is in Portuguese) in the soundcard Sound Manager option - I changed the environment option from "living room" to "none". I think you can try something like this using the "Sound Properties" dialog box in Windows (sorry again if this is a bad translation...). Just try some of the options to see if they help.

 

Other than that, you could try to update your soundcard drivers.

 

EDIT: You could also try to run VC in compatibility mode (right-click on the .exe file, select 'properties', 'compatibility' and check the box where it says 'run this program in compatibility mode', choosing Windows 98 in the drop-down box. I'd try this before the other things I mentioned.

Edited by segvirion

Share this post


Link to post
Share on other sites
  • 0
Justin

Hey guys, I should have got around to it a lot earlier, but I've added the echo problem to the bug list, and split off your posts into a new topic (this one). I can't guarantee the solution(s) will fix your problem, but they're well worth a try. Good luck, and be sure to report back. smile.gif

 

.......................................

 

Problem #18

Sounds echo when playing Vice City. This often occurs with all sounds except for the radio.

 

Solution: Update your sound drivers! Yes, this is stated in the above introduction, but is particularly relevant with this problem.

 

Alternatively: Set the compatibility mode of the executable file to 'Windows 98'. Do so by: right-clicking gta-vc.exe (default: C:\Program Files\Rockstar Games\Grand Theft Auto Vice City\gta-vc.exe) -> Properties -> Compatibility tab -> check 'Run this program in compatibility mode for:', and select 'Windows 98 / Windows Me' from the drop-down menu. Apply, OK. And as pictures speak a thousand words, click here for an 84 kB, 367 x 510 image of the process, care of Fuzzy.

 

Alternatively: Through Control Panel, disable any volumetric or advanced audio effects that may be enabled in your sound configuration (e.g. environmental audio).

 

.......................................

Share this post


Link to post
Share on other sites
  • 0
guv

Thanks for the tips, guys. I can't check tonight as I'm doing other things on my computer, but I've altered the audio setting from Windows 95 (a strange default...) to Windows 98, so I will see if that's worked next time I play the game. If not, I'll try the other suggestions. Anyway, I'll get back and let you know which worked.

 

Thanks again. cool.gif

Share this post


Link to post
Share on other sites
  • 0
dragonfly222

I have the same problem with the same soundcard (Realtek AC97). I tried everything in this topic, including updating drivers and compatibility mode. In sound effect manager I have environment set to none. Any other suggestions? confused.gif

Share this post


Link to post
Share on other sites
  • 0
dragonfly222

I fixed the problem after several hours. I hope this will help someone.

 

Control panel > Sound effect manager > 3D Audio Demo

 

You should have "loopy music" as default. Set it to "buzzing bee".

Share this post


Link to post
Share on other sites
  • 0
Spuds725

Thanks for posting back your solution-- will add to the buglist solutions and give you credit...

 

thanks..

Share this post


Link to post
Share on other sites
  • 0
grack
I fixed the problem after several hours. I hope this will help someone.

 

Control panel > Sound effect manager > 3D Audio Demo

 

You should have "loopy music" as default. Set it to "buzzing bee".

excellent! this is the only thing that's worked for me smile.gif

 

I know this is an old thread, just wanted to show my appreciation

Share this post


Link to post
Share on other sites
  • 0
Ring_of_Fire

 

I know this is an old thread, just wanted to show my appreciation

However, do keep your appreciations to yourself! No, you should not have to touch the sound manager. Updating drivers automatically fixes sound problems. Sound managers are not for people who don't have updated drivers, and it's only there for tweaking purposes and never to fix sound problems in most cases.

Share this post


Link to post
Share on other sites
  • 0
grack

what's your problem?!

updating my drivers didn't work, and this did...

Share this post


Link to post
Share on other sites
  • 0
Ring_of_Fire

Because I have Realtek AC'97 onboard audio as well and I didn't have to touch the sound manager. It's there running in my taskbar feeling useless. Unless of course the echoing from peds isn't normal, then you have a point! cryani.gif I'm trying that out!

 

What do you mean exactly? You mean you don't have any sound problems except for the echoing? You mean it is supposed to sound just like on the PS2/Xbox console versions? Hmm... gotta try do some tweaking around, always thought it was normal to the PC version of Vice City because of some content they took out that was on PS2. icon14.gif

Share this post


Link to post
Share on other sites
  • 0
grack

no, I have no other sound issues than this (that is to say, had)

and why in the world would they make it sound like you're in a church just for the PC version? whatsthat.gif

 

anyway, try the fixes - the game seems a lot better once you get the right sound going...

Share this post


Link to post
Share on other sites
  • 0
ThunderPower

This always happens when I use something other than Rad Game Tools or Miles 2D Sound.

Share this post


Link to post
Share on other sites
  • 0
lostinbttf

where do i find sound effects mangager within control panel? thanks to anyone who can help, i've tried everything else

Share this post


Link to post
Share on other sites
  • 0
lostinbttf

perfect! i updated my realtech audio driver with my vice city game in the cd tray, restarted, now when i double click play vice city, nothing happens! the spinning cd pointer comes up, then nothing! i'v managed to screw up vice city just to get rid of some echo!! arghhhh!

Share this post


Link to post
Share on other sites
  • 0
HOD

Hey i tired doing this, and whenever I did, it changes it back to loopy music.

 

It looks like this

 

o Loopy Music

o Buzzing Bee

-----------------

Moving path

and etc.

 

I clicck on buzzing bee, but how do i set it to default?

Share this post


Link to post
Share on other sites
  • 0
tweakn

not to bring up an old thread, but i have recently installed vice city on my PC and was having the same sound problems mentioned above, the peds and other sfx echoing like crazy. I found this topic as the first listing when i searched google for a fix to the problem and tried everything listed here.

 

I updated my drivers, checked the Environment sounds, sfx manager in control panel, compatibility etc. None of it worked. A friend suggested to me to try updating my direct X (i'm using 9.0c) and i did, to some updated version of 9.0c. I still had the echoing sounds.

 

So what eventually fixed it for me was adjusting the sound setting in directX from Full Acceleration to Standard Acceleration.

 

I, too, have an onboard RealTek soundcard, so maybe anyone else who tries all the above mentioned tricks to get the sound working properly can try this if all else fails:

 

- Go to Start > Run and type in dxdiag

- click the Sound tab at the top

- If your sound card settings are set to Full Acceleration, turn it down one notch to Standard Acceleration.

 

This fixed my problem and hopefully can help other people who may be having the same issue and have tried any/all of the above mentioned fixes to no avail. I hope this helps ^_^

Share this post


Link to post
Share on other sites
  • 0
Spuds725

Thanks for posting your fix... will see about adding this to the pinned buglist with solutions thread... That is Justins Forte-- I'm the PS2 guy.

 

//edit//

 

Did you do the same thing as in the buglist (one of the solutions to #17 regarding sound problems)...

 

 

Alternatively: Change your hardware sound acceleration to a different setting. This is achieved through: Start -> Run -> dxdiag, clicking the Sound tab and moving the Hardware Sound Acceleration Level slider to a different position; or by going to Advanced Speaker Settings through Control Panel -> Sounds and Audio Devices.
Edited by Spuds725

Share this post


Link to post
Share on other sites
  • 0
QwertyAAA

or stop letting your comp overheat.

Share this post


Link to post
Share on other sites
  • 0
Jusser
I fixed the problem after several hours. I hope this will help someone.

 

Control panel > Sound effect manager > 3D Audio Demo

 

You should have "loopy music" as default. Set it to "buzzing bee".

it's really funny, and strange, but .. this really works!

Thank you!

 

also a late reply, but who cares

Share this post


Link to post
Share on other sites
  • 0
Rosenberg123

 

 

- Go to Start > Run and type in dxdiag

- click the Sound tab at the top

- If your sound card settings are set to Full Acceleration, turn it down one notch to Standard Acceleration.

 

This fixed my problem and hopefully can help other people who may be having the same issue and have tried any/all of the above mentioned fixes to no avail. I hope this helps ^_^

 

 

I know; old thread- but I tried everything above this tip to no avail. Doing the dxdiag thing did the trick though, & I was beginning to think nothing would help. Reinstalls, driver updates everything. I made this account just to express my gratitude. Thanks bunches to everyone else as well for sharing and bringing others solutions also. Much appreciated.

 

 

biggrin.gifbiggrin.gifbiggrin.gif

Share this post


Link to post
Share on other sites
  • 0
flicko

Hey buddy, welcome to the forums! It's nice to know that you have solved your problem, and thanks for utilizing the search feature. Usually I'd frown upon folk who bump a topic up in the troubleshooting section if they hadn't had a problem of their own that needs fixing, but I think in this case, since others can learn and hopefully solve problems from this, it's perfectly justifiable. icon14.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • 1 User Currently Viewing
    0 Members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.