Jump to content

[REL] Kam's Maxscript going over quick update!


Kam

Recommended Posts

The "white" problem has occured for me too, but it only occurs when I use the latest DFF_IO, it is solved with the same parameters when I use GTA_DFF_IO_(22Jul05) or earlier.

 

I have one problem more. This is with the COL3 script. I can import Dff COL3 and also COL1 but I can't export them. I define the "collision mesh" and "shadow mesh", select everything, give a name, press Export, then define the fail name, press save but nothing happens - no file is created mad.gif . Could someone give me some idea what I am doing wrong.

 

PS. I am using 3Ds max 7 and 8 (don't worry they are trials) biggrin.gif

Link to comment
Share on other sites

The textures are perfect, but the object without UVW Mapping or UVW Form, with only GTAMaterial, in the game are white. In 3ds MAX the object have a GTAMaterial Black, in the game White. This problem there isn't on 25 Aug Script. This problem is present only on new script.

Excuse for my english... blush.gifalien.gif

Link to comment
Share on other sites

toooomas and pirlano,

Could you send me both dff(problem and working ones), so I can debug it!

 

Also, for col export, you have to select boxes/spheres or meshes(not only define collision/shadow mesh in pickbuttons) before export, If you didn't select anything before export, the script can't calculate bounding box/sphere. So it didn't export anything!

 

Link to comment
Share on other sites

For my case the dff "error" was solved when I used the earlier version of dff script and because of that I don't have the files.

 

But I can't still get the col script to work. I define the collision and shadow mesh, then I select everything (also define the name), press the export button give the name but still nothing happens. Do I firstly have to select only shadow or collision mesh to create bounding box/sphere... (I have worked with the first collision script - only col1 - and it works like a charm). GTA_VC collision script had an option to make the boundings with a button, so I could see that everything was OK, all parts exist.

Link to comment
Share on other sites

KAMS updated, 'white' material problem should fixed!

 

toooomas,

I test my collision script in Max3, Max6 and GMax. Try export COLL/COL2/COL3. They all works !?

 

How I test:

1. create a sphere and a box

2. run my collision script and select them

3. give a name 'test' and press 'Export'

4. A open dialog popup and I give it a name 'Col_test.col'

5. all done and a file 'Col_test.col' created

 

6. create a teapot

7. pick this teapot as collision mesh

8. select the box and sphere again

9. give a name 'test2' and press 'Append'

10. all done and test2 appended to 'Col_test.col'

 

11. pick the same teapot as shadow mesh

12. select the box and sphere again

13. give a name 'test3' and press 'Append'

14. all done and test3 appended to 'Col_test.col'

 

No problem at all!?

Edited by Kam
Link to comment
Share on other sites

biggrin.gifalien.gif 'white' material problem is fixed!

Now it works!!!!!!!! biggrin.gif

 

[edit]the 'white' material problem is still present

Edited by pirlano
Link to comment
Share on other sites

Unfortunately, the 'white' material problem is still present in Kams latest script(in case of GTA Vice City) confused.gif

I've tried to export a car to VC and ended up with following:

http://c.1asphost.com/ShadyBoy/images/wp.jpg

(to windscreen and any other window of the car applied the same material(without mapping))

It works fine on door windows but windscreen is still white!

please help!

Edited by ShaDy01Boy_
Link to comment
Share on other sites

Hepl needed. I'm adding a new wheel to my car, but I keep getting this:

 

More than 1 Hierarchy links were selected!

Only 1 is allowed in DFF.

 

Can anyone tell me how to fix/remove the hierarchy.

Link to comment
Share on other sites

I don't want to push you off ,teknogeek. But it is something very basic for MAX/GMax user. If you are new to it. Just run you MAX/GMAX, press F1 and search for hierarchy. It only take you few minutes to understand the term and usage. If you still having problem, could you mind open up another thread to ask for help!? Thanks

Link to comment
Share on other sites

I don't want to push you off ,teknogeek. But it is something very basic for MAX/GMax user. If you are new to it. Just run you MAX/GMAX, press F1 and search for hierarchy. It only take you few minutes to understand the term and usage. If you still having problem, could you mind open up another thread to ask for help!? Thanks

I figured it out. Forgot to link the new object biggrin.gif.

Link to comment
Share on other sites

Since Kam has not responded in a while I suggest you to convert all your objects to an editble mesh if they weren't and check for any material that is not used no more. No I don't know the answer but try the above. It appears that you are using GMAX which I'm not familiar with. I don't know how close it is to 3DS 6.

Link to comment
Share on other sites

Since Kam has not responded in a while I suggest you to convert all your objects to an editble mesh if they weren't and check for any material that is not used no more. No I don't know the answer but try the above. It appears that you are using GMAX which I'm not familiar with. I don't know how close it is to 3DS 6.

 

Just another thing that convinces me of the benefits of open source; it allows people to try to fix their problems themselves instead of having to wait for the tool's author to fix it. smile.gif

 

Alex

 

Link to comment
Share on other sites

  • 2 weeks later...

Hi Kam,

 

When is want to import the CJ police outfit i can only import the ripped clumb

 

3 import clumbs import the same outfit, not cj: fat, ripped, normal.

 

Anyone also problems with this, because i want to mod the police outfit because its buggy.

 

Please help me

 

Bye,

Frank

Link to comment
Share on other sites

f5544, I found a lot of body part are actually same mesh but different bones/unknown value. So I don't think it's my script problem!?

 

If my script works, when you import 1st clump, the root bone will called 'Ripped'. Root bone for 2nd clump is 'Fat' and 'Normal' for the 3nd one.

 

Just make you model and export it follow those name rule will do! (Remember to set your model's pivot exectly the same as root bone, and edit the atomic section of your dff)

 

Link to comment
Share on other sites

Ever since I started using the new script, I can't get the SA lights to work right and smooth groups get f-ed up. I'm trying to update my F150 conversion with a new reflection, SA plates, and SA lights. I did the headlights first, and ended up with this:

 

(look at headlight and the windows on the doors)

 

user posted image

 

Is there something different I have to do? Adding a smooth group in 3DS just makes the rest of the door look like crap. I did the lights like I always do and they're not even there!

Link to comment
Share on other sites

f5544, I found a lot of body part are actually same mesh but different bones/unknown value. So I don't think it's my script problem!?

 

If my script works, when you import 1st clump, the root bone will called 'Ripped'. Root bone for 2nd clump is 'Fat' and 'Normal' for the 3nd one.

 

Just make you model and export it follow those name rule will do! (Remember to set your model's pivot exectly the same as root bone, and edit the atomic section of your dff)

hi kam,

 

No if i import clumb 1 i get cj ripped

if i import clumb 2 i get cj ripped

if i import clumb 3 i get cj ripped

 

No cj fat and normal.

 

have you got gtasa?

 

try to import policetr.dff

 

i can send you the file over msn and test it for you?

 

thanks for your help

 

bye,

Frank

Link to comment
Share on other sites

f5544 and 91RS, you are right! They are bugs!

 

- for multi-clump import error, it is definate fixed!

- for vehicles light error, it should be fixed as well. (you know I can't test it myself)

 

but I can't see any smoothing problem from your pic? You might try to use the 'Smooth Group Solver' form my helper script (Apply to problem object only) to see if it help!

 

 

Great news for GMax user as well.

With this update, you don't need to run t2b.exe manually for DFF and COL now.

 

Links and details in the first post!

 

 

 

 

Link to comment
Share on other sites

So this release should have fixed my problems? I opened the .max file I saved and exported and both problems where still there. Do I need to import and start over to fix the problems?

Link to comment
Share on other sites

So this release should have fixed my problems? I opened the .max file I saved and exported and both problems where still there. Do I need to import and start over to fix the problems?

In theory, you don't need to do anything with your Max file. As I said it 'should' fix the problem but I'm not sure!

what I found was that I forgot to check if anyone use those light color with 'MMC'. And fixed that part!

I guess you already know how SA light works and it works before!?

 

So your problem is it works with my old script(which one) but not now? If you don't mind, send me both version of your dff export for me to debug!

 

 

And I didn't do anything about smooth group since I can't see your problem from the pic!

 

 

Sorry for disappoint you!

Link to comment
Share on other sites

I didn't mean the max file, I meant the DFF. I never saved the F150 as a MAX file when I first did it, so I had to import it to make the changes I wanted do. You can see it in my picture I just didn't expain it well, the smooth problem is on the top of the glass of the doors and it's white. I exported again using the new script and the lights were still invisible. Mainly I asked about importing again because of the window problem, that's not with the exporter but with the importer part of the script because I can see the problem in Max. And yes, the lights did work before using your script.

Link to comment
Share on other sites

I didn't mean the max file, I meant the DFF. I never saved the F150 as a MAX file when I first did it, so I had to import it to make the changes I wanted do. You can see it in my picture I just didn't expain it well, the smooth problem is on the top of the glass of the doors and it's white. I exported again using the new script and the lights were still invisible. Mainly I asked about importing again because of the window problem, that's not with the exporter but with the importer part of the script because I can see the problem in Max. And yes, the lights did work before using your script.

Sorry I still can't get what you mean? Could you give two screenshot (before/after) to show the different if you don't want to sent me the files?

With the headlight on if possible!

Link to comment
Share on other sites

hey there, i've got a problem, i import a SA vehicle trailer (bagboxa) and just as a test, i export it, once without a col, and 2nd time with a VC col file, and both times they dont show up in game, it just doesnt do anythign when i try spawn it :\

*edit*: and yes i have selected all the parts

Edited by [DRuG]Trix
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.