Jump to content

problems with graphics (?)


Recommended Posts

Hi everyone!


I have also quite many problems with my computer and GTA3SA. After some time game stops going back to desktop or to blue screen with error and restarts computer.

Usually on blue screen the error is caused by nv4_disp.dll or driver_irql_not_less_or_equal.

I have tried many things like:

update drivers of my graphics - nothnig

revert drivers - nothing


My computer is:


Motherboard: Asus A7V880 - newst BIOS updated

Audio intergrated

Processor: AMD 2000+ (1667 MHz real speed)

Memory: 2 x 256 DDR (Dual Channel) - 512 MB total

HDD: 60 GB IBM, 20 GB Maxtor

Graphics: GeForce4 MX 440 128 MB - nVidia Detonators newest: 78.01

(tried even older too).

DirectX: 9.0c

Optical: DVD-RW Dual LiteOn + DVD reader Samsung + CDRW LiteOn


Can you help?


Today I got some hints to downgrade DX to 9.0b or use Omega Drivers or delete gta_sa.set. I'm going to try this today when I reach home.

I have read also that GF4MX440 may not be supported by the game, but GTA3SA works fine on my machine, even in 1024x768x32. So I doubt it's a reason. I was quite close to go and buy GF5500 but I read other people have similar problems with GF5900.


Can anyone help me?


Thanks a lot in advance for your help folks.



Link to comment
Share on other sites

Your graphics card is good enough to run it. Try rolling your drivers back to the previous update, and delete gta_sa.set


I think you said you've tried to roll the drivers back, try this after you delete gta_sa.set. If this dosen't work, then go back to your original drivers and try again with that.


See if that works, if it dosen't, then post what happens.


Link to comment
Share on other sites

Big Vinny: thanks for your response!


I have already rolled back to drivers nVidia 66.81. Didn't help. Yesterday I deleted gta_sa.set - didn't help. Downgraded DX9.0c to DX9.0b - didn't help. Uninstalled nVidia drivers totaly (cleaned with special software) and installed Omega drivers - didn't help.

I have also updated sound driver of my mobo chipset. Didn't help. Is it possible my AC97 sound chipset is incompatible? I have Sound Blaster Live! in my drawer, I can install it in my computer and see if it helps. But I'm not sure if sound is a reason.

I have statrted thinking about installing Windows from scratches. But I'm not convinced.

Of course I have SP2 installed. Actually, my OS is almost fresh. Installed one week ago. Almost no other software - temporary I'm disconnected from ISP. So no firewalls, no antivirus software, no problems. Computer is clean of spyware, trojan, viruses, whatever else. This configuration of machine I have for couple of months - no problems at all I had previously. No hanging up. I observe temperatures - seems to be ok, no overheat. All fans are rotating. Memory is also stable.

I have no idea what's going on. I have also notebook, Asus A6000. But it has poor graphics (some SIS) so I can't play SA. SA is so slow, like in slow motion :-(. So I'm unable to say if GTA SA is working or not on my notebook.


What I will do is:

format drive C:;

plug SB Live!

install WXP Pro;

install SP2;

install all drivers (newest, but nVidia Detonators 66.81)

install DX9.0b

install GTA SA

cross my fingers and pray I can play... :-)


ps. do you think any influence may have desktop resolution 1280x1024x32 and game resolution 800x600x16 / 1024x768x16?


wish all of you nice and quiet weekend... so you can play San Andreas been no disturbed ;-)


Link to comment
Share on other sites

i have the same video card (but 64 Mo) with:

forceware 45.23

directX 9.0c


it work fine on:



Draw Distance : medium

FX quality LOW

mipmap disabled (with nVHardPage)

FPS limiter ON






Link to comment
Share on other sites

If you have built the PC yourself, you may want to double check your RAM. ASUS Motherboards (especially ones running the nForce chipset) do not work well if you buy cheep sh*t RAM. If you have went and baught cheep RAM then you should send it back and buy some decent stuff (check if there are recomendations on the ASUS site for your board).


I know this as I baught Kingston Value RAM for my motherbaord and I kept getting the blue screen of death when I was using my computer with sertin programs that use alot of RAM and also full screen programs would cut out as well.

Link to comment
Share on other sites

No, that's no RAM.

My ASUS mobo (A7V880) is built on VIA KT880 chipset. And memory is GeIL Dual Channel PC3200 400MHz DDR CL2.5...


Best regards to all who are trying to help me...



Link to comment
Share on other sites

No, that's no RAM.

My ASUS mobo (A7V880) is built on VIA KT880 chipset. And memory is GeIL Dual Channel PC3200 400MHz DDR CL2.5...


Best regards to all who are trying to help me...



I strongly suggest you do check it out. Go to the ASUS website and search for your motherboard. then check if your RAM is one noted for working.

Link to comment
Share on other sites

Yes, it is. That is written in manual also.

Memory is not a problem. Nevertheless it can be broken. I will do low level test of memory.



Link to comment
Share on other sites

To: gta_rodney:


I have already pachted to 1.01 - didn't help.


To all:


I have formatted drive c:, installed WinXP + SP2 + all newest drivers. There is only OS and drivers and GTA SA on hard drive.

And still same problems.

DX9.0b, nVidia drivers 66,81 and Omega drivers. Same problems. I have also tried different BIOS settings - didn't help.

I did low level cpu, memory and system tests - everything is O.K.


And my problem is not solved.

If I check mmc for application error (I'm not sure if it's correct English name, because I have WinXP i other language, my national language :-) it says: dx3d error (or something like this, I forgot to take it with me). Anotoer error is caused by:

nv4_disp.dll, smwdm.dll (it's my SoundMax on-board audio), in pagefile.sys errors and so on.

As all my hardware seems to be ok, I have tested all sugested on this forum hints, I suspect my on-board audio, I did't test my SB Live! I have to do it - switch-off AC'97 and plug and install Live! Also one of the error was cause by eax. So maybe here I have some problems.

I suspect all problems happen in system memory... Even if Windows should protect these areas.

I will test my Live! and report here...


Have a good day



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.