Jump to content

Burnt RAM


Recommended Posts

So today I decided greedily that my 1024Mb of RAM wasn't enough, I thought I'd fill the third slot, so I bought an Elixir (I was told it's just a generic brand) 512Mb DDR - 400 MHz thing of RAM; if that helps. So I put it in it's place, push it in, making sure it's right in, all that. I turn the computer on, and I get the buzzing noise and a letter-digit error on the MB display thing. I check it up, memory error. I've had this before, last two times it was because it wasn't pushed in all the way. So I turn off the computer, give it a push in, wouldn't move and seemed to be right in. Tried my luck again, and turned the computer back on. Same thing, repeated. Again, not working, so I turn the computer off yet again. Try it yet again, and go to turn the computer on.


It won't start, and there's a burning smell. I feared the worse, and I couldn't, and still can't really tell if anything else was burnt. I took out the PSU, put my old one back in, took out the new thing of RAM, and the computer turns on fine. When I have a closer look at the RAM, the gold thingies on it, some are charred or totally gone:


user posted image


Now, my question. Why would this happen exactly? Would it be the RAM's fault, or something with my MB? And a last question; I haven't tried my newer PSU yet to see if that's okay, just using what works at the moment, so, would it not turn on because it has a safety feature of some sort, or that rooted also?



Link to comment
Share on other sites

i would think its a ram problem caused by a short on the DIMM. you should be able to take it back.



also, was the computer on when you installed the ram, or the ram not proporly seated when the comp was turned on?

Link to comment
Share on other sites

The latter, though I did think it was seated correctly. It wouldn't move in anymore at all. I'll try my luck taking it back then. Cheers.

Link to comment
Share on other sites

I agree with the short in the RAM stick. Being a brand I've never heard of before that's probably the problem.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.