Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (91,403 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions


[REL] GTA SA Admin Console Beta

Recommended Posts


hello sir


i don,t know u r working on the project or not but i want to ask u a simple question about ur control centre


i have added vehicles to gta sa and now when i play if i use ur console it shows not recognised vehicle i know the reason that it can,t find it


in car pics or data so i have added carpics thumbnails of accurate size and added data too but now also it is not in car saelection list


plz tell me where i m wrong n help me to correct it


ur software is best for me i needed these additions bcoz using control center makes my added vehicles behaving abnormally so i cant play




sorry but its no effort to modify ur product jst i want it to be more helpful n productful to me


if u feel its wrong thn i wil nvr ask again for this


hope u get my msg n reply soon.....


btw u rock man!!!

Share this post

Link to post
Share on other sites
AMD Ultimate

MAAAJJOOORRR BUGG! Windows 7. Fail to open.. it loads but nothing appears.

Share this post

Link to post
Share on other sites

OK, this IS a major problem - And the solution is a major pain in the you-know-where. Oh, and uhh - It's a hit and miss solution at that! bored.gif


First of all, you need to search Google for the "GTA SA Downgrade Patch". It's about 10mb and will change the version of your copy of GTA SA from 2.0, to 1.0 or 1.1. Sounds crazy? To downgrade something? Maybe it is - But it's essential to getting Control Center to work!


You've done that.


You now need to search for, and download, three 'OCX' files that are infuriatingly missing from Windows 7 64bit.


These are:







A good place to get them from is the OCXdump site (Google it, or Google the individual file names)


Once you've downloaded these - You need to move them from your download folder to the following location:




You may find that you already have one of them in there - In which case, when you're prompted to "Replace" or "Don't Copy" - Don't Copy.


Next - Press 'Start' (You know, the button at the bottom left hand corner of your desktop) and type in 'Run'. Open 'Run'.


Type in the following (Or just Copy and Paste from here):


regsvr32 \windows\SysWOW64\COMDLG32.OCX

regsvr32 \windows\SysWOW64\MSCOMCTL.OCX


regsvr32 \windows\SysWOW64\TABCTL32.OCX


**YOU MAY RECEIVE AN ERROR MESSAGE EACH TIME** - But it seems to make no difference whatsoever.


Now, here's where my assistance gets a little... confused.gif ! Unsure! Because I did quite a few things after the above failed to fix the problem immediately - I can't be sure what I've suggested below, worked (Though something did!)


1. Uninstall any previously installed GTA SA Control Center files then restart. Reinstall the Control Center.


It seems to me that you MUST be IN THE GAME for the Control Center to initiate the first time (If it's a new game - In the alley, before you get on that bike) When Tenpenny's thrown you out of the car and you gain control of CJ first - Press 'Esc' then switch to the desktop (Alt+Tab together).

Or whenever a previously saved game has loaded - And you're able to control CJ's movements.


Should work.


2. If not! Try asking Windows to help you find the best Compatibility settings by right-clicking the GTA SA Control Center shortcut and selecting 'Troubleshoot Compatibility' (You may have to try more than one suggested fix)


If it still isn't working - Go here: http://www.gtagarage.com/mods/show.php?id=11359

And download the 'Source Code' (11mb)


Extract the zip compressed download and look for the GTA SA Control Center executable in there, and try and get THAT compatible (As per step 2)


Try the above and get back to me if it still doesn't want to work.


(By the way, I found the information about putting the OCX files in SysWOW - I'm not claiming false authorship there! biggrin.gif )





Share this post

Link to post
Share on other sites
Erik The Born

Can you add the option to freeze "get back in your vehicle timer"?

Share this post

Link to post
Share on other sites

the site you've hosted these on is down. not only that, but I don't see why anyone should have to go through all that trouble just to use this program on Win 7 64bit. something needs to be done about all this.

Share this post

Link to post
Share on other sites


I´ve used this in my old computer that had XP but now I have new computer with Vista and it won´t even start. Why? What I´m missing?

I had the same problem and i fixed it with this file: mscomctl.ocx

You have to download this file from here:Press Here and put it in the ControlCenter folder.

It worked for me...

Share this post

Link to post
Share on other sites

Just FYI...


(i) I managed to get this to work on my Win7 rig. To do this I (a) copied the files from my XP machine, and plopped in a directory, (b) copied the OCX files from my Win32 directory on XP and dropped them in my WinWOW64 directory, as well as in the root of the control center, and © ran compatibility setting scanner on the control centre exe and it found WinXP-SP2, and viola! It now works!


(ii) Mind you, it does seem -- or maybe it's SA on Win7 -- a little less stable. I guess that's to be expected. ADDENDUM: I've found the handbrake is permanently on, the "vertical mouse" 10x more sensitive than the horizontal which makes aiming next to impossible. I think it's XP VM time. I really don't think this is a viable idea.


(iii) I've used this since I've been playing SA and it is undeniably AWESOME. I'm sorry to read the author has been forced to abandon it on account of family life, but he wrote an incredibly useful tool, and for that I thank him.


(iv) There were consoles too for VC and III, which were similarly awesome. It was using the console on III that meant I played that thing for over a thousand hours -- the most I have played any game ever. It's a shame game publishers appear set on preventing this sort of hackery going on because this is the best use of games: hacking them. Some of the vids I've seen of IV hacked MP sessions convince me of this. I'm glad R* didn't make it too hard for the IV hackers.


Anyway. Hope this helps.

Edited by aragond

Share this post

Link to post
Share on other sites

i also have the problem of "online no game in progress" and i dont know waht virsion of game i have. how do i check my virsion? plz help


Share this post

Link to post
Share on other sites

Could be stupid........ but is there a way to run this on WIndows 10?

It was the best trainer ever.

Tried compatibilty mode for Xp SP2 but no work

Share this post

Link to post
Share on other sites

Such a pity. I don't think this even works with Win10 anymore. :(

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest


Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.