Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    2. News

    1. Red Dead Redemption 2

    1. GTA Online

      1. After Hours
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

steve-m

[REL|SA] Map Cleaner

Recommended Posts

G)-(OSTofCT

On/Offtopic: I've been tring to figure out the odd boat paths and randomly placed water creature life.

 

I dunno how many people have tried (or have been bored enough) but when you go back to St Marks (Liberty City), jump the wall and fall through where the col files end you sometimes land in water that isn't there.

 

I swam around for a while and boats, oysters and fish are randomly scattered once you swim past the 6000 mark (the end of the map).

 

hardcoded stuff?

Edited by G)-(OSTofCT

Share this post


Link to post
Share on other sites
Redkiller

Ummmm, ok, I i used your tool steve to remove the sh*t, and it did the looping sh*t. SO I copied an IPL and iDE put my sh*t in there deleted the uneeded stuff, added my things to the img, added the lines to the GTA.dat, but it still don't work. WTF? im getting sick of wasting hours of time and getting the same sh*t over and over. mad.gif

 

Share this post


Link to post
Share on other sites
burpicane

Does it remove the files in gta3.img by you cause that's problem by me tounge.gif

Share this post


Link to post
Share on other sites
TRN4L
I ran the map cleaner on a fresh install, and the game crashes when i try to start a new game. Did i miss somthing or is it just that it doesnt work on all games? Must i be using an unmodified exe?

Share this post


Link to post
Share on other sites
steve-m

 

Although it works for some people, I'm not able to run a stripped version of SanAn without the loading routine entering that infinite loop of doom. However, as soon as I add custom objects (like a part of Myriad) it does work. Strange.

 

Share this post


Link to post
Share on other sites
TRN4L
I figured out why I was crashing out... it was a small, but important "oversight" by me. I've got it workin out the loop too. Thanx steve. Edited by TRN4L

Share this post


Link to post
Share on other sites
dertyjerzian
Ummmm, ok, I i used your tool steve to remove the sh*t, and it did the looping sh*t. SO I copied an IPL and iDE put my sh*t in there deleted the uneeded stuff, added my things to the img, added the lines to the GTA.dat, but it still don't work. WTF? im getting sick of wasting hours of time and getting the same sh*t over and over. mad.gif

 

99.9% chance that you are doing something wrong, other than the way you've regarded your respect on the boards hehe.

 

I'd bet you have an important integer in your IPL wrong or missing, or you've made a typographical error in your gta.dat. Check it out, good luck.

Share this post


Link to post
Share on other sites
Cecil475

I try to clean San Andreas using the default settings and I keep geeting this...

user posted image

 

What am I doing wrong?

 

- Warren Lewis

Share this post


Link to post
Share on other sites
steve-m

Did you modify the game in any way? Are any of your game files read-only? Do you have full read/write access to your SA directory? Are any of the files opened by another program (e.g. IMG Tool, MooMapper/MEd)? What game version do you have?

Share this post


Link to post
Share on other sites
The-end

Hi Steve, im having some trouble with your map cleaner, i clean the game patch the scm and water and i get the infinite loop of doom so then i do as sujested and add a custom object to the game (1 object) i know it's all correct as it works normally without the map been cleaned.

 

How many objects need to be added in order for the game to start?

Share this post


Link to post
Share on other sites
steve-m

I have no idea, but apparently more than 1... wink.gif

Share this post


Link to post
Share on other sites
The-end

Oh ok thanks for the info, im just curious if this method works/ frees up the model places.

 

I deleted all of the placemnt information in the Lae2.ipl, does this free up the model slots it was using? When i deleted the ide information for Lae2 the game froze during loading.

Share this post


Link to post
Share on other sites
steve-m

No it won't, since you still define the objects (and use slots), you just don't instantiate them. And you can't just delete one ide since there are many dependencies between the map files, and you also have to delete unneeded cols and bin ipls from the img.

Share this post


Link to post
Share on other sites
The-end

Right ok, thanks for the info Steve icon14.gif

 

 

Ill just keep trying to get my game to work with the map cleaner.

Share this post


Link to post
Share on other sites
Jestic

I have a question, what exactly cleans this program ? I now it cleans the gta3.img and it places # in the gta.dat, but what else cleans this program ?

And i have found something strange:

I have a clean sa. I run the SA Map Cleaner and i apply the changes. I copy the main.scm and water.dat from the the sa map cleaner dir. to my sa map. At last i rebuild the gta3.img. The game crashes...

When i add bistro.txd to the gta3.img, sa works! xmas.gif

That means the sa map cleaner removes bistro.txd, but why ?

Share this post


Link to post
Share on other sites
The-end

wow thanks for posting that Blster, my game now works, i am very happy smile.gif

 

@steveOk i need to change the place my player spawns at but when i remplie the scm i get this message.

 

user posted image

 

it then leads me to this line.

 

0053: $PLAYER_CHAR = create_player #NULL at  $SpawnX $SpawnY $SpawnZ

 

 

Edited by The-end

Share this post


Link to post
Share on other sites
Jestic

Maybe this line works...

 

0053: $PLAYER_CHAR = create_player 0 at $SpawnX $SpawnY $SpawnZ

So, you should replace #NULL to 0

Share this post


Link to post
Share on other sites
The-end

Ill try that thanks, i just edited the coords, didnt change anything else.

 

EDIT:That worked great thanks, also how do i chnge it so the player spawns in a bullet, i also had to remove the whole player spwning in hydra part because it woudlnt comple with it in there sad.gif it said it could not find #hydra in the .ide

Edited by The-end

Share this post


Link to post
Share on other sites
Jestic

That's because SA uses ID numbers instead of the real names, the hydra is 520.

 

 

0247: request_model 520:MAIN_20001: wait  0 ms00D6: if  00248:   model 520 available004D: jump_if_false ££MAIN_200A5: $vehicle = create_car 520 at $SpawnX $SpawnY $SpawnZ036A: put_actor $PLAYER_ACTOR in_car $vehicle

 

 

The bullet would be:

 

 

0247: request_model 541:MAIN_20001: wait  0 ms00D6: if  00248:   model 541 available004D: jump_if_false ££MAIN_200A5: $vehicle = create_car 541 at $SpawnX $SpawnY $SpawnZ036A: put_actor $PLAYER_ACTOR in_car $vehicle

 

 

I hope it works for ya... smile.gif

Share this post


Link to post
Share on other sites
The-end

Thanks allot Blaster, how come original it was coded with the #hydra instead oft id?

Share this post


Link to post
Share on other sites
Jestic

No problem The-End. smile.gif But i don't understand your question, what exactly do you mean ?

And this map cleaner only cleans the gta3.img and gta.dat, am i right ?

Share this post


Link to post
Share on other sites
steve-m

@The-end: If you copy default.ide, peds.ide and vehicles.ide over to your Mission Builder directory, it will replace the #... placeholders with the real IDs.

 

@Blaster_nl: Yes, it cleans gta3.img, deletes gta_int.img and removes unused file references from the gta.dat. The readme explains what the cleaner does step-by-step. No idea why it works when you add bistro.txd, since you definitely don't need it as other tests have shown. Maybe you can just add any file and it will work?

Share this post


Link to post
Share on other sites
Jestic

 

@The-end: If you copy default.ide, peds.ide and vehicles.ide over to your Mission Builder directory, it will replace the #... placeholders with the real IDs.

 

@Blaster_nl: Yes, it cleans gta3.img, deletes gta_int.img and removes unused file references from the gta.dat. The readme explains what the cleaner does step-by-step. No idea why it works when you add bistro.txd, since you definitely don't need it as other tests have shown. Maybe you can just add any file and it will work?

 

Thanks steve-m for the usefull information. smile.gif

I tried many files to find out why it crashes, after a few hours I found out that bistro.txd was missing. smile.gif

 

EDIT: But there is one thing i still don't get. Before you install (MI +) GTI you must run this sa map cleaner otherwise the game will crash. But in (MI +) GTI there is a gta3.img and a gta.dat included. And if the sa map cleaner only cleans the gta3.img and gta.dat (and it removes gta_int.img, but that doesn't matter...) why the game crashes then ? dozingoff.gif

Edited by Blaster_nl

Share this post


Link to post
Share on other sites
ARMax

works great stsve

 

EDIT: just noticed, steve-m is a SA worked, listed in one of the files biggrin.gif

Share this post


Link to post
Share on other sites
Mercenary1st

angry.gifangry.gifangry.gifangry.gifangry.gifangry.gifangry.gifangry.gif

I tried to use the thing but everything I do it comes up access violation and invalad pointer sh*t wtf help me cause i need it to use the SA LC mod

Share this post


Link to post
Share on other sites
booboomc21

hello

i get this error when trying to use SA map cleaner. Invalid Pointer Operation.

Can anyone help? thanks in advance.

Share this post


Link to post
Share on other sites
OnanManiak

Now you can release a working version of your program steve-m ? please

 

I tryed 0.4Beta version but this not working,game will not start,i god always error.

 

I have 1.0 EU version,i try reinstall game but i have same error.

 

Or if you can post here a working tut. to succesfully start game after using your program

 

 

Share this post


Link to post
Share on other sites
steve-m

DexX posted a test map that you can use with a cleaned game to prevent it from crashing. Make sure to read the install notes.

 

As for program bugs/crashes, I'll address those once I have time.

Share this post


Link to post
Share on other sites
*xXx*

umm after 10 seconds after starting the mapcleaner , this thing pops up and says

 

'Acces violation at address 00402387 in module 'MapCleaner.exe'. Read of address BF4A4918'

 

i dont know what it means confused.gif If you know how to fix this plz tell me how plz plz plz!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.