Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (84,924 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

  • 0
Jh00

Sound fix for GTA San Andreas here.

Question

Jh00

 

Hi there!

 

Some people were complaining (including me) of problems regarding sound in GTA S.A. Basically, after some time, you can only hear the music (no voices or other sound effects) and the subtitles are displayed so quickly that you can't even read them.

 

I think I discovered a very simple fix:

 

Just run dxdiag (START > RUN... > dxdiag and hit enter) and go the the sound tab. Then, change the slider to "basic acceleration" and you're ready to go! (I can't guarantee that these terms are accurate because I don't use an English vesion of Windows).

 

I'm sure it is something related to EAX, because I have experienced similar behaviour in other games. Since I couldn't find a switch to turn off EAX in GTA SA, this is the only thing I could do to make it work.

 

Hope it helps someone.

 

Peace.

 

Jh00

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0
jdawg224

I found that when you move the slider all the way down, you will get audio-sync issues. Basic, Standard, and Full Acceleration should be fine.

Share this post


Link to post
Share on other sites
  • 0
murdo

Although I am sure this will help most people, dont forget, DRIVERS DRIVERS DRIVERS!!

 

A friend of mine has a Sound Blaster Audigy Platinum eX, and *thought* he had the latest drivers. His problem was that he had sound for everything, EXCEPT the car he was driving. He could hear other cars, just not his own.

 

After updating the drivers to the latest available (which arn't very new... 2003 sometime!) everything was sweet once again...

 

http://files.europe.creative.com/manualdn/...4DRV_031031.exe

Share this post


Link to post
Share on other sites
  • 0
Fuse_Head

I would update drivers if newer were available.. biggrin.gif My card is old Sound Blaster PCI128 and there are no new drivers available so it won't work.. I think I'll just buy new card at monday. Maybe it will help and game won't crash anymore. tounge.gif

Share this post


Link to post
Share on other sites
  • 0
Fuse_Head

Sorry.. Double post.

Share this post


Link to post
Share on other sites
  • 0
maf

Worked for me, thanks biggrin.gif

Share this post


Link to post
Share on other sites
  • 0
NPNG

thanks alot m8

worked fine for me!!!

 

love u big time inlove.gifsmile.gif

Share this post


Link to post
Share on other sites
  • 0
oblong

this worked for me for a bit but now all of a sudden I have issues again and with the accel set on zero the game won't load coz it says no sound card is detected, i've also instituted all the other audi fixes except the dx downgrade, anyone know a way round this?

Share this post


Link to post
Share on other sites
  • 0
segvirion

Holy bumping, Batman! tounge.gif

 

I thought that necroposting was not allowed...

Share this post


Link to post
Share on other sites
  • 0
uk_john

I have solved the sound cutting out and stuff when it rains, but what about the electronic beep noises when it rains? Any help there?

Share this post


Link to post
Share on other sites
  • 0
Girish
I have solved the sound cutting out and stuff when it rains, but what about the electronic beep noises when it rains? Any help there?

Was there really a need to bump a 3 year old topic? I think not.

 

Any sound issues people had during rains were fixed in the v1.01 patch. If you still have issues, consult the pinned audio fixes topic and preferably, post in there itself.

 

 

user posted image

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.