Jump to content

stream.ini


davew2040

Recommended Posts

If you open stream.ini, you'll see a tag indicating how much memory is allocated to streaming content (at least I assume that's what it is). If you have a lot of RAM, you can probably set this to something higher than what it is; I think it's 12mb, so you could conceivably allocate a whole bunch more if you had a gig of RAM. Attempt at your own risk.

Link to comment
Share on other sites

And I strongly recommend people try this. I don't know how well the game streams by default, but if you're having problems, this is just like the Limits Adjuster SteveM made for Vice.

Link to comment
Share on other sites

Original:

 

memory  13500devkit_memory	13500vehicles	12pe_lightchangerate	0.0005pe_lightingbasecap	0.35pe_lightingbasemult	0.5pe_leftx	16pe_topy  16pe_rightx	16pe_bottomy	16dontbuildpaths

 

 

what i've changed it to:

 

memory  512000devkit_memory	512000vehicles	512pe_lightchangerate	0.0005pe_lightingbasecap	0.35pe_lightingbasemult	0.5pe_leftx	16pe_topy  16pe_rightx	16pe_bottomy	16dontbuildpaths

 

 

I have 2 gigs of ram, and the peak memory usage in task manager stays at around 137mb, which is nothing

bbq.gif

 

p.s. in winxp task manager you can go to view->select more columns->check "Peak Memory Usage"

user posted image
Link to comment
Share on other sites

Original:

 

memory  13500devkit_memory	13500vehicles	12pe_lightchangerate	0.0005pe_lightingbasecap	0.35pe_lightingbasemult	0.5pe_leftx	16pe_topy  16pe_rightx	16pe_bottomy	16dontbuildpaths

 

 

what i've changed it to:

 

memory  512000devkit_memory	512000vehicles	512pe_lightchangerate	0.0005pe_lightingbasecap	0.35pe_lightingbasemult	0.5pe_leftx	16pe_topy  16pe_rightx	16pe_bottomy	16dontbuildpaths

 

 

I have 2 gigs of ram, and the peak memory usage in task manager stays at around 137mb, which is nothing

bbq.gif

 

p.s. in winxp task manager you can go to view->select more columns->check "Peak Memory Usage"

and did you get 512 vehicles at thew moment?

i think this tag stands for that

 

vehicles	512

 

 

Link to comment
Share on other sites

santaclaws

 

Original:

 

memory  13500devkit_memory	13500vehicles	12pe_lightchangerate	0.0005pe_lightingbasecap	0.35pe_lightingbasemult	0.5pe_leftx	16pe_topy  16pe_rightx	16pe_bottomy	16dontbuildpaths

 

 

what i've changed it to:

 

memory  512000devkit_memory	512000vehicles	512pe_lightchangerate	0.0005pe_lightingbasecap	0.35pe_lightingbasemult	0.5pe_leftx	16pe_topy  16pe_rightx	16pe_bottomy	16dontbuildpaths

 

 

I have 2 gigs of ram, and the peak memory usage in task manager stays at around 137mb, which is nothing

bbq.gif

 

p.s. in winxp task manager you can go to view->select more columns->check "Peak Memory Usage"

and did you get 512 vehicles at thew moment?

i think this tag stands for that

 

vehicles	512

 

I tried those setting and nothing happened. Same amount of cars and memory usage was the same.

Link to comment
Share on other sites

santaclaws

 

Perhaps those numbers are too high, try something lower.

I already tried with lower numbers and i didnt see any diffrence.

Edited by santaclaws
Link to comment
Share on other sites

I think that is the number of different vehicle models allowed in RAM. If you have a higher number, you should see more diversity in traffic. I'll try it out some time later.

 

By the way, is it just me, or is there more trafic on the highways than there was in PS2 version of Sandy?

Prior to filing a bug against any of my code, please consider this response to common concerns.

Link to comment
Share on other sites

I doubled the memory limit and increased the car limit from 12 to 20. I didn't see any additional cars compared to what there was, but there did seem to be more diversity in the models that appeared. Normally you can get 2 or 3 of the same car driving in a row, didn't notice that with the file changes and I was standing in the middle of the freeway holding up about 8 or 9 cars.

 

And yeah, there does seem to be a lot more traffic.

Link to comment
Share on other sites

liesofsilence
Thanks for posting. Anyone get some settings for 512 mb ram?
Link to comment
Share on other sites

  • 5 years later...

memory 512000

devkit_memory 512000

vehicles 50

pe_lightchangerate 0.0

pe_lightingbasecap 0.0

pe_lightingbasemult 0.0

pe_leftx 0

pe_topy 0

pe_rightx 0

pe_bottomy 0

buildpaths

 

nervous.gifwow.gif

Link to comment
Share on other sites

  • 6 months later...
colt45m1911

Thanks this fixed up my San Andreas. I have a few "slow" spots on the map, but when I drive around running 17 CLEO mods and an extra 100MB in gta3.img, this helps. I used to look one way, then slowly houses would load, then I would look another way, and slowly houses would load and the ones behind me would disappear. This was a big annoyance. Sometimes now the houses look low quality when I turn around, but quickly load up and no houses or roads completely disappear.

Link to comment
Share on other sites

  • 5 years later...
  • 6 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.