Jump to content

The thread that started it all


Demarest

Recommended Posts

Craig Kostelecky

I would appreciate that greatly. Good luck.

Link to comment
Share on other sites

Urban Legend

I'm trying this bad ass grind on Salvatores mansion...

 

http://www.megafileupload.com/en/file/413900/replay-rep.html

 

Just drop the .rep file into the "user files" folder usually located in My Documents, start any saved game or new game for that matter and press F2 to view the replay.

Thanks LC team! I did land it before but it's a long story tounge.gif I gotta do it again.

user posted image

 

Link to comment
Share on other sites

Craig Kostelecky

I have finished converting all of the missions into high-level code. There's still two small threads in the main section that I need to update. I have tested each mission, though only briefly. So I'd like some help testing this out. It's very possible that a mission that played 100% correctly before may now have some new bugs. So please try to play each mission in many different ways. Please report any bugs either here or in the bugs thread.

 

Download

 

Edit, the entire code is now converted. There may be minor bugs in the car crusher yet.

Edited by Craig Kostelecky
Link to comment
Share on other sites

  • 2 weeks later...
Craig Kostelecky

I've never tested any GTA games with multiplayer. Its also never been this team's objective to add multiplayer support. We fully welcome mods on top of this though. Anybody can use our files as the base of their mod just as if it was a game released by Rockstar.

Link to comment
Share on other sites

HackMan128

OMG, another clever, who didn't bought pendrive with 0,5 GB and copy important things.

There is always risk, and I seen people here before, who lost their data because of dead HDD.

Link to comment
Share on other sites

After this two years and four months at your home, this time to make mod. wink.gif

Edited by Baris_22
Link to comment
Share on other sites

Craig Kostelecky

I'm not sure what you're trying to say there Baris_22.

Link to comment
Share on other sites

ThirteenAG

I can't start this mod sad.gif

I've downloaded Beta3.3.rar, 33update.rar, unpacked it to a clean install of VC, with 1.0 exe. Menu runs fine, but immediately after i press start new game, crash appears with errorlog:

 

Exception at address:	0x07381F9CEXE Version:          gta-vc.exe 1.0 USRegisters -----------------------------------------------------EAX: 0x06B720E4	EBX: 0x0068E59C	ECX: 0x06B720E4	EDX: 0x6EFF4CE0ESI: 0x6A9DE9A0	EDI: 0x001C1088	EBP: 0x6A9DE9A0	ESP: 0x0013FDF8EFLAGS: 10000001000010010

 

 

After deleting vc_traffic.asi, vc_weather.asi i can see loadscreens for a while, then this:

 

Exception at address:	0x064C1660EXE Version:          gta-vc.exe 1.0 USRegisters -----------------------------------------------------EAX: 0x00000000	EBX: 0x007E3FB8	ECX: 0x007E3FB8	EDX: 0x00000000ESI: 0x00000006	EDI: 0x00211088	EBP: 0x00000000	ESP: 0x0013FDC0EFLAGS: 10000001001000110

 

Both vc_traffic.asi and vc_weather.asi works on the normal game.

After deleting IIItoVC.asi cutscene starts, everything seems working fine, until i enter the car:

 

Exception at address:	0x004630EEEXE Version:          gta-vc.exe 1.0 USLast opcode executed:	0100 opcode_0100In thread:            hjRegisters -----------------------------------------------------EAX: 0x00000000	EBX: 0x007E3160	ECX: 0x00000001	EDX: 0x00000000ESI: 0x00000100	EDI: 0x00000100	EBP: 0x007E3160	ESP: 0x0013FC70EFLAGS: 10000001001000110// THREAD "usj"00015438: opcode_00D6        ...

 

 

With removed vcopcode.asi:

 

Exception at address:	0x004630EEEXE Version:          gta-vc.exe 1.0 USLast opcode executed:	0100 opcode_0100In thread:            hjRegisters -----------------------------------------------------EAX: 0x00000000	EBX: 0x007E3160	ECX: 0x00000001	EDX: 0x00000000ESI: 0x00000100	EDI: 0x00000100	EBP: 0x007E3160	ESP: 0x0013FC70EFLAGS: 10000001001000110// THREAD "c_carp"

 

 

I have Windows 8 x86, tried with x64 too, same thing.

Link to comment
Share on other sites

Craig Kostelecky

Do you also get a crash if you try to launch the game in debug mode? You can do that by either opening up gta-lc.ini and changing UseDebugSCM=0 to UseDebugSCM=1 or rename the DBUG.scm to MAIN.scm.

 

The traffic and weather asis are optional, but the others you mentioned are critical. The game will not play (for long) without them.

Link to comment
Share on other sites

ThirteenAG

Yes, without vc_weather.asi/vc_traffic.asi i have:

 

 

Exception at address:	0x03601660EXE Version:          gta-vc.exe 1.0 USRegisters -----------------------------------------------------EAX: 0x00000000	EBX: 0x007E3FB8	ECX: 0x007E3FB8	EDX: 0x00000000ESI: 0x00000006	EDI: 0x00321088	EBP: 0x00000000	ESP: 0x0013FDC0EFLAGS: 10000001001000110

 

 

I also don't have any sound, and audio options in the menu are unavailable.

Link to comment
Share on other sites

ThirteenAG

Mystery solved, i didn't copied audio files from gta3, shame on me smile.gif

It's working fine now.

 

UPD. 33% of my cleo scripts working with the latest beta. I also had to delay cleo.asi loading to make it work with them, without it only 1 script worked for me. mercie_blink.gif

user posted image

Edited by ThirteenAG
Link to comment
Share on other sites

Craig Kostelecky

Great to hear. I'm strongly considering including all the audio with beta 4/1.0 Final.

Link to comment
Share on other sites

ThirteenAG

About that cleo delaying thing i mentioned, here's the asi i used: https://dl.dropboxusercontent.com/u/1399262...leo_starter.asi

 

Code is very simple:

 

Sleep(1000);LoadLibrary ("./CLEO.dll");

 

CLEO.asi should be renamed to CLEO.dll and be located in root directory, cleo_starter.asi goes to root folder too.

 

I don't know what bugs it may cause.

 

UPD. I might have an idea why cleo scripts isn't compatible with GTA LC:

Original game:

 

$2=player_char$3=player_actor

 

 

GTA LC:

 

$136 = $player_char$137 = $player_actor

 

 

Shouldn't be too hard to fix.

 

UPD2: Okay, 100% of cleo scripts working with GTA LC.

https://dl.dropboxusercontent.com/u/1399262...CLEOtoGTALC.bat

You'll need 010 editor to run this script.

Copy VCCLEOtoGTALC.bat to CLEO folder, run it and wait a few seconds, it will convert vice city's cleos to compatible with GTA LC main.scm(this one, not sure about the others) cleos.

 

user posted image user posted image user posted image

Edited by ThirteenAG
Link to comment
Share on other sites

Easier, we may fix next release SCM to make these vars occupy proper indexes. Thanks for mentioning.

Link to comment
Share on other sites

ThirteenAG

 

Easier, we may fix next release SCM to make these vars occupy proper indexes. Thanks for mentioning.

In-built delay of cleo.asi loading would be nice too, because otherwise game crashes.

Link to comment
Share on other sites

Craig Kostelecky

I think it'll be a good idea to have the LC mod CLEO ready when the final version ships. Kind of like how the old DMagic wheel mod is already a part of the mod from the beginning.

Link to comment
Share on other sites

HackMan128

Hey, isn't LC better with white lines, when plane is flying?

It's cool VC feature.

Link to comment
Share on other sites

Hey, isn't LC better with white lines, when plane is flying?

It's cool VC feature.

White lines? What white lines?

Link to comment
Share on other sites

Craig Kostelecky

I too was a bit confused with what he meant, but ultimately guessed it was the jet trails. It's been a while since I looked up in LC, are those trails present?

Link to comment
Share on other sites

I too was a bit confused with what he meant, but ultimately guessed it was the jet trails. It's been a while since I looked up in LC, are those trails present?

Just loaded up the game in wine. And, they aren't there. Would this be simple to fix?

Link to comment
Share on other sites

HackMan128

Sorry for misunderstanding, I just had problems to find proper name for that plane fog tounge.gif.

I think it wasn't visible since beta 2.

Link to comment
Share on other sites

Craig Kostelecky

 

Would this be simple to fix?

I'm not sure where that data is. I have no problem enabling it if someone can nudge me in the right direction.

Link to comment
Share on other sites

HackMan128

I know, what determine planes to leave white lines.

It's LC option

 

[Misc]DisableScrollObj=0

 

and

 

[Objects]

 

which you can leave empty.

Edited by HackMan128
Link to comment
Share on other sites

Craig Kostelecky

Awesome, switching that variable not only turned those jet trails on, it also turned on the scrolling message boards by the Portland tunnel, sunshine autos, Times Square, and the airport. Cool. I wonder why we (or I) ever switched that off.

Link to comment
Share on other sites

HackMan128

Because it may turn on VC airport escalators, which is located in LC's airport too (but it shouldn't because this: Esc_step=amcogaragedoor), you should check.

As it is in LC Launcher's source code, this function has four addresses, which are NOPed.

I don't know, which address is affinity with what, but it's easy to test on ArtMoney or some memory tools like that.

It would be cool to have them documented smile.gif.

Edited by HackMan128
Link to comment
Share on other sites

Russel Stone

What about iOS version? Is it planned? Original GTA 3 is sh*t on my iPhone 5

Link to comment
Share on other sites

Craig Kostelecky

Not by us. Anyone is free to use our files to port it over though.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.