Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
      4. Frontier Pursuits
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. DLC
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
      7. The Diamond Casino Heist
    2. Grand Theft Auto Series

    3. GTA 6

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA IV Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA SA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA VC Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA III Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

Demarest

The thread that started it all

Recommended Posts

Demarest
ok i threw together a fixes pack with installer.

 

http://www.hot.ee/karlneil/GtaWorldOnlineFixes.zip

 

if the link dosent work , copy the url and paste it to the adress bar.

The address says GTAWO in it. The files these mods were for were known as the GTA:LC files and the name of this project is GTA:LC. Again, WO has nothing to do with what we're doing here.

 

@crazydude: You have to use the RCBaron as that is the only vehicle ID that allows for winged flight AND to have wheels. When I tried, I replaced the DFF and TXD with that of the Dodo as well as the handling line. I did NOT address the COL file though and judging by the way it drove, THAT's where I went wrong. If nobody else can fix that, I'll contact punk_rocker128 because he says he can do vehicle COLs. Can't be too hard though.

 

@Knux: The sirens under me indicate that I am a member of the official forum gang The Precinct.

Share this post


Link to post
Share on other sites
Lix

@theanswer same problem occurs for me sad.gif

Share this post


Link to post
Share on other sites
Aztlan

hopefully illspirit can allow this mod to have its own forum because this thread is becoming big and unorganize

 

and like Demarest said. Karlneil gtawo didnt make those fixes

gta:lc team did

 

and rofl to blaer's posts biggrin.gifbiggrin.gif

Edited by Aztlan

Share this post


Link to post
Share on other sites
killer.ip

The good news is that I believe I've arrived at an answer to the bug just reported in Portland, there is no bad news...

 

After testing all 6 files individually, and then in pairs to see if it was dependancy related, I got a total of zero crashes (tested between 5-10 mins each time). Just for the hell of it I reinstalled those files with the Mod Installer, and managed to reproduce the crash twice in a row on the same corner in Portland... you probably see where I'm going here. I then installed all 6 files manually and with no crash problems. So my final test was to install them using the Mod Installer, then rebuild the archive manually with IMG Tool, 10 minutes later still no crash.

 

So the advice I can give is to rebuild your IMG archives manually after installing a mod or fix using the GTA Mod Installer.

 

Let me know if any other problems crop up, with the number of files we're dealing with here it's no surprise sometimes things don't work out quite according to plan. smile.gif

Edited by killer.ip

Share this post


Link to post
Share on other sites
kipo

 

too much too read, no time to update everything.. too many things to add.. anyone waht to be webmaster and to do it? I'm busy with Run down that guy!! with the paths (he's doing some great job, there is some peds and some boats ingame

 

 

Im willing to help with the ped paths for the third island, if thats ok with you, or him, no mistakes now, guaranteed, unless of course, hes already done them confused.gif

Share this post


Link to post
Share on other sites
Posty_2k3

 

After installing the last fixes my game crashes in portland  sad.gif

the exact points are:

 

image

I think it happened after installing the skidz map fix or the 2d fix compilation of killer.ip

Yep, the 2nd pic you posted is where I crash too. I have no freakin clue what to do now. Oh well, I'll just avoid that spot from now on wink.gif i take a different path to places now.

 

EDIT: Read the thing wrong up there. I see how to fix it wink.gif

Edited by Boombot

Share this post


Link to post
Share on other sites
Knaxia

Good news everybody

 

PORTLAND TRAFFIC = DONE

 

user posted image

 

the only little prob is, since there is no paths to the bridge, the traffic/traffic light combo is f*cked up, the traffic wont stop at the good lights.To the traffic to stop correctly, the inntersection nodes all need to be connected to another road paths connected itself on the 2 extrimity by something else.

It will be fixed as soon as traffic on brigde will be re-done, I removed the bridge path to avoid problem you saw under it and also, those paths needed to be redone completly.

 

I will put files in the next mins here (in EDIT)

 

EDIT: here we go: HERE

 

number of paths = 183

file size (paths.ipl) = 100k

files size (zip) = 12k

files included =

.../data/info.ipl

.../data/gta3maps/paths.ipl

Installation: Remplace old files by those in the zip file in the good folder

Edited by Knux

Share this post


Link to post
Share on other sites
Aztlan

nice to hear that biggrin.gif

Share this post


Link to post
Share on other sites
Posty_2k3

@killer.ip

Okay, I followed your instructions for the mod. IT STILL WONT WORK. I keep getting crashes no matter what i do. I added files manually. I rebuilt archive after mod installer. I even tried the original file sagain. It just wont work sad.gif If you ahve msn or something, I'd really apreaciate if you could help me fix this dang bug.

Share this post


Link to post
Share on other sites
killer.ip

Sorry to hear you're still having problems Boombot, thought I'd nuked that bug earlier on today. If you've tried installing the files as per instructions after a clean install of the mod, and are still gettin crashes, then you could try downloading and running a new set I've just uploaded that contain all but the six I mentioned earlier as being the possible culprits.

 

Before installing and using the files in this revised update, make sure you are using fresh gta3.dir & gta3.img files. These can be found in the original compressed file of the mod you downloaded.

 

You can download the update here.

Share this post


Link to post
Share on other sites
Aztlan

Nice work Knux

to the team i just saw an issue with this mod

i look at the txd files of the map and there are alot of textures with 32 bit textures

nobody has probably seen thats is an issue because most have tested the mod with stock cars

i just tested the mod with car mods installed the and the game goes crazy. textures flashing on and off etc. you probably are going to say that the car mods are guilty. but the car mods all have 8 bit textures and prior to installing this mod. the original vice city worked perfectly with these cars

i also compare the textures. and vice city has all textures from 8 bit to 16 bit

but not 32 bit because the vice city engine doesnt handle 32 bit textures very well

people who might want to install car mods in this mod will see the issue i am referring to if the textures are not converted

converting the textures is my speciality hehe

and if the team wants to i can convert them

also:

i have converted other building textures from 32 bit to 8 bit without a loss of quality wink.gif

 

on the funny side i saw this glitch hehe

is a game glitch not the mod

user posted image

Edited by Aztlan

Share this post


Link to post
Share on other sites
killer.ip

Hi Aztlan, this is exactly the issue my initial release of the Transparent Texture Fix addressed by converting all of the TXD's that contained just 32bit images into ones using DXT1/DXT3 compression with TXD Workshop. That's roughly 2000 individual textures.

 

If you open up the TXD's contained in the original files of GTA3 & VC you'll find that Rockstar used a mixture of 8bit and DXT compressed images themselves. If you used Vice TXD instead of TXD Workshop to view the files, the DXT compressed textures will appear as 16bit.

 

I'm afraid at this moment I'm doubtful as to whether that release or the update I'm planning is to make it into a release of the mod.

 

[EDIT] Nice pic btw. turn.gif

 

[EDIT2] This was a badly named release. While it can cause transparent textures, it's more likely to cause them to either fade or be rendering at a lower res. Check out those pics below.

Edited by killer.ip

Share this post


Link to post
Share on other sites
Aztlan

ooh ok

if you want help in that part

i am here smile.gif

Edited by Aztlan

Share this post


Link to post
Share on other sites
killer.ip

Well, I think first it needs to be assertained whether or not there is a problem with the DXT compression I used, so I think a valid first step might be to distribute the files to a handful of beta testers to see if in fact I did introduce more bugs than I fixed.

 

All that's left to do is to convert a further 15 or so files containing a mix of 8bit and 32bit images. These can't use DXT compression, as when you use DXT compression on an 8bit image it screws up the colour chart. The 32bit images in these files need to be manually converted to the 8bit format.

 

If you're willing I can see what I can do about uploading the files again and we could start some testing. smile.gif

Share this post


Link to post
Share on other sites
Aztlan

i will be glad to test them smile.gif

aztlan goes to make a backup just in case

to get a better understanding of what i am talking about

look at this

behind me i have two car mods (which you cant see) and this happens

the cars have 8 bit textures and are not that high poly.

 

user posted image

 

and here

 

user posted image

Edited by Aztlan

Share this post


Link to post
Share on other sites
Posty_2k3

@killer.ip

Your new fix doesn't crash the game at all! biggrin.gif (finally!) Great job biggrin.gif

Share this post


Link to post
Share on other sites
scarface_refugee

Hey Demerast. It's no problem for me to keep track of all the updates, and put them into an auto installer and/or put all of the updates, patches, ect. on a website. I have one autoinstaller finished that has about, 4 updates. The only problem is with the GTA3.img, I cannot just add in the file GTA3.img into the .exe because it would be far too big. The GTA3.IMG with a couple updates was around 333 mbs.

 

Thanks

Share this post


Link to post
Share on other sites
crazydude

Since when you first start the game, the whole city loads up, it doesnt have any loading screens, so your computer has to work alot harder to load everything. Gta LC runs slower than gta3 or vc for me because of this, plus having the 32 bit textures makes it worse. nervous.gif

Share this post


Link to post
Share on other sites
PineCreek-Skidz

killer.ip: Sweet release man, it makes the game look so much better.

 

About the texture problem.

This looks like a huge job if its all manual work, maybe someone with programming knowledge could build us a little app to do it for us smile.gif

Kinda dought it, but that would be sweet.

Share this post


Link to post
Share on other sites
Aztlan

killer.ip has converted some/probably most of the textures

and we agreed that i am going to do the rest

 

if thats ok with the rest of the team smile.gif

Edited by Aztlan

Share this post


Link to post
Share on other sites
Lix

@killer.ip your patch fixes the problem. You can go on holidays for now smile.gif

 

@Aztlan nice glitch there. It looks like a donkey riding on a bike tounge.gif

 

@Knux I will try your paths in a minute.

Share this post


Link to post
Share on other sites
MN316

I somtimes have the same problem as Aztlan dose, but then it loads the texture. I think its just your going to fast the textures havent loaded yet so you still see the LODs, just give it some time and it should come up.Maybe 5 10 secs and they should pop up.

Another proble I have too is around Luigi's club somtimes the textures of the buildings around it flicker.you see them and then there gone and then there back and it keeps going on and on.

Edited by MN316

Share this post


Link to post
Share on other sites
TheAnswer

After rebuilding the gta3.img it worked fine for me. No more crashes biggrin.gif

Good work killer.ip rah.gif

Edited by TheAnswer

Share this post


Link to post
Share on other sites
killer.ip

Thanks for the positive feedback folks, things were looking as if they might go belly up for a while there. Glad to hear things are as they should be, very much appreciated. smile.gif At some point I'd like reintroduce those 6 files I removed, but I'll be giving you all advance warning of this. To any beta testers wanting to help in this, that would be great.

 

I'll be sending the DXT1/DXT3 TXD's over to Aztlan over the course of the day, so we may have a surprise for you all at some point... you'll have to wait and see. wink.gif

 

Thanks all, Happy Holidays. xmas.gif

 

Share this post


Link to post
Share on other sites
Posty_2k3

Sorry about the menu set backs guys. I'm having a TINY bit of trouble right now. Oh well, I'm almost done fixing it. It's gotten better and better. Hopefully new update today or tomorrow.

Share this post


Link to post
Share on other sites
Demarest

@killer.ip: Do you know why you're such an important member? Not only because you do so much work, but you stand behind it! The amount of time you've put into testing alone is something most people would shun at. Good work!

 

@Aztlan: I would love to have your help in this mod. As Skidz said, it will be a daunting task and 2 heads are better than one. If you guys need any additional support, let us know what we can do.

 

Good news. I have to get some sleep and have an engagement tomorrow. After that, I don't have to work for about a week! Much progress to be made! Is ANYBODY going to work on converting the people from GTA3 over to VC? Or converting the GXT? I need these things before I can continue working on the code. If nobody else will, the GXT conversion will probably be my next project. I need it.

Share this post


Link to post
Share on other sites
killer.ip

/wipes a tear from his eye. smile.gif

 

Hehe, seriously though, the whole team is pitching in at a frightening pace. It was only yesterday that I had my first chance to compile together all the releases members have contributed so far. Not an easy task, they've been coming left, right & centre... and seeing as how I've been running the most basic install while developing I saw the difference between what we have now, and what we started with.

 

Very cool, very cool indeed. I won't elucidate further right now, but what I'm seeing is most definitely very cool. biggrin.gif

Share this post


Link to post
Share on other sites
JamesSHF

 

I somtimes have the same problem as Aztlan dose, but then it loads the texture. I think its just your going to fast the textures havent loaded yet so you still see the LODs, just give it some time and it should come up.Maybe 5 10 secs and they should pop up.

  Another proble I have too is around Luigi's club somtimes the textures of the buildings around it flicker.you see them and then there gone and then there back and it keeps going on and on.

I also get the same problem with my VC, even when using the original VC maps, the textures load like that, then a few seconds later, they get drawn properly.

I've installed new car models in my VC too, so maybe that's the problem.

 

edit: I put the original gta3.img back into my VC, and it still has the texture loading problem, so maybe it's a problem with VC and certain hardware, rather than something to do with LC.

Edited by JamesSHF

Share this post


Link to post
Share on other sites
Demarest

It's a horsepower thing. Which is why the 32 bit thing mentioned earlier is a serious issue. That and the fact that the GTA engines have a documented inability to handle many 32 bit textures at all.

Share this post


Link to post
Share on other sites
Lix

Yeah, I have a 2.1 Ghz so i don't have any loading problems colgate.gif

 

@Knux paths are working great!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 2 Users Currently Viewing
    0 members, 0 Anonymous, 2 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.