Quantcast

Jump to content

» «
Photo

When near a Crane it Disapears bug [iOS]

6 replies to this topic
yuvraj6122
  • yuvraj6122

    Thug

  • Members
  • Joined: 21 Feb 2018
  • India

#1

Posted 16 March 2018 - 03:28 PM

I saw this on my ios that the crane near doherty construction site,the easter basin docks one and the hunter quarry one are visible from a short distance but when i go close to it is disappears.whats the problem

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#2

Posted 09 April 2018 - 05:54 PM

Well... There is a mechanic for this glitch to work; the crane objects are one of the few "scm" (included in the save) objects that include low and high detail models. You should see the higher detail model as you approach. But I haven't heard of this type of issue before, and scm objects are generally quite stable across systems.

 

Please check the (movable) crane constructing a new casino in east LV. I'm assuming it also has issues, but not the static crane across from the hospital in western LS.

 

Do you get the same glitch on a new save? Do you get the same glitch from random saves downloaded from browsing SA Mobile saves on GTASnP? If the answer is No to either of these questions then please upload your save to SnP so I can see if I get the glitch on my device and look for clues in the save data.

 

If you get the same glitch on old, new, and downloaded saves then the problem is probably related to your data files. Reinstalling might help. I think iOS might have the same mechanic as Android that allows modified data files to be used in place of the uneditable standard data files if they are placed in the correct user folder - a subfolder located in the same places as the saved games, iirc. Reinstalling might not clear these files.


yuvraj6122
  • yuvraj6122

    Thug

  • Members
  • Joined: 21 Feb 2018
  • India

#3

Posted 10 April 2018 - 10:38 AM Edited by yuvraj6122, 10 April 2018 - 10:45 AM.

if u want to see it yourself just go to mission help forum>> mobile saves forums page and use the starter save uploaded on top,that starter save on which you also have a mention

 

 

no it happens only with that starter save,i have used it like 4 times to reach 100%


OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#4

Posted 10 April 2018 - 06:40 PM Edited by OrionSR, 11 April 2018 - 04:49 PM.

Ah, okay. This is starting to make sense. That's a v1.05 save. In the early save format there were some minor variations in how iOS and Android managed some flags and fields of objects. A version mismatch could very likely explain this glitch. Unfortunately, the save template that allows me to easily read and diagnose SA saves doesn't work on pre-1.06 mobile saves. I'll need something you've converted to a modern save format to continue the investigation.

 

Update: It looks like this glitch might be caused by converting a v1.05 Android save to something newer on iOS. I am unable to recreate the glitch with my Android device. I don't get the same glitch on the save you posted in the topic with mobile saves. I'm assuming this save was created on iOS.

 

If you want more information on the glitch you'll need to send me a save with the glitch active.


yuvraj6122
  • yuvraj6122

    Thug

  • Members
  • Joined: 21 Feb 2018
  • India

#5

Posted 14 April 2018 - 09:58 AM Edited by yuvraj6122, 14 April 2018 - 10:08 AM.

i did not convert anything but i have the saves on my google drive

 

along with this glitch,,,,i have another bug,the airport gates are invisible but still are solid and u can crash onto it with a bike


OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#6

Posted 14 April 2018 - 06:46 PM

Anything object related is basically the same glitch in another form. But if it's more than just the cranes then it's likely a lot of other stuff is broken too. It's hard to pick out the scm objects if you don't know what and where they are.

 

Your game converted the pre-1.06 Android save to iOS v1.07 when you loaded the save. It makes sense that this would scramble some of the flags. Others had reported "stealable" objects - liftable, like the burglary items. 

 

This is something I can't recreate on my Android device. If you load and save the starter save then I'll have my best chance of comparing the glitched save to something normal.

 

The easiest way to fix the starter save is to have someone with Android convert the save to v1.06+ by loading and saving right away.

 

One way to fix a pre-1.06 Android save that was converted using iOS would be to remove the glitchy objects and replace them with a cleo script that has the code originally used to place the objects. This would, of course, require an Android device with cleo installed.

 

I'm not sure what would be involved in a manual hex edit fix. I'll need to take a look at a glitchy save to see what's going on. I had high hopes of fixing the cranes but... Over 70 scm objects are added to a starter save by the intro scripts. That's a lot of manual repairs.


yuvraj6122
  • yuvraj6122

    Thug

  • Members
  • Joined: 21 Feb 2018
  • India

#7

Posted 17 April 2018 - 03:54 PM Edited by yuvraj6122, 17 April 2018 - 04:05 PM.

oh.....i have been using this starter save like 5 times

 

and most probably you are right,i used ios 1.07,it got automatically converted.fine fine now i got it

i will upload the glitchy save now

 

http://gtasnp.com/BBHTiH





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users