Quantcast

Jump to content

» «
Photo

no longer able to toggle joypad on in the settings

4 replies to this topic
diogenes085
  • diogenes085

    Player Hater

  • Members
  • Joined: 04 Jan 2018
  • United-States

#1

Posted 04 January 2018 - 06:26 PM Edited by diogenes085, 04 January 2018 - 06:33 PM.

Originally my steam controller was working perfectly with the game using Ginput (downgraded to 1.0). But later on was experiencing game freezes while entering buildings during a playthrough. Googled some fixes where one wanted me to delete the gta_sa.set in the documents folder. Tried that and lost most of my functionality on the controller (A button could open cars but the other buttons [x, y and b] did nothing). So decided on a clean install and removed any lingering folders before I reinstalled.

 

Controller issue still persists and now I no longer have an option to toggle joypad or mouse + keyboard in the settings.


Silent
  • Silent

    Chief Vision™ Alterer

  • GTA Mods Staff
  • Joined: 01 Feb 2010
  • Poland
  • Best Conversion 2017 Contribution [Liberty City Stories: PC]
    Most Helpful in Modding 2017
    Most Helpful [Modding] 2016
    Contribution Award [Mods]
    Best Script/Plugin 2014 [SilentPatch]
    Most Respected 2014
    Most Helpful [Mods] 2014
    Most Helpful [GTA] 2013
    Most Helpful [Mods] 2013
    Most Talented [Modding] 2013
    Best Map 2013 [ViceCityStories PC Edition]
    Best Vehicle 2013 [III Aircraft]
    Most Helpful [Mods] 2012
    Modder of the Year 2012

#2

Posted 04 January 2018 - 07:01 PM

That's intended - GInput removes this option from menus.

diogenes085
  • diogenes085

    Player Hater

  • Members
  • Joined: 04 Jan 2018
  • United-States

#3

Posted 05 January 2018 - 02:02 PM Edited by diogenes085, 05 January 2018 - 04:57 PM.

I went ahead and gave up on trying to get the Steam controller to work. Just went ahead and bought a PS4 controller to try with it. Managed to get GTA 3 and vice city to work with it, but not having any success with San Andreas.


lil weasel
  • lil weasel

    Shoot Looters, Hang Pirates!

  • GTA Series Staff
  • Joined: 25 Dec 2006
  • United-States
  • Contribution Award [San Andreas]

#4

Posted 06 January 2018 - 12:43 AM

There is a market for making Console Controllers work with the PC using Third Party Software.

However the GTA San Andreas was designed to use a PC Game Pad, the one I use is made by Logitech, I have also used Seitec, both without the need of any special drivers (even their own).

 

The problem with Console Controllers is the trigger do not send the proper signals, so they require a "translator" (Driver) to convert the signal to one that the PC understands.


diogenes085
  • diogenes085

    Player Hater

  • Members
  • Joined: 04 Jan 2018
  • United-States

#5

Posted 06 January 2018 - 07:01 PM

Got the PS4 controller working with the game now. Only have a couple weird issues of having the L1 & L2 buttons flipped (same for R1 & R2), also steam button tooltips for the popup button hints. But other than that its still very much playable.

 

Not sure what entirely I did to fix it though. Tried to just downgrade it to the 3.0 version with a basic setup (loader + silent patch) but the gta-sa.exe error just popped up during that method (no 2nd .exe in the folder btw). After that just kept trying with the 1.0 downgrader. And after that it was just repeated reinstalls, deletion of the .set file in a couple trial-and-error runs.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users