Quantcast

Jump to content

» «
Photo

FPS dropping only on GTA after update

5 replies to this topic
AN566
  • AN566

    Player Hater

  • Members
  • Joined: 23 Aug 2017
  • United-States

#1

Posted 3 weeks ago

Hello. I just recently got a new gaming laptop, and it used to be able to run GTA V on max settings at around 70-100 FPS. But, after I updated my windows yesterday to the creator's update (version 1709), it now runs at around 20-50 FPS. The only thing that has changed is the update. I've already tried disabling full screen optimization, turning off Game Bar and Game DVR, and I set the slider in the battery menu to "Plugged in: Best Performance", and none of these have solved the issue. How can I fix this?

I posted on the forum for my laptop brand and they said that this is a GTA-specific problem, because my other games still run fine.

 

Here are my specs:
Laptop model: Razer Blade Pro Full HD 2017

Processor: Intel i7 7700HQ

Graphics Card: Nvidia GeForce GTX 1060

RAM: 16GB DDR4

Storage: 256GB SSD + 2TB HDD

 


ACM-Jan
  • ACM-Jan

    Usually helpful, BUT very defensive upon disrespect

  • Members
  • Joined: 31 May 2014
  • Estonia

#2

Posted 3 weeks ago Edited by ACM-Jan, 3 weeks ago.

it's common problem with that windowes 10 version, try to downgrade and keep it on any older win versions, do not update.

if you can't keep it from updating make separate pc for internet using and install win 7 for gta 5 pc


_P136_
  • _P136_

    ★★★★★

  • Members
  • Joined: 3 weeks ago
  • None

#3

Posted 2 weeks ago

It could be because of other tasks running in the background: check with Task Manager (Ctrl-Shift-Esc) or Process Explorer then kill and/or switch them off with Autoruns; the latter two are part of the Sysinternals suite downloadable from here: https://docs.microso...internals-suite

 

It could also be the Windows Search indexing everything, which always happens on new installations and perhaps on updates as well, or some other service (press Win-R, then type mmc compmgmt.msc to see all running services).

 

It's difficult to be more specific but I don't think it has to do with any of the in-game settings.


ACM-Jan
  • ACM-Jan

    Usually helpful, BUT very defensive upon disrespect

  • Members
  • Joined: 31 May 2014
  • Estonia

#4

Posted 2 weeks ago Edited by ACM-Jan, 2 weeks ago.

ive looked into this by using shortly win 10 myself and there are unkillable windows tasks or hidden processes keeping the performance down but game mode settings can help it maybe, OP play with those settings little bit maybe you get solution


_P136_
  • _P136_

    ★★★★★

  • Members
  • Joined: 3 weeks ago
  • None

#5

Posted 2 weeks ago

A couple of other things to try:
  • Leave the computer on overnight, eventually all the background tasks should finish... unless in the meantime MICROS~1 pushes another update, of course.
  • Check Nvidia Control Panel (right-click on Desktop) and make sure the settings there are right. The GPU power management mode setting should be Optimal. Note that there could be different settings applied just to GTA.
  • Uninstall the driver (manually or using Display Driver Uninstaller), and reinstall it once again.
 

III-Ari-III
  • III-Ari-III

    Corporate Warlord

  • Members
  • Joined: 25 Sep 2016
  • Argentina

#6

Posted A week ago

Reinstall video drivers, that should fix it.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users