Quantcast

Jump to content

» «
Photo

GTA IV PC Issues

2 replies to this topic
saturatedfats
  • saturatedfats

    Player Hater

  • Members
  • Joined: 25 Mar 2015
  • None

#1

Posted 3 weeks ago

I just got a new computer with WIndows 10, and it's impossible to get GTA IV to run. It ran fine on my old PC with Windows 8.1, but now when I click play on the launcher it only gets to the very first text screen and freezes. It's the steam version by the way. Plus, when I go to the installers folder umdf.exe, wmfdist11.exe, and wmpappcompact.exe all say Not enough storage is available to process this command when I try to run them. I have 16 gb of ram and a terabyte ssd, why is this a problem? Has anyone had the same issues and fixed it?


whateven
  • whateven

    Player Hater

  • Members
  • Joined: 11 Mar 2017
  • European-Union

#2

Posted 3 weeks ago

I have the same issue, must be the recent Windows Update, because it ran well for me before.


saturatedfats
  • saturatedfats

    Player Hater

  • Members
  • Joined: 25 Mar 2015
  • None

#3

Posted 3 weeks ago

Well, I fixed it. First I deleted my whole GTA 4 installation again and used steam to reinstall a clean game. Then, I deleted the settings folder under Rockstar Games/GTA IV in my documents. Then I manually downgraded to 1.0.7.0, installed xlive.dll, and restarted my PC. Then I right clicked LaunchGTAIV.exe and ran as administrator, and the game launched successfully for the first time since I got this computer. The only problem was, it detected I had 120 mb vRAM instead of the correct 4 gb. So I made a commandline.txt and typed -availablevidmem 4000. The game for some reason translated 4000 to 1 gb, so I changed it to 8000 and now it says I have 2 gigs of vram, which is good enough. The game runs fine now.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users