Quantcast

Jump to content

» «
Photo

Help with custom ped creation

4 replies to this topic
PsychoTrevor
  • PsychoTrevor

    Player Hater

  • Members
  • Joined: 3 weeks ago
  • Germany

#1

Posted 3 weeks ago

Hello everyone. I am new to GTA5 modding scene and have some basic understanding of 3d modeling and rigging and have decided to start off by rigging a custom ped model and loading it in game using AddonPed mod. For my project, I used Leon from RE6 model by "fungfung879" (https://www.gta5-mod...-on-ped-replace) and facegen to create the custom 3d model's head. Using 3DS Max with GIMS EVO installed, I imported the 'ODD' file of another custom ped (i.e, leon-which loads fine in-game) extracted using OpenIV. The model loads without any errors. I attached the facegen head model in place of Leon's head. After embedding the textures, I exported the file to a folder which generated multiple mesh files and texture files in subfolders along with one main 'ODD' file. I wasn't sure if this was how it's supposed to happen as every other model I have seen had yft, ytd, ymt files. Not being sure how to proceed, I imported the files to OpenIV which converted the 'ODD' file to 'YDD' file which loaded fine along with the textures when viewed using OpenIV's built in model viewer. After adding the model entry to AddonPed Editor, I tried loading the model in game which didn't do anyting. No error messages, no nothing. After selecting the model fron the ped selector menu, pressing 'L' doesn't bring up pedselector menu anymore. I have no clue pertaining to this issue, thus this post. 
 
After spending hours pulling out my hair, I decided to rig the model using Zmodeler. Before long, I realized that I had fell into a rabbit hole. So, I have put a halt to my work and have decided to place my query in front of the modding community itself. Any kind of help is appreciated!
 
P.S. I read here (https://cain-x.devia...tudio-611194523) that Daz models can be imported into the game. So, I tried to export Daz3d models using GIMS (Daz3d>Export model>Import in 3DS Max>Export with GIMS) which could'nt find any object to export in the first place.
 
If anyone is willing to help me out or guide me in the right direction, you have my thanks :)

Mr.Arrow
  • Mr.Arrow

    God Save the Penis

  • Members
  • Joined: 08 Nov 2011
  • United-Kingdom

#2

Posted 3 weeks ago Edited by Mr.Arrow, 3 weeks ago.



Do you check your dlclist.xml? Make sure the game loads your ped model.

PsychoTrevor
  • PsychoTrevor

    Player Hater

  • Members
  • Joined: 3 weeks ago
  • Germany

#3

Posted 3 weeks ago

Do you check your dlclist.xml? Make sure the game loads your ped model.

Yes, I did. The AddonPed DLC pack is listed under the xml file. In fact, all the other ped models in the archive loads fine without any issues :facedesk:


Mr.Arrow
  • Mr.Arrow

    God Save the Penis

  • Members
  • Joined: 08 Nov 2011
  • United-Kingdom

#4

Posted 3 weeks ago

Instead of add-ons, why not replacing it? That might narrow down your problems.

PsychoTrevor
  • PsychoTrevor

    Player Hater

  • Members
  • Joined: 3 weeks ago
  • Germany

#5

Posted 3 weeks ago

Instead of add-ons, why not replacing it? That might narrow down your problems.

That's an excellent suggestion. I'll try and replace the generic models to see if it solves the problem.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users