Quantcast

Jump to content

» «
Photo

Better Skybox

SA WIP
95 replies to this topic
guru_guru
  • guru_guru

    pajaro culiao

  • Members
  • Joined: 22 Jul 2017
  • Chile

#91

Posted 4 weeks ago

After saving game with this mod then remove this mod and load the save game, the game did crash and I realized this mod actually didn't delete sky objects properly.
I didn't realized loading invalid models from save games crashes the game until then, though. So I uploaded a fixed version.
http://www.mediafire...kybox_2.0.2.zip
All I had to do to resolve this problem, was add this trick

function makeObjectUnsaveable(obj)
	local objPtr = getObjectPointer(obj)
	objPtr += 0x13C
	memory.write(objPtr, 6, 1)
end
This makes objects persistent but unsaveable.

Cool, I'll check it out when I get back home. Thanks!

VIOLATOR23
  • VIOLATOR23

    Player Hater

  • Members
  • Joined: 10 Dec 2017
  • Spain

#92

Posted 4 weeks ago

I'm getting this bug with Better Skybox:

 

Stars are showing in daylight.

 

19f6990f1589e916fea029789bc5832b.png


WeedSR
  • WeedSR

    Player Hater

  • Members
  • Joined: 09 Nov 2014
  • Albania

#93

Posted 4 weeks ago

 

 

 

As reported in comments, the object collision was not disabled... A guy said there is an "invisible wall" bellow the plane. (on SAMP, at least)
I recommend to disable the collision to each frame to force it.

 
that's weird.
but i don't feel like doing that just for this one dude.

I can confirm this bug too.

Only in SA-MP or also SP?

 

 

Only in SA-MP


EmperorTigris
  • EmperorTigris

    Programmer

  • Members
  • Joined: 4 weeks ago
  • England

#94

Posted 4 weeks ago

The clouds are not appearing for some reason.

 

What could it be?


guru_guru
  • guru_guru

    pajaro culiao

  • Members
  • Joined: 22 Jul 2017
  • Chile

#95

Posted 4 weeks ago

I'm getting this bug with Better Skybox:

 

Stars are showing in daylight.

 

I'm almost sure that is not caused by BS.

 

 

 

The clouds are not appearing for some reason.

 

What could it be?

 

 

Wrong installation of required mods most likely.


RifleExpert
  • RifleExpert

    Player Hater

  • Members
  • Joined: 29 Sep 2017
  • None

#96

Posted 2 weeks ago Edited by RifleExpert, 2 weeks ago.

nevermind issue still present

https://i.imgur.com/sZUn1Qm.png

 

This happen in the single play and SAMP, it come and go, and then stays longer then goes. I tried SilentPatch and Skygfx pass rendering still bug appears.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users