Quantcast

Jump to content

» «
Photo

[GTA SA] Help: My own Gun Sounds don't work!

7 replies to this topic
Two-Tu
  • Two-Tu

    Player Hater

  • Members
  • Joined: 16 Apr 2015
  • Germany

#1

Posted 06 August 2017 - 02:30 PM Edited by Two-Tu, 07 August 2017 - 05:15 PM.

[SOLVED: Solution below!]

 

Hello!
 

I today tried to create my own gun sound mods. I have some .wav files from CS:GO. I made sure that they have the same length as other already working and existing gun sound mods. However, my own gun sounds won't apply in game. The other mods do, though. I have no idea what is wrong with them.

 

My custom .wav files do have nearly the same properties as the other files.

 

Help!

 

EDIT: I am using the modloader.

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

EDIT: SOLUTION FOUND (For "Audacity 2.1.3" Users)

 

If you ever struggle to create your own gun sounds using "Audacity" as a tool to implement into your game, make sure to do following things:

 

1. Open your original sound file in "Audacity". Crop it as desired and do other stuff if you wish.

2. Now select the whole track (by pressing CTRL + A, for example)

3. While selected, click at "Tracks" at the upper bar

4. Select "Stereo Track to Mono" - now your two tracks will merge into one track (mono, you know)

5. Then export the file. For that, click at "File" in the upper left corner > select "Export Audio" > select following options:

 

File type: "Other uncompressed files"

Header: "WAV (Microsoft)"

Codec: "16-bit PCM"

 

Then click on "Save" to export the file to the location you chose.

6. Done! 


Mysterdogg
  • Mysterdogg

    Dig it!

  • Members
  • Joined: 09 Mar 2015
  • United-States

#2

Posted 06 August 2017 - 04:39 PM

Hello!
 

I today tried to create my own gun sound mods. I have some .wav files from CS:GO. I made sure that they have the same length as other already working and existing gun sound mods. However, my own gun sounds won't apply in game. The other mods do, though. I have no idea what is wrong with them.

 

My custom .wav files do have nearly the same properties as the other files.

 

Help!

 

Have you tried with Modloader? sounds modifications are really bugged due to game limitations.


Two-Tu
  • Two-Tu

    Player Hater

  • Members
  • Joined: 16 Apr 2015
  • Germany

#3

Posted 06 August 2017 - 04:59 PM Edited by Two-Tu, 06 August 2017 - 05:06 PM.

 

Hello!
 

I today tried to create my own gun sound mods. I have some .wav files from CS:GO. I made sure that they have the same length as other already working and existing gun sound mods. However, my own gun sounds won't apply in game. The other mods do, though. I have no idea what is wrong with them.

 

My custom .wav files do have nearly the same properties as the other files.

 

Help!

 

Have you tried with Modloader? sounds modifications are really bugged due to game limitations.

 

Yep, I am using the modloader. I put the new gun sounds together into the GENRL/Bank_137 folder. As I've said, the other gun sound mods I downloaded from GTA Inside and other sources work, but my "self-made" sounds don't.

 

How exactly do I create a working gun sound mode? I've made sure that it's a .wav file, has a fitting length and file size (they are not longer or bigger compared to the other sound files I have installed), has a similiar bit rate, and that it is replacing the exact desired weapon sound. During the process, I used Audacity to clip the sound files and converted them 1 or 2 times. 


The_Human
  • The_Human

    The Eye

  • Members
  • Joined: 31 Dec 2015
  • Mars

#4

Posted 07 August 2017 - 12:45 PM

Your audio file might be in a wrong format, if it so then ModLoader will ignore it.

 

Your audio file should be in mono PCM-16 format.

  • Two-Tu likes this

Two-Tu
  • Two-Tu

    Player Hater

  • Members
  • Joined: 16 Apr 2015
  • Germany

#5

Posted 07 August 2017 - 04:32 PM Edited by Two-Tu, 07 August 2017 - 04:53 PM.

Your audio file might be in a wrong format, if it so then ModLoader will ignore it.

 

Your audio file should be in mono PCM-16 format.

Well, I have made the sound using Audacity. The original sound files were .mp3 files. I then used Audacity to crop them and exported them with following options:

 

Uncompromized file

Header: WAV (Microsoft)

Codec: Signed 16 bit PCM

 

Is this alright?


The_Human
  • The_Human

    The Eye

  • Members
  • Joined: 31 Dec 2015
  • Mars

#6

Posted 07 August 2017 - 05:00 PM

 

Your audio file might be in a wrong format, if it so then ModLoader will ignore it.

 

Your audio file should be in mono PCM-16 format.

Well, I have made the sound using Audacity. The original sound files were .mp3 files. I then used Audacity to crop them and exported them with following options:

 

Uncompromized file

Header: WAV (Microsoft)

Codec: Signed 16 bit PCM

 

Is this alright?

 

Yes. It is correct.

 

Spoiler

Two-Tu
  • Two-Tu

    Player Hater

  • Members
  • Joined: 16 Apr 2015
  • Germany

#7

Posted 07 August 2017 - 05:06 PM Edited by Two-Tu, 07 August 2017 - 05:07 PM.

 

 

Your audio file might be in a wrong format, if it so then ModLoader will ignore it.

 

Your audio file should be in mono PCM-16 format.

Well, I have made the sound using Audacity. The original sound files were .mp3 files. I then used Audacity to crop them and exported them with following options:

 

Uncompromized file

Header: WAV (Microsoft)

Codec: Signed 16 bit PCM

 

Is this alright?

 

Yes. It is correct.

 

Spoiler

 

This did't work either.

 

HOWEVER: I found the solution. It was the "mono" thing that got me stuck.

 

Thanks alot! Really, thanks for this essential tip! 

 

(I'll edit the solution into the original post)


Mysterdogg
  • Mysterdogg

    Dig it!

  • Members
  • Joined: 09 Mar 2015
  • United-States

#8

Posted 07 August 2017 - 06:32 PM

 

 

 

Your audio file might be in a wrong format, if it so then ModLoader will ignore it.

 

Your audio file should be in mono PCM-16 format.

Well, I have made the sound using Audacity. The original sound files were .mp3 files. I then used Audacity to crop them and exported them with following options:

 

Uncompromized file

Header: WAV (Microsoft)

Codec: Signed 16 bit PCM

 

Is this alright?

 

Yes. It is correct.

 

Spoiler

 

This did't work either.

 

HOWEVER: I found the solution. It was the "mono" thing that got me stuck.

 

Thanks alot! Really, thanks for this essential tip! 

 

(I'll edit the solution into the original post)

 

 

I was about to say that, that error or mistake is more common than you think, I have given that answer a lot of times here. But just in case you didn't notice, The_Human told you about the mono format.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users