Quantcast

Jump to content

» «
Photo

Normals messing up on DFF export?

4 replies to this topic
Gmer
  • Gmer

    Player Hater

  • Members
  • Joined: 08 May 2017
  • Netherlands

#1

Posted 22 July 2017 - 12:18 AM Edited by Gmer, 22 July 2017 - 12:18 AM.

Hey, so often when I export a DFF with Kams scripts in 3DS Max, the normals mess up like in the below picture:

 

liOYeQB.png

 

Even when I select ''VCol'' and ''Normals'' to export it with. It happens the most at cracks and spaces like bodywork borders.. and most often or even exclusively on cars that are NOT GTA-style/athmosphere (so with custom looking material bodywork). But it happens even if I export with GTA_Mat as material for the chassis or whatever.. even trying to use 3DS ''Normals'' or ''Edit normals'' tools won't be able to correct it, only make it worse..

 

Also its already messed up if I didnt even change anyhting in 3DS, so only re-exporting it.

Does anyone know why and how to solve it?

 

if I edit those DFF's through other stuff like RWTools/RWConv it won't happen and normals get preserved. (although that basicly also re-exports it..)


Gmer
  • Gmer

    Player Hater

  • Members
  • Joined: 08 May 2017
  • Netherlands

#2

Posted 22 July 2017 - 05:58 AM

also I just noticed, tho really weird - that when I edited the model part where that white normals spot were on (by modifying vertexes/poly count or idk if it can be anything you change)

the bugged normals spots disappeared!

 

So as you can see in picture 1 the door is normals glitched, then I change the door frame and its solved. but I know for many cars it wont work like that.. so please

if anyone knows more and can also explain why editing door vertexes/anything can work too to correct it.


guard3
  • guard3

    Liberty City's Finest

  • Members
  • Joined: 21 Jul 2013
  • Greece

#3

Posted 22 July 2017 - 09:36 AM

Kam's export isn't very good with prelight and normals. I suggest you use these alongside with Kam's scripts
http://www.gtagarage...ow.php?id=19771
http://www.gtagarage...ow.php?id=18572
Great plugins, never had any problems. Hope you have 3ds Max 2010 or 2012 because they don't work with newer ones...
  • B_Smiles likes this

Gmer
  • Gmer

    Player Hater

  • Members
  • Joined: 08 May 2017
  • Netherlands

#4

Posted 4 weeks ago

After my latest comment I found out all problems like this can be easily solved, just edit the atomic a bit of the part that shows f*cked up normals/bright corners or parts like on my images.

I just need to change the vertexes/polys a bit, in any way, easy fix is using MultiRes to bring it below 93 or around 90% of original vertexes. Just because of this change in scene, it resolves itself and fixes.

 

I suspect that Kams doesnt correctly load normals, unless they are modified/updated by 3DS. That's ofcourse Kam's fault for forcing you to touch it, but until it really gets out of hand I will keep using Kams.. thanks for info though

Guard3!


guard3
  • guard3

    Liberty City's Finest

  • Members
  • Joined: 21 Jul 2013
  • Greece

#5

Posted 4 weeks ago

I'd still use other plugins. They only rely on Kam's for materials, so anything about geometry and/or prelighting/colours is up to the plugin itself. But if you know how to solve it without hassle, fine by me. Happy modding!





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users