Quantcast

Jump to content

» «
Photo

The correct scaling for Sketchup models.

No replies to this topic
csillam_faszlama
  • csillam_faszlama

    Little Willie owner

  • Members
  • Joined: 14 Dec 2014
  • Hungary

#1

Posted 01 June 2017 - 09:02 AM Edited by csillam_faszlama, 01 June 2017 - 09:45 AM.

    Have you ever read/heard somewhere, that models for old GTAs need to be scaled down badly? Or even the magic number, which is (roughly) 1/28? Now, I'm not going to say, that you were doing stuff absolutely wrong, cause I also used this scale - wich worked seemingly - until yesterday evening.
    It always annoyed me, that, when you export a .dff in .3ds format from 3ds Max, scale it, so it will be 28 times bigger, modify it, or use it as size comparison for some stuff, then scale it back to 1/28-th of the 'real size', put it in the game, and stuff you draw are bigger, then they should. For example, you draw a kitchen, and the cabinet was 0,8 meters high in sketchup, but in game it seems bigger; and CJ really can't be that short.
    But, he is short, cause - for example - if you import the model of the Flint County Safehouse:
Spoiler
It'll be small:
Spoiler
So, you scale it x28:
Spoiler
    As you see, the door is not 2 meters in height. Now, what I thought at the first time, and what you may think is: So what? Who cares this particular door, when there are door of every size in the game, from tiny to giant (go for a sightseeing in Vice city)? This door is important for comparison, because this is the mostly used size for doors, that can bee entered in San Andreas; and I don't think, you need pictures, about how big are they compared to CJ. So there must be something with the scaling.
    And that problem must be the cause of exporting from 3ds Max, then importing to Sketchup, because if you create something in Max, then you don't need to scale it down, if you used sizes taken from the real world in meters. The problem does not come from Sketchup, neither from them using meter scaling differently:
Spoiler
Saved as version 8 .skp, so Max 2012 can import it:
Spoiler
Sizes will be the same, as in Sketchup:
Spoiler
    So the problem should come from exporting the model from 3ds Max. So experiment with that...
I exported the model in two other format: .dae and .obj, from wich the second cannot be imported by Sketchup without a plugin (I used Fluidimporter Pro). See, what happens, when we import them to Sketchup:
Spoiler
The same model imported from .dae is much bigger, than the one imported from .3ds:
Spoiler
Compared to the scaled .3ds model:
Spoiler
Is this the good scale for the model?
Spoiler
Compared to the other two:
Spoiler
It is seemingly the same size, that of the .dae model. To be sure, check the door sizes:
Spoiler
    So CJ isn't really that short.
    I sad, two formats are enough to proove, that the problem is with 3ds. But what is the problem with it? The export options from Max. While you can set the unit type in the export panel for .dae, .obj and .3ds  export in model units. But then why only .3ds gets imported in a wrong scale?
 
    Solutions:
 
    1. In Sketchup, the import panel has an option, to set .3ds file units to meters, rather than model units, and then it will be imported correctly. Then, don't scale the model, but when importing to Max, let it convert units. (Which had to be unchecked, when using the 1/28 scale in Sketchup.)
    2. Use any other format, but don't forget to set units to the same, whenever exporting or importing. The import plugin (Fluidimporter Pro) was set to meters, so .obj got imported correctly because of that. After realising that, I imported the .3ds with it, and it also had the correct scale.
 
    What to do with models, that you started to draw according to the 1/28 scale?
 
    The height of that door, as you may see on the pictures is ~2,52 m and if scaled  x28 it's ~1,79, so the first size is 2,52/1,79 = 1,4078 times bigger then the second. This caused my 0,8 m high cabinet to be 1,1263 m high in game. So in Sketchup choose an edge, that is 1 m in length and use the Tape Measure Tool to set it's size to 252/179 m. After this resizing your model should be the real size.
 
    (The real scale: 1/(28*(2,52/1,79)) = 1/39,4190)
 
Correct me, if I'm wrong (which I hope I'm not) Hope it helps.
  • guard3 likes this




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users