Quantcast

Jump to content

» «
Photo

Gta V FPS issue.

3 replies to this topic
Lula.
  • Lula.

    Player Hater

  • Members
  • Joined: 15 May 2017
  • None

#1

Posted 15 May 2017 - 10:07 PM

Okay, so my PC is a little bit of a potato, I know, but I should be getting more frames than 20 I know of it. 

I used to use a GTX 750 ti 2gb and I'd get 40 fps, I changed over to a GTX 960 4gb and I'm getting 20.

 

You may think this is my graphs card manufacture's fault, but ever game runs better than it used to, GTA is the only one that took an fps hit. 

 

If there are any drivers I need, please send them to me as I've had this issue for many months and it caused me to stop playing.

 

My specs:

 

Processor: AMD A8-6600K APU w/ Radeon HD Graphics (Speed: 3.9 GHz) (Cores: 4)

 

Video Card: NVIDIA GeForce GTX 960 (Dedicated Memory: 2gb) (Total Memory: 4gb) (Pixel & Vertex Shader version: 5.1)

 

OS: Windows 8.1 (64-bit)

 

I normally run GTA with razer cortex, I have the option for razer to show it's FPS for the game and also steams FPS count at the same time, razer says I'm getting around 60 - 100 FPS which I expected for this type of graphics card, but I'm getting 20 - 30. Sometimes even 9. 

 

http://prntscr.com/f88yau

 

 

http://prntscr.com/f88yz0

 

If anyone could help, much will be appreciated

 

 


ZANTHERA
  • ZANTHERA

    The colors man... all the colors...

  • Members
  • Joined: 15 Mar 2014
  • United-Kingdom
  • Contribution Award [GTA Online]

#2

Posted 15 May 2017 - 10:11 PM

I'm no expert on this but I have an issue where my fps stays at 30 in game then when I alt tab out of the game and back in the fps goes back to normal, I have to do this every time and I have a 970 with an older i5 3470.

 

Probably won't work at all but that's the only help I could possibly offer.


Lula.
  • Lula.

    Player Hater

  • Members
  • Joined: 15 May 2017
  • None

#3

Posted 15 May 2017 - 10:42 PM Edited by Lula., 15 May 2017 - 10:44 PM.

I'm no expert on this but I have an issue where my fps stays at 30 in game then when I alt tab out of the game and back in the fps goes back to normal, I have to do this every time and I have a 970 with an older i5 3470.

 

Probably won't work at all but that's the only help I could possibly offer.

Nope. This hasn't worked... I really don't know what's causing it, as I get great frames in other games, such as Rust, ArmA 3, SaintsRow, Black Ops 3, etc.

And yeah, I have tried reinstalling the game, in fact, I've just installed it today after it being uninstalled for like a year.

 

But every little helps.


I'd like to also add, I thought it had something to do with my processor, but here's a video with someone using the same one as I have, and same graphics card.

 

 

I know it's running at 40 - 50 fps, which I can play with, but my GTA runs at 20 - 30, and every couple of secs it freezes for like a half a sec..


EvoBeardy
  • EvoBeardy

    Player Hater

  • Members
  • Joined: 10 Jul 2016
  • United-Kingdom

#4

Posted 19 May 2017 - 06:28 PM Edited by EvoBeardy, 19 May 2017 - 06:30 PM.

Okay, so my PC is a little bit of a potato, I know, but I should be getting more frames than 20 I know of it. 

I used to use a GTX 750 ti 2gb and I'd get 40 fps, I changed over to a GTX 960 4gb and I'm getting 20.

 

If there are any drivers I need, please send them to me as I've had this issue for many months and it caused me to stop playing.

 

My specs:

 

Processor: AMD A8-6600K APU w/ Radeon HD Graphics (Speed: 3.9 GHz) (Cores: 4)

 

Video Card: NVIDIA GeForce GTX 960 (Dedicated Memory: 2gb) (Total Memory: 4gb) (Pixel & Vertex Shader version: 5.1)

 

OS: Windows 8.1 (64-bit)

 

I normally run GTA with razer cortex, I have the option for razer to show it's FPS for the game and also steams FPS count at the same time, razer says I'm getting around 60 - 100 FPS which I expected for this type of graphics card, but I'm getting 20 - 30. Sometimes even 9.

Firstly your resolution is awfully low, is that the native resolution of your monitor? Not 1280x1024 at least? (even if relatively old/basic). At that resolution, you'll be leaning on the CPU more, even if "lower resolution=(typically)higher framerates" and not making the most of your GPUs power.

[EDIT: Just noticed you're running in Windowed mode? Any particular reason for this?]

 

Secondly what nVidia drivers are you running (You can download and run GPU-Z and see the driver version, or start up GeForce Experience if installed and see that way), you may be using the Windows Update version of the driver or have multiple driver conflicts. I highly suggest downloading directly from nVidia, selecting Custom Install, and ensuring the "Clean Installation" is checked.

 

Once you've got the Driver out of the way and if the issue still persists, go into nVidia Control Panel>Manage 3D Settings and under the Program Settings tab, select GTAV from the drop-down, or add it. Scroll down to Power Management Mode and set it to Prefer Maximum Performance, apply and close.

 

I'd also like to ask about your PSU model and whether you ensured the 960 (and even the 750Ti) both had their necessary PCI-E power leads?

 

Have you tried playing it without Cortex running, to see if it's an issue with that and GTA? Are you recoding/streaming at the time? Traditionally, when people used to record gameplay footage, we'd unknowingly record to the same HDD we ran our games off, the read/writes put a strain on the HDD and you'd end up with significantly lower visible framerates, then people started recording off the main drive (onto a separate HDD) and then faster drives came out and then SSDs.

The fact you're freezing also possibly points to some sort of driver/hardware issue or something, as you'll most likely see drops/spikes in GPU/CPU frequency at the times you experience freezing, stick GPU-Z on the SEnsors tab in the background and/or if you've not download it already, get yourself MSI AfterBurner and check out the Hawdware Monitor graphs on the right, scroll down to Core Clock (not far down) and leave that there while you run GTA, when you freze/stutter, alt-tab out after a few seconds and check the graph and see if the Core Clock dived, and what to, keeping track of your CPU details would also be handy, I usually use HWInfo but I have multi monitors, so maybe something with an overlay like Rivatuner Statitiscs or something will show you a better result. There was another program but I forgot what it's called.

 

I'm no expert on this but I have an issue where my fps stays at 30 in game then when I alt tab out of the game and back in the fps goes back to normal, I have to do this every time and I have a 970 with an older i5 3470.

 

Probably won't work at all but that's the only help I could possibly offer.

 

Have you tried rolling back to older nVidia Drivers or even newer ones? Again, follow the Clean Installation route or if that doesn't help, try running DDU in Safe Mode and install nVidia Drivers from scratch.

 

Firstly though, check all VSync options in-game and within the nVidia Control Panel, ensure nVidia CP is either set to Adaptive or Off, and turn it off in the game itself, do the same thing I suggested above and set GTAV to Prefer Maximum Performance under Power Management in Control Panel> Manage 3D Settings, but it sounds more like a VSync/Driver issue.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users