Quantcast

Jump to content

» «
Photo

How do you deal with large amount of cols?

4 replies to this topic
Le Shark
  • Le Shark

    Proud Alderney resident

  • Members
  • Joined: 03 Jan 2016
  • Russia

#1

Posted 10 May 2017 - 08:18 PM

I'm currently working on a small project, and I'm importing building models to the game. I have a problem with .col files. Currently I am using fastman92's limit adjuster, and I have a separate .img file where I keep .dff's, .txd's and a single .col file for all the collisions. The problem is that after a certain (very small) amount of collisions added to this .col, the game won't launch, as if I exceeded the limit, which I don't do because I only add 1 .col. Of course, I tried adjusting the limits, but it didn't work. So, I have a question: how do you deal with that large amount of cols? How to add collisions properly?


eagle152
  • eagle152

    Visits Glory Hole Theme Park every day

  • Members
  • Joined: 18 Sep 2014
  • Antarctica

#2

Posted 11 May 2017 - 07:54 AM

There are multiple collision limits - one of them is .COL file limit. Another is total collision model amount (~10000) models totally inside all .COL files. Also there's .COL file size limit, but it is quite big.

Le Shark
  • Le Shark

    Proud Alderney resident

  • Members
  • Joined: 03 Jan 2016
  • Russia

#3

Posted 11 May 2017 - 10:46 AM

There are multiple collision limits - one of them is .COL file limit. Another is total collision model amount (~10000) models totally inside all .COL files. Also there's .COL file size limit, but it is quite big.


But I'm pretty sure I'm not exceeding any of them, and even if I do, I still got them adjusted

dkluin
  • dkluin

    GTA:Underground Developer

  • Members
  • Joined: 11 Jun 2013
  • Netherlands
  • Best Conversion 2016 [GTA: Underground]

#4

Posted 11 May 2017 - 03:23 PM

Did you increase the COL file buffer size? It might overflow when reading large COL files. However, latest public FLA has this feature in a broken state (I spoke with fastman92 about it to have it fixed and I'm pretty sure he will fix it in a new FLA release).


Le Shark
  • Le Shark

    Proud Alderney resident

  • Members
  • Joined: 03 Jan 2016
  • Russia

#5

Posted 11 May 2017 - 05:17 PM

Did you increase the COL file buffer size? It might overflow when reading large COL files. However, latest public FLA has this feature in a broken state (I spoke with fastman92 about it to have it fixed and I'm pretty sure he will fix it in a new FLA release).

If you mean the "Max size of single collision from .col archive" parameter, then I tried with both changed and unchanged value. Heck, I even tried disabling FLA, but it still didn't help..





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users