Quantcast

Jump to content

» «
Photo

GTA IV Lag

6 replies to this topic
StormBreaker
  • StormBreaker

    Rockstar Hater

  • Members
  • Joined: 17 Dec 2016
  • India

#1

Posted 28 March 2017 - 12:58 PM

Using version 1.0.7.0, game lags like hell. Can't complete even first mission. Worked fine earlier, just reinstalled due to some mods and poof. Any help?

HalfOfAKebab
  • HalfOfAKebab

    Help & Support

  • Members
  • Joined: 01 Aug 2015
  • United-Kingdom
  • Helpfulness Award [GTAO]

#2

Posted 28 March 2017 - 01:56 PM

All video settings that use a slider (e.g. view distance) greatly affect CPU performance. GTAIV is a notoriously badly optimised game. Turn down the sliders to the minimum and you should be able to play.


StormBreaker
  • StormBreaker

    Rockstar Hater

  • Members
  • Joined: 17 Dec 2016
  • India

#3

Posted 29 March 2017 - 02:25 AM

I'll try that, but i dunno why it's happening all of a sudden. It used to work fine before

The American Army 1775
  • The American Army 1775

    Joseph Stalin

  • Members
  • Joined: 12 May 2016
  • United-States

#4

Posted 29 March 2017 - 05:17 AM

Lower the shadow level in graphics settings.

StormBreaker
  • StormBreaker

    Rockstar Hater

  • Members
  • Joined: 17 Dec 2016
  • India

#5

Posted 31 March 2017 - 03:24 PM Edited by StormBreaker, 31 March 2017 - 03:25 PM.

Nope, the shadow level, the sliders, none of them worked. I think I found the problem. Every time i start my pc, i get a message saying the system fan us not working properly. Need to fix that. Either that, or the sh*tty earphones i have which makes everything lag, wherever i put it, my phone or pc.

The American Army 1775
  • The American Army 1775

    Joseph Stalin

  • Members
  • Joined: 12 May 2016
  • United-States

#6

Posted 01 April 2017 - 12:50 PM

Or just buy a cooling pad.
gta IV makes laptops too hot. You just have to keep the PC cool.

StormBreaker
  • StormBreaker

    Rockstar Hater

  • Members
  • Joined: 17 Dec 2016
  • India

#7

Posted 10 April 2017 - 03:20 PM

I got the solution. Apparently, the graphics card was overheating




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users