Quantcast

Jump to content

» «
Photo

Downloaded GTA IV, won't start.

4 replies to this topic
bmxkid624
  • bmxkid624

    Player Hater

  • Members
  • Joined: 14 Mar 2015
  • United-States

#1

Posted 13 March 2017 - 09:37 PM

I've owned GTA IV on steam for about two years now, but my old PC got about 20FPS so I never played, I recently got a new PC. I've installed everything but the game won't start. I get the rockstar social club thing, tried linking my account and clicked play, but after that nothing happens. Is there something else I need to install? My PC specs: AMD FX4350 (overclocked currently to 4.5ghz, XFX R7 240 GPU, XFX TS550W PSU, 16GB DDR3 RAM, I have Windows 7 on a 80GB HDD currently (Don't laugh) And, GTA IV along with a few other games are installed on a 360GB HDD. All other games work, but GTA IV, so there must be something I'm doing wrong. 


HalfOfAKebab
  • HalfOfAKebab

    Help & Support

  • Members
  • Joined: 01 Aug 2015
  • United-Kingdom
  • Helpfulness Award [GTAO]

#2

Posted 13 March 2017 - 10:38 PM

Completely uninstall Games for Windows Live (GFWL) and then reinstall it. That should do the trick.


bmxkid624
  • bmxkid624

    Player Hater

  • Members
  • Joined: 14 Mar 2015
  • United-States

#3

Posted 14 March 2017 - 12:54 AM Edited by bmxkid624, 14 March 2017 - 12:55 AM.

I downloaded Windows live GFWL, installed it, uninstalled and reinstalled GTA IV, and this time after the social club screen, it just says "GTA IV FATAL ERROR: WTV270, as soon as I click ok on the error message, GTA just force closes. 


The American Army 1775
  • The American Army 1775

    The Protectors

  • Members
  • Joined: 12 May 2016
  • United-States

#4

Posted 15 March 2017 - 09:45 AM

Update to Patch 1.0.8.0.
  • UltraZ likes this

bmxkid624
  • bmxkid624

    Player Hater

  • Members
  • Joined: 14 Mar 2015
  • United-States

#5

Posted 15 March 2017 - 09:17 PM

I downloaded the patch from https://www.gtaall.c...gta-4-1080.html as the patch is installing it starts the process to uninstall the Rockstar Social Club, which it then comes up with an error stating "The setup has detected no version of rockstar games social club is installed. the specified command-line options require that the application be installed to continue. The setup will now terminate." 

But, I do in fact have social club installed because every time I try starting GTA IV the social club screen is as far as I get before it gets an error and fails to launch.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users