Quantcast

Jump to content

» «
Photo

Car Repair Mod Bug?

2 replies to this topic
Martovvi
  • Martovvi

    Player Hater

  • New Members
  • Joined: 2 weeks ago
  • Germany

#1

Posted 2 weeks ago Edited by Martovvi, 2 weeks ago.

I've downloaded the "Instantly Repair Vehicle" mod from Rocker453 and for some reason when I use it in missions stuff like "Ryder's car has been destroyed" happens whilst the car completely disappears without a trace.

 

Is there a way to fix the mod so it doesn't do that anymore?

 

It repairs the car as normal but for some odd reason it glitches while doing it in missions.

 

Here is the .cs code:

// This file was decompiled using SASCM.ini published by GTAG (http://gtag.gtagaming.com/opcode-database) on 14.6.2013
{$CLEO .cs}

//-------------MAIN---------------
thread 'REPAIR' 

:REPAIR_11
wait 100 
if 
   Player.Defined($PLAYER_CHAR)
else_jump @REPAIR_38 
jump @REPAIR_45 

:REPAIR_38
jump @REPAIR_11 

:REPAIR_45
wait 0 
if and
   Actor.Driving($PLAYER_ACTOR)
0AB0:   key_pressed 49 
else_jump @REPAIR_108 
1@ = Actor.CurrentCar($PLAYER_ACTOR)
0A30: repair_car 1@ 
Car.RemoveReferences(1@)
wait 200 

:REPAIR_108
jump @REPAIR_45 


Richie Makyura
  • Richie Makyura

    Most Wanted Criminal :v

  • Members
  • Joined: 2 weeks ago
  • Mexico

#2

Posted 2 weeks ago

Try to make the mission without the mod, and see what happens. I Not sure if you can use mods in story missions (sometimes crashes my game like GTA3 % GTA VC)


ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#3

Posted A week ago

remove this code:

Car.RemoveReferences(1@)




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users