Quantcast

Jump to content

» «
Photo

GTA IV and EFLC won`t launch after newest patch (Steam version)

3 replies to this topic
Fantoka
  • Fantoka

    Player Hater

  • Members
  • Joined: 08 Dec 2016
  • Germany

#1

Posted 08 December 2016 - 02:14 PM Edited by Fantoka, 13 February 2017 - 12:10 AM.

Hello,
 
After the newest update to GTA IV I can't play GTA IV or EFlC. When I press start in Steam, the social club window appears, where you can click on connect Gamertag. I made sure my social club and GFLW account were connected (they were because earlier I could play both Games, and there I had to connect them) and pressed start game, but now nothing happens. The Social Club window closes itself and nothing happens. In Steam, it only says play, when I click on GTA IV. Sometimes it shows running, beside the Games name in the Steam list, after the social club window has closed itself, but it disappears after some time. Most of the time it only says running, until I click play game in the social club window. The same thing happens in GTA IV and EFLC. Also, at times a Windows error appears, after I clicked play game in the social club window, saying GTA IV stopped working and searching for a solution, but it closes itself after around 10 seconds and then nothing happens anymore.
What I already tried:
 
- uninstall and re install Games for Windows Live (trying it with and without GFWL)
 
- verifying game files in Steam
 
- completely re install both games
 
- I installed the patches found here: https://support.rock...icles/235721567
 
- restarting my computer
 
Before the update I also had problems with GTA IV, because the login to social club only worked sometimes.
 
I hope someone can help me with this issue. Thanks in advance,
 
Fantoka
 
Edit: Both games are working now. Explanation in the comments.

FulValBot
  • FulValBot

    Punk-ass Bitch

  • Members
  • Joined: 09 Mar 2007
  • Italy

#2

Posted 08 December 2016 - 11:50 PM

steam version was already updated, that link is not need... don't install that update, is for retail version only

 

 

remember to remove all commands (remove also commandline.txt file)


damian001
  • damian001

    Vice City fanboy

  • Members
  • Joined: 19 Oct 2003
  • None

#3

Posted 11 December 2016 - 08:04 AM Edited by damian001, 11 December 2016 - 08:08 AM.

What OS are you using OP? Windows 10? I had the same problem with Windows 10 until I downloaded "Games for Windows Marketplace"

 

http://www.xbox.com/.../DownloadClient

 

I guess the game can't authenticate because "Games for Windows LIVE" is dead, and now now been replaced by "Games for Windows Marketplace"

 

more info:

 

https://steamcommuni...456486983108166


Fantoka
  • Fantoka

    Player Hater

  • Members
  • Joined: 08 Dec 2016
  • Germany

#4

Posted 13 February 2017 - 12:07 AM Edited by Fantoka, 13 February 2017 - 12:10 AM.

I don't know why exactly, but today I re installed GTA IV and EFLC, just like I did 2 months ago and now both games are working, with no problems. Not even Games for Windows Live or the Social Club had a problem.

 

So here is what I did: I tried running it in Admin mode, and when the games crashed again, I deleted them via Steam and installed them via Steam and that's it.

 

So I guess my problem is solved, although I don't know exactly why.

But anyway thanks to all the ones who where trying to help me.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users