Quantcast

Jump to content

» «
Photo

GTA2 Windows 10 "Fix"

7 replies to this topic
----------------------
  • ----------------------

    Man With No Name

  • BUSTED!
  • Joined: 25 Oct 2013
  • None

#1

Posted 16 November 2016 - 10:26 AM Edited by ----------------------, 19 November 2016 - 01:19 AM.

Ok, using Toshiba-3's awesome guide/mod here as a base, I think I've found a legit crash-free fix for GTA 2 on modern Windows (in my case 10). Before hand, the game would freeze every 3 mins or so, forcing me to log out and log back in of my computer. After applying this method, no crashes so far. No guarantees it will work for anyone else, but I don't see why not:

 

1. First you need to install GTA 2 11.44. I don't know if I can link to it, but it shouldn't be hard to find.

2. Install Nglide. You can grab it from here.

3. Launch Nglide Configurator and adjust the settings so they match these, then apply, save and exit the program:
Screen resolution: By desktop
Aspect ratio: Preserve original
Refresh rate: By app (Default)
Vertical sync'
: On (Default)
Gamma correction: 0.8
3Dfx logo splash: Off

4. Go the GTA2 install directory and launch the GTA2Manager executable.

5. Go the video tab, and change the Screen Mode drop-down option from "Direct3D" to "3DFXGlide". While you're here, make sure Frame Rate Limiter is ticked.

6. Don't bother selecting a resolution, just click the GTA2 button and the game should load.

 

I've played for a few hours and no crashes at all, yet before it would hard freeze every 3 mins or so.  Again, just a tip to try. It might actually work for someone else, besides me.

 

Full credit to Toshiba-3 as well as all the other talented people in the community.

 

EDIT: Also massive thanks and credits to Sektor and Vike for patching the game for all these years. You're both top blokes. Cheers! 

  • Sektor likes this

FulValBot
  • FulValBot

    Snitch

  • Members
  • Joined: 09 Mar 2007
  • Italy

#2

Posted 28 February 2017 - 10:09 AM

I'm playing gta2 without problems on my windows 10 anniversary update... and i have installed only gta2 from steam client, just this...

 

There are some slowdowns (and minor speed) with amd cpus... (all gpus nvidia and amd works just fine)


TomRous
  • TomRous

    Player Hater

  • Members
  • Joined: 14 Feb 2017
  • Czech-Republic

#3

Posted 28 February 2017 - 05:17 PM

I'm playing gta2 without problems on my windows 10 anniversary update... and i have installed only gta2 from steam client, just this...

 

There are some slowdowns (and minor speed) with amd cpus... (all gpus nvidia and amd works just fine)

I looked for GTA 2 on Steam but i couldn´t find DOWNLOAD button. It is downloadable? I looked on R* web too (www.rockstargames.com/classics/) but this web is unavaiable. How to get it on Steam?


FulValBot
  • FulValBot

    Snitch

  • Members
  • Joined: 09 Mar 2007
  • Italy

#4

Posted 28 February 2017 - 11:46 PM

it's not a free version, it was included with GTA Complete Pack (that still available on GMG, and include a steam key, but not for GTAV)


SSRenz
  • SSRenz

    LCPD Crime Record Officer

  • Members
  • Joined: 30 Jul 2016
  • None

#5

Posted 01 March 2017 - 10:42 AM

Ok, using Toshiba-3's awesome guide/mod here as a base, I think I've found a legit crash-free fix for GTA 2 on modern Windows (in my case 10). Before hand, the game would freeze every 3 mins or so, forcing me to log out and log back in of my computer. After applying this method, no crashes so far. No guarantees it will work for anyone else, but I don't see why not:

 

1. First you need to install GTA 2 11.44. I don't know if I can link to it, but it shouldn't be hard to find.

2. Install Nglide. You can grab it from here.

3. Launch Nglide Configurator and adjust the settings so they match these, then apply, save and exit the program:
Screen resolution: By desktop
Aspect ratio: Preserve original
Refresh rate: By app (Default)
Vertical sync'
: On (Default)
Gamma correction: 0.8
3Dfx logo splash: Off

4. Go the GTA2 install directory and launch the GTA2Manager executable.

5. Go the video tab, and change the Screen Mode drop-down option from "Direct3D" to "3DFXGlide". While you're here, make sure Frame Rate Limiter is ticked.

6. Don't bother selecting a resolution, just click the GTA2 button and the game should load.

 

I've played for a few hours and no crashes at all, yet before it would hard freeze every 3 mins or so.  Again, just a tip to try. It might actually work for someone else, besides me.

 

Full credit to Toshiba-3 as well as all the other talented people in the community.

 

EDIT: Also massive thanks and credits to Sektor and Vike for patching the game for all these years. You're both top blokes. Cheers! 

Use widescreen fix by ThirteenAG but you must have a downgrade from v.11.44 to v.9.6.0.0 if you have a 1920x1080 Resolution Here: https://thirteenag.github.io/wfp

Download File and Extract them and play the game

  • NoNameBandit likes this

Sektor
  • Sektor

    GTAMP.com

  • GTA Series Staff
  • Joined: 28 Jan 2003
  • None

#6

Posted 01 March 2017 - 10:47 AM Edited by Sektor, 03 March 2017 - 02:44 AM.

That widescreen patch cuts off text, talking heads and offsets the arrows, until someone fixes that, 4:3 (non widescreen) is better for playability.

 

Pretty sure Steam version has the same compatibility as classics version or 11.44, so if those don't work for you then Steam version won't work either.  I don't have the Steam version so I can't confirm that but I doubt Rockstar fixed it in any way.

  • NoNameBandit likes this

FulValBot
  • FulValBot

    Snitch

  • Members
  • Joined: 09 Mar 2007
  • Italy

#7

Posted 01 March 2017 - 09:21 PM

steam version and rockstar free version are the same version... only retail version is different


NoNameBandit
  • NoNameBandit

    The Legend

  • Members
  • Joined: 18 Dec 2016
  • None
  • Ban Roulette Winner 2016

#8

Posted 03 March 2017 - 02:35 AM Edited by NoNameBandit, 03 March 2017 - 02:36 AM.

That widescreen patch cuts off text, talking heads and offsets the arrows, until someone fixes that, 4:3 is better for playability.

 

Pretty sure Steam version has the same compatibility as classics version or 11.44, so if those don't work for you then Steam version won't work either.  I don't have the Steam version so I can't confirm that but I doubt Rockstar fixed it in any way.

 

I have the game on CD, but it ran like poop on W10 for me. I needed 11.44 just to get the game to start.

 

To the guy who suggested the widescreen patch, thanks (I'm the OP btw), but downgrading is not viable for me.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users