Quantcast

Jump to content

» «
Photo

ASI manager problem

Best Answer joelafrite, 01 November 2016 - 09:57 PM

So I resolved the issue. Turns out it was a conflict with the windows ten anniversary update and the latest nvdia drivers. So I rollbacked to an older version of the drivers and now openIV works fine. Thanks for the help and your time. Great software !

Go to the full post


10 replies to this topic
joelafrite
  • joelafrite

    Player Hater

  • Members
  • Joined: 29 Oct 2016
  • None

#1

Posted 29 October 2016 - 03:30 PM

Hello,

I have a problem with asi manager in openIV. Whenever I try to launch it in order to install the loader, i get the error : "CreateDevice() - Failed" ; followed by ": CFramework Initialize faild".

I'm guessing the asi loader is just a dll to put inside the gta folder, so if anyone could send me the files for the loader, openIV.asi, and opencamera, I could install them manualy therefore bypassing the bugged manager.

Any help would be much apreciated.


GooD-NTS
  • GooD-NTS

    OpenIV Lives

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#2

Posted 29 October 2016 - 04:20 PM

Well, this is very strange. This error means OpenIV was unable to initialize DirectX by some reason.
Anyway, you can find files in OpenIV folder here:
C:\Users\[UserName]\AppData\Local\New Technology Studio\Apps\OpenIV\Games\Five\x64\

joelafrite
  • joelafrite

    Player Hater

  • Members
  • Joined: 29 Oct 2016
  • None

#3

Posted 30 October 2016 - 11:26 AM

Thank you GooD-NTS, it works really well.

If you don't mind me asking, why does the manager need to access directx just to copy a few files ?

 

Thanks again for the quick answer ! cheers !


GooD-NTS
  • GooD-NTS

    OpenIV Lives

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#4

Posted 30 October 2016 - 12:32 PM

If you don't mind me asking, why does the manager need to access directx just to copy a few files ?

The user interface of ASI Manager uses DirectX.

joelafrite
  • joelafrite

    Player Hater

  • Members
  • Joined: 29 Oct 2016
  • None

#5

Posted 30 October 2016 - 09:46 PM

I have the same problem with the package installer. Unfortunately some mods only come in .oiv package. Is there a way to extract them in order to install them manually ?


GooD-NTS
  • GooD-NTS

    OpenIV Lives

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#6

Posted 31 October 2016 - 07:53 AM

You can extract OIV easily just rename it to .zip

But, I think we need to know why you have this issues with DirectX because without it you are not able to use OpenIV properly.
Can you please provide information about your system? Windows version, video card vendor, video card driver version etc...

joelafrite
  • joelafrite

    Player Hater

  • Members
  • Joined: 29 Oct 2016
  • None

#7

Posted 31 October 2016 - 06:02 PM Edited by joelafrite, 31 October 2016 - 06:04 PM.

Thanks. Yes I wish I could use openIV normally cause it's a bit tedious to install mods manually. I think my directx problem comes from sandboxie so there's not much I can do about it. Some games like gta work with it, and others (and openIV) don't, I'm not sure why. Maybe I need to reinstall the whole thing.


GooD-NTS
  • GooD-NTS

    OpenIV Lives

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#8

Posted 31 October 2016 - 08:46 PM

Any particular reason why you need run in under sandboxie?
And btw I have install sandboxie on my virtual machine and OpenIV is works fine under it.

joelafrite
  • joelafrite

    Player Hater

  • Members
  • Joined: 29 Oct 2016
  • None

#9

Posted 01 November 2016 - 09:14 AM

Well it's just a security mesure, I install everything under sandboxie. And yeah I think I f*cked something up, I'll try to reinstall it.


joelafrite
  • joelafrite

    Player Hater

  • Members
  • Joined: 29 Oct 2016
  • None

#10

Posted 01 November 2016 - 09:57 PM   Best Answer

So I resolved the issue. Turns out it was a conflict with the windows ten anniversary update and the latest nvdia drivers. So I rollbacked to an older version of the drivers and now openIV works fine. Thanks for the help and your time. Great software !


JU3X REMIX
  • JU3X REMIX

    Player Hater

  • New Members
  • Joined: 10 Jul 2017
  • United-States

#11

Posted 10 July 2017 - 08:15 PM

Well, this is very strange. This error means OpenIV was unable to initialize DirectX by some reason.
Anyway, you can find files in OpenIV folder here:
C:\Users\[UserName]\AppData\Local\New Technology Studio\Apps\OpenIV\Games\Five\x64\i po

I'm having the same problem  as  him and I put the path to the files in on my computer and they didn't show up





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users