Quantcast

Jump to content

» «
Photo

GTA IV doesn't seems to recognize GTX960M

4 replies to this topic
prince_linus
  • prince_linus

    Player Hater

  • Members
  • Joined: 15 Mar 2016
  • Germany

#1

Posted 31 July 2016 - 12:23 AM

Hi there, 

finally, I've bought a new Notebook :) 

it's a Lenovo Ideapad Y700 - i7 + GTX960M 

 

However, this is the problem: 

GTA IV doesn't seems to recognize the video card, the game always seems not to use the GTX;

looks like the game starts with that intel graphics chip only. 

I already created a commandline and wrote availablevidmem and similar stuff into it; 

also told the game to use the GTX by using the nVidia control panel.

Nothing helped.

 

I'm using the Steam version;

BTW; this happens with EFLC as well

 

Thanks :)


Red Hat
  • Red Hat

    its moi

  • Daily Globe
  • Joined: 16 Nov 2012
  • None
  • Helpfulness Award GTA IV

#2

Posted 31 July 2016 - 10:54 AM

First make sure your GTX960M drivers are up to date.
You can download them from Nvidia's official site.
https://www.nvidia.c...aspx?lang=en-us

Then do the following.
Open up Steam --> go into Library --> right-click on GTA IV--> Select Properties --> Under the 'General' tab, you will see an option called 'Set launch options...' --> Click on that and copy/past these codes into it.

-nomemrestrict
-norestrictions
-novblank
-percentvidmem
-availablevidmem 10

After that click on 'OK' and close the box.

*You can edit the commands as per your preference.

 

Since it's a laptop, make sure the power option is set in "High Performance mode" or something similar to that while gaming.


prince_linus
  • prince_linus

    Player Hater

  • Members
  • Joined: 15 Mar 2016
  • Germany

#3

Posted 31 July 2016 - 10:43 PM

Hi, thanks for the answer - already figured that out by myself :)
Writing - availablevidmem 8000 - nomemrescrict and - norestrictions inside is enough.
Thanks anyway :)

However, now I'm struggling with another error:
After installing CryENB 3.o I'm getting that infinitive loading screen bug -
The unmodded game without the ENB works completely fine.
I haven't tried out any other mods - except for Script Hook and both ASI loader. Also, using Xlive instead of dsound or the other way around didn't help.

prince_linus
  • prince_linus

    Player Hater

  • Members
  • Joined: 15 Mar 2016
  • Germany

#4

Posted 31 July 2016 - 11:01 PM Edited by prince_linus, 31 July 2016 - 11:04 PM.

Alright. This is definitely becoming ridiculous. I fixed it doing some real primitive thing:
I went back to the Steam Launch Options and changed -availablevidmem 8000 to - availablevidmem 800.0

So, to summarize it:
To let GTA IV recognize your graphics card, go to Steam, right click the game, select properties and click on Select Launch Options
Now, write:
-availablevidmem x (find a suitable valuable)
-norestrictions
-nomemrescrict

Maybe -norestrictions and/or -nomemrescrict isn't necessary, but, however, it isn't a bad idea to add these as well

Then, if you're getting that infinitive loading screen error when using ENB, change the valuable from e. g. -availablevidmem 8000 to -availablevidmem 800.0
However, the only thing which seems to be important is to have any decimal in that number. 


Hitmare
  • Hitmare

    Player Hater

  • Members
  • Joined: 23 Dec 2014
  • Poland

#5

Posted 3 weeks ago Edited by Hitmare, 3 weeks ago.

I have the same issue on the 1.0.8.0 patch, but -avaiblevidmem doesn't go above 512mb of video memory

 

EDIT:

i think thats because the main gpu is the intel hd one which actually has 512mb of video memory, but the game is ran on the nvidia gpu by default (btw, i have the same gpu as prince_linus, and the laptop is a dell inspiron 15 7559 btw)





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users